[nsp] FW: Cisco IOS 11.2P -> 11.1CC migration plan

From: Jared Mauch (jared@iagnet.net)
Date: Tue Jun 02 1998 - 15:14:34 EDT


Subject: BOUNCE cisco-nsp@qual.net: Non-member submission from ["Jason Lixfeld" <jlixfeld@idirect.ca>]

From: "Jason Lixfeld" <jlixfeld@idirect.ca>
To: "Cisco-NSP" <cisco-nsp@iagnet.net>
Subject: FW: Cisco IOS 11.2P -> 11.1CC migration plan
Date: Tue, 2 Jun 1998 15:14:15 -0400
Message-ID: <000101bd8e5a$a1f068d0$0b5088cf@blackbox.idirect.com>

I'm currently running IOS 11.2(12.1)P on a 7206 and am seriously considering
moving to a CC train of 11.1. Probably 11.1(18)CC for the following
features:

CEF Switching (CAR QoS)
v5 NetFlow export

I will pose my questions more so about CEF and CAR in a separate email. For
now, I would like to know how much I'm going to shoot myself in the foot if
I try to drop my 11.2 config into an 11.1 box. I'm going to paste my config
here along with my hardware specs so if anyone sees something that won't
work or isn't supported by 11.1 from 11.2, please let me know incase I miss
something in my own research:

! Last configuration change at 11:59:32 EST Mon Jun 1 1998
! NVRAM config last updated at 21:31:12 EST Fri May 29 1998
!
version 11.2
no service finger
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname c7
!
enable secret 5 <secret>
enable password 7 <password>
!
ip subnet-zero
no ip source-route
ip flow-export 207.136.80.6 9995
ip rcmd rsh-enable
ip rcmd remote-host crsh 207.136.80.6 crsh
ip rcmd remote-username crsh
ip rcmd source-interface FastEthernet1/0
ip domain-name idirect.com
ip name-server 207.136.65.24
ip name-server 199.166.254.254
ip name-server 207.136.66.20
ip name-server 207.136.80.18
clock timezone EST -5
clock summer-time EST date Mar 20 1998 21:00 Oct 21 1998 21:00
!
interface Loopback1
 ip address 207.136.64.6 255.255.255.255
!
interface Loopback2
 ip address 207.136.64.5 255.255.255.255
 no ip route-cache
 no ip mroute-cache
!
interface Loopback3
 ip address 206.222.70.129 255.255.255.128
 no ip route-cache
 no ip mroute-cache
!
interface FastEthernet1/0
 description Core, Term Server & Proxy ISP Network
 ip address 199.166.254.9 255.255.255.0 secondary
 ip address 207.136.64.33 255.255.255.224 secondary
 ip address 192.168.80.254 255.255.255.0 secondary
 ip address 207.136.80.33 255.255.255.0
 no ip directed-broadcast
 ip route-cache same-interface
 ip route-cache optimum
 ip ospf priority 5
 no ip mroute-cache
 load-interval 30
 keepalive 0
 full-duplex
!
interface FastEthernet2/0
 description Toronto Internet Exchange
 ip address 192.168.191.9 255.255.255.252 secondary
 ip address 206.222.95.54 255.255.255.252 secondary
 ip address 207.136.64.66 255.255.255.252 secondary
 ip address 209.161.210.1 255.255.255.248
 ip access-group 197 in
 ip access-group 105 out
 no ip directed-broadcast
 ip route-cache same-interface
 ip route-cache flow
 no ip mroute-cache
 load-interval 30
 full-duplex
!
interface Hssi3/0
 description UUNet Canada HSSI
 ip address 205.150.206.66 255.255.255.252
 ip access-group 197 in
 ip access-group 105 out
 no ip directed-broadcast
 encapsulation ppp
 ip route-cache flow
 no ip mroute-cache
 load-interval 30
 no cdp enable
!
interface Ethernet4/0
 description Oshawa POP Office
 ip address 192.168.102.254 255.255.255.0 secondary
 ip address 207.136.102.1 255.255.255.192
 no ip directed-broadcast
 ip route-cache same-interface
 ip route-cache optimum
 no ip mroute-cache
 load-interval 30
 no cdp enable
!
interface Ethernet4/1
 description i*Star ISP Network TO BE 199.166.254.0/24
 no ip address
 no ip directed-broadcast
 ip route-cache optimum
 no ip mroute-cache
 load-interval 30
 shutdown
 no cdp enable
!
interface Ethernet4/2
 description Old TUCOWS Now lucid, cns1 ascd2 ISP Network
 ip address 207.136.66.17 255.255.255.240
 no ip directed-broadcast
 ip route-cache optimum
 no ip mroute-cache
 load-interval 30
 no cdp enable
!
interface Ethernet4/3
 description ISDN & Misc. ISP Network
 ip address 207.136.65.17 255.255.255.240
 no ip directed-broadcast
 ip route-cache optimum
 no ip mroute-cache
 load-interval 30
 no cdp enable
!
interface Ethernet4/4
 description Untrusted ISP Network
 ip address 207.136.65.33 255.255.255.240
 no ip directed-broadcast
 ip route-cache optimum
 no ip mroute-cache
 load-interval 30
 no cdp enable
!
interface Ethernet4/5
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no cdp enable
!
interface Ethernet4/6
 description Hamilton POP
 ip address 207.136.126.1 255.255.255.192
 no ip directed-broadcast
 ip route-cache optimum
 no ip mroute-cache
 load-interval 30
 no cdp enable
!
interface Ethernet4/7
 description NOC Microwave Network
 ip address 207.136.82.37 255.255.255.192
 no ip directed-broadcast
 ip route-cache optimum
 no ip mroute-cache
 load-interval 30
 no cdp enable
!
interface Ethernet5/0
 description Dedicated Customer ISP Network
 ip address 192.168.67.254 255.255.255.0 secondary
 ip address 207.136.67.1 255.255.255.0
 no ip directed-broadcast
 ip route-cache same-interface
 ip route-cache flow
 no ip mroute-cache
 load-interval 30
 no cdp enable
!
interface Ethernet5/1
 description TUCOWS Mirror Network
 ip address 207.136.66.1 255.255.255.240
 no ip directed-broadcast
 ip route-cache optimum
 no ip mroute-cache
 load-interval 30
 no cdp enable
!
interface Ethernet5/2
 description TUCOWS Web Network
 ip address 207.136.66.65 255.255.255.224
 no ip directed-broadcast
 ip route-cache optimum
 no ip mroute-cache
 load-interval 30
 no cdp enable
!
interface Ethernet5/3
 description counters TUCOWS Network
 ip address 207.136.66.33 255.255.255.224
 no ip directed-broadcast
 ip route-cache optimum
 no ip mroute-cache
 load-interval 30
 no cdp enable
!
interface Serial6/0
 description Head Office T1 Link
 ip address 207.136.65.209 255.255.255.252
 no ip directed-broadcast
 ip route-cache optimum
 no ip mroute-cache
 bandwidth 1536
!
interface Serial6/1
 description Colosseum T1 Line
 ip address 207.136.65.193 255.255.255.252
 no ip directed-broadcast
 ip route-cache optimum
 no ip mroute-cache
 bandwidth 1536
!
interface Serial6/2
 no ip address
 shutdown
!
interface Serial6/3
 no ip address
 shutdown
!
interface Async1
 no ip address
 no ip route-cache
 no ip mroute-cache
!
autonomous-system 7271
!
router ospf 100
 network 207.136.80.33 0.0.0.0 area 0
 network 207.136.65.208 0.0.0.3 area 0
 maximum-paths 2
 default-information originate
!
router bgp 7271
 no synchronization
! Abbreviated network statements for Inet-Access
 network 207.136.64.0 mask 255.255.192.0
 network 206.222.66.8 mask 255.255.255.252
 network 199.71.119.0
 network 205.207.146.0
 neighbor 199.45.118.2 remote-as 7271
 neighbor 199.45.118.2 filter-list 1 out
 neighbor 205.150.206.65 remote-as 816
 neighbor 205.150.206.65 soft-reconfiguration inbound
 neighbor 205.150.206.65 route-map UUNET in
 neighbor 205.150.206.65 route-map P out
 neighbor 205.150.206.65 filter-list 1 out
 neighbor 206.47.45.128 remote-as 3804
 neighbor 206.47.45.128 ebgp-multihop 4
 neighbor 206.47.45.128 update-source Loopback2
 neighbor 206.47.45.128 soft-reconfiguration inbound
 neighbor 206.47.45.128 route-map BGS in
 neighbor 206.47.45.128 filter-list 1 out
 neighbor 206.222.95.53 remote-as 6463
 neighbor 206.222.95.53 soft-reconfiguration inbound
 neighbor 206.222.95.53 route-map SPRINT in
 neighbor 206.222.95.53 route-map P out
 neighbor 206.222.95.53 filter-list 1 out
!
ip classless
! Abbreviated static table for Inet-Access
ip route 1.0.0.0 255.0.0.0 Null0
ip route 10.1.0.0 255.255.0.0 207.136.65.26
ip route 142.77.1.0 255.255.255.0 Hssi3/0
ip route 192.168.22.0 255.255.255.0 207.136.80.119
ip route 205.207.146.0 255.255.255.0 Null0 10
ip as-path access-list 1 permit ^$
ip as-path access-list 1 deny .*
ip as-path access-list 3 permit ^10151$
ip as-path access-list 100 permit _701_
ip as-path access-list 100 permit _816_
ip as-path access-list 100 permit _6463_
ip as-path access-list 100 permit _1239_
ip as-path access-list 100 permit _3602_
ip as-path access-list 100 permit _3561
ip as-path access-list 101 permit .*
ip as-path access-list 110 permit _3804_
ip as-path access-list 110 permit _577_
ip as-path access-list 110 permit _3561_
ip as-path access-list 110 permit _6463_
ip as-path access-list 110 permit _1239_
ip as-path access-list 110 permit _3602
ip as-path access-list 111 permit .*
ip as-path access-list 120 permit _3804_
ip as-path access-list 120 permit _577_
ip as-path access-list 120 permit _816_
ip as-path access-list 120 permit _701_
ip as-path access-list 121 permit .*
ip as-path access-list 122 permit .*
!
logging 207.136.80.14
access-list 34 permit 207.136.80.0 0.0.0.255
access-list 34 permit 207.136.103.128 0.0.0.15
access-list 99 permit 207.136.80.15
access-list 99 permit 207.136.80.11
access-list 99 permit 199.166.254.67
access-list 105 permit ip 198.235.156.0 0.0.0.255 any
access-list 105 permit ip 198.235.157.0 0.0.0.255 any
access-list 105 permit ip 198.235.158.0 0.0.0.255 any
access-list 105 permit ip 198.235.159.0 0.0.0.255 any
access-list 105 permit ip 199.71.119.0 0.0.0.255 any
access-list 105 permit ip 199.166.254.0 0.0.0.255 any
access-list 105 permit ip 204.225.106.0 0.0.0.255 any
access-list 105 permit ip 205.150.206.0 0.0.0.255 any
access-list 105 permit ip 205.233.93.0 0.0.0.255 any
access-list 105 permit ip 206.116.92.0 0.0.0.255 any
access-list 105 permit ip 206.130.178.0 0.0.0.255 any
access-list 105 permit ip 206.222.95.0 0.0.0.255 any
access-list 105 permit ip 207.81.52.0 0.0.0.255 any
access-list 105 permit ip 207.81.99.0 0.0.0.255 any
access-list 105 permit ip 207.136.64.0 0.0.63.255 any
access-list 105 permit ip 209.47.75.0 0.0.0.255 any
access-list 105 permit ip 209.161.192.0 0.0.63.255 any
access-list 105 deny ip any any log
access-list 197 permit ip 208.229.216.0 0.0.0.255 any
access-list 197 deny ip 10.0.0.0 0.255.255.255 any
access-list 197 deny ip 127.0.0.0 0.255.255.255 any
access-list 197 deny ip 172.16.0.0 0.15.255.255 any
access-list 197 permit ip 192.168.64.0 0.0.63.255 any
access-list 197 permit ip 192.168.191.0 0.0.0.255 207.136.80.0 0.0.0.255
access-list 197 permit ip 192.168.192.0 0.0.63.255 any
access-list 197 deny ip 192.168.0.0 0.0.255.255 any
access-list 197 deny ip any 0.0.0.255 255.255.255.0 log
access-list 197 deny ip any 0.0.0.0 255.255.255.0
access-list 197 deny ip host 255.255.255.255 any
access-list 197 deny tcp any 207.136.126.0 0.0.0.255 eq telnet log
access-list 197 deny tcp any 207.136.102.0 0.0.0.255 eq telnet log
access-list 197 deny tcp any 207.136.82.0 0.0.0.255 eq telnet log
access-list 197 permit tcp any host 207.136.80.35 eq telnet
access-list 197 permit tcp any host 207.136.80.38 eq telnet
access-list 197 permit tcp any host 207.136.80.61 eq telnet
access-list 197 permit tcp any host 207.136.80.98 eq telnet
access-list 197 permit tcp any host 207.136.80.132 eq telnet
access-list 197 permit tcp any host 207.136.80.133 eq telnet
access-list 197 permit tcp any host 207.136.80.136 eq telnet
access-list 197 deny tcp any 207.136.80.0 0.0.0.255 eq telnet log
access-list 197 deny tcp any host 207.136.66.26 eq telnet log
access-list 197 deny tcp any host 207.136.66.18 eq telnet log
access-list 197 deny tcp any host 207.136.65.19 eq telnet log
access-list 197 deny tcp any host 207.136.65.26 eq telnet log
access-list 197 deny tcp any host 207.136.65.27 eq telnet log
access-list 197 permit icmp any host 207.136.80.3
access-list 197 permit icmp any host 207.136.80.11
access-list 197 permit icmp any host 207.136.80.19
access-list 197 permit icmp any host 207.136.80.33
access-list 197 permit icmp any host 207.136.80.41
access-list 197 permit icmp any host 207.136.80.45
access-list 197 permit icmp any host 207.136.80.46
access-list 197 permit icmp any host 207.136.80.49
access-list 197 permit icmp any host 207.136.80.50
access-list 197 permit icmp any host 207.136.80.59
access-list 197 permit icmp any host 207.136.80.63
access-list 197 permit icmp any host 207.136.80.64
access-list 197 permit icmp any host 207.136.80.61
access-list 197 permit icmp any host 207.136.80.69
access-list 197 permit icmp 209.90.128.0 0.0.31.255 any log
access-list 197 deny icmp 209.47.145.0 0.0.0.255 any echo-reply log
access-list 197 deny icmp 147.226.205.0 0.0.0.255 any echo-reply log
access-list 197 deny icmp 209.47.146.0 0.0.0.255 any echo-reply log
access-list 197 deny icmp 38.0.0.0 0.255.255.255 any echo-reply log
access-list 197 deny icmp 199.71.188.0 0.0.0.255 any echo-reply log
access-list 197 deny icmp 204.186.0.0 0.0.255.255 any echo-reply log
access-list 197 deny icmp 205.179.19.0 0.0.0.255 any echo-reply log
access-list 197 deny icmp 206.49.34.0 0.0.4.255 any echo-reply log
access-list 197 deny icmp 205.150.64.0 0.0.0.255 any echo-reply log
access-list 197 deny icmp any 207.136.70.0 0.0.0.63 echo-reply log
access-list 197 deny icmp any 207.136.82.0 0.0.0.255 echo-reply log
access-list 197 deny icmp any 207.136.80.0 0.0.0.255 echo-reply log
access-list 197 deny icmp any 207.136.66.0 0.0.0.255 echo-reply log
access-list 197 deny icmp any 207.136.102.0 0.0.0.63 echo-reply log
access-list 197 deny icmp any 207.136.126.0 0.0.0.63 echo-reply log
access-list 197 deny udp any any eq snmp log
access-list 197 permit ip any any
!
priority-list 1 protocol ip high list 190
priority-list 1 protocol ip medium list 191
priority-list 1 protocol ip normal list 192
priority-list 1 default low
!
route-map P permit 10
 set as-path prepend 7271
!
route-map SPRINT permit 10
 match as-path 120
 set local-preference 30
!
route-map SPRINT permit 20
 match as-path 121
 set local-preference 60
!
route-map SPRINT permit 30
!
route-map BGS permit 10
 match as-path 100
 set local-preference 50
!
route-map BGS permit 20
 match as-path 101
 set local-preference 60
!
route-map BGS permit 30
!
route-map UUNET permit 10
 match as-path 110
 set local-preference 40
!
route-map UUNET permit 20
 match as-path 111
 set local-preference 60
!
route-map UUNET permit 30
!
snmp-server community public RO 99
snmp-server location Toronto, Canada
snmp-server contact Jason Lixfeld jlixfeld@idirect.ca +1 416 236-5806 ext.
18
!
line con 0
line aux 0
line vty 0 4
 access-class 34 in
 password 7 <password>
 login
!
ntp clock-period 17183471
ntp update-calendar
ntp peer 207.136.80.9 prefer
end

Thanks in Advance!

--
Regards,

Jason A. Lixfeld

Network Engineer, iDirect Network Operations

------------------------------------------------------------------------- TUCOWS Interactive Ltd. o/a | "A Different Kind of Internet Company" Internet Direct Canada Inc. | "FREE BANDWIDTH for Toronto Area IAPs" 5415 Dundas Street West | http://www.torontointernetxchange.net Suite 301, Toronto Ontario | (416) 236-5806 (T) M9B-1B5 CANADA | (416) 236-5804 (F) ------------------------------------------------------------------------- mailto:jlixfeld@idirect.ca | mailto:jlixfeld@torontointernetxchange.net -------------------------------------------------------------------------

 



This archive was generated by hypermail 2b29 : Sun Aug 04 2002 - 04:13:14 EDT