Re: [j-nsp] BGP-OSPF route redistribution

From: Kisito Nguene (knguene@hotmail.com)
Date: Mon Jun 11 2001 - 10:53:01 EDT


Markolf,

1- You need to define a policy to export OSPF routes to BGP.

# set policy-options policy-statement ospf-to-bgp term a from protocol ospf
# set policy-options policy-statement ospf-to-bgp term a then accept
# set policy-options policy-statement ospf-to-bgp term b then reject

2- ... apply this export policy to BGP

# set protocols bgp group 52-72 export ospf-to-bgp

3- Commit changes
# commit

4- Verify
# run show route advertising-protocol bgp 192.168.201.225

You should see your OSPF routes being exported to the BGP peer

Hope this helps.

- Kisito

----- Original Message -----
From: <eedmgu@eed.ericsson.se>
To: <juniper-nsp@puck.nether.net>
Sent: Monday, June 11, 2001 4:26 PM
Subject: [j-nsp] BGP-OSPF route redistribution

> Hi,
>
> I'm new to Juniper routers, so please forgive me if this is a FAQ (I
> couldn't find anything in the digest):
>
> I'm trying to set up an M40 to redistribute routes from OSPF to BGP,
> exchanging with a Cisco 7507. The M40 sees the routes from the Cisco just
> fine, but the Cisco doesn't receive anything. Is there anything I need
> to do to emulate the Cisco "redistribute ospf <...>" statement?
>
> The relevant bits of the configs are below. Thanks in advance for any
> help!
>
> - Markolf
>
> *** Cisco:
>
> interface ATM1/0/0.8 point-to-point
> ip address 192.168.201.225 255.255.255.252
> pvc 100/38
> vbr-nrt 103515 51757 10000
> encapsulation aal5snap
> !
> router bgp 65500
> bgp log-neighbor-changes
> redistribute ospf 100
> [neighbours...]
> neighbor 192.168.201.226 remote-as 64000
> no auto-summary
> !
>
> *** Juniper:
>
> interfaces {
> at-1/0/0 {
> unit 0 {
> encapsulation atm-snap;
> vci 100.38;
> family inet {
> address 192.168.201.226/30;
> }
> }
> }
> fe-6/0/0 {
> unit 0 {
> family inet {
> address 10.0.24.253/24;
> }
> }
> }
> }
> protocols {
> bgp {
> log-updown;
> group 52-72 {
> type external;
> peer-as 65500;
> neighbor 192.168.201.225;
> }
> }
> ospf {
> area 0.0.0.0 {
> interface fe-6/0/0.0;
> interface at-1/0/0.0;
> }
> }
> }
>
>
>



This archive was generated by hypermail 2b29 : Mon Aug 05 2002 - 10:42:42 EDT