[nsp] BGP issues after upgrading IOS versions

sthaug at nethelp.no sthaug at nethelp.no
Tue Aug 26 01:46:06 EDT 2003

> In hopes of curing this we tried to upgrade the IOS over the weekend.
> We have tried 12.0(25)S1 and 12.2(18)S.  In both cases, everything
> looked like it worked with one exception.  We could not reach anywhere
> outside our network.
> With 12.0(25)S1, we received the full BGP routes from both providers,
> but simply couldn't go anywhere.  One provider told us they were not
> seeing any advertisements from us.  On reverting to the old IOS, we
> suffered the same symptoms until we copied the original config off tftp
> into the running config.  Ten seconds or less after that, we had full
> external connectivity.  The diff between the non-working and working
> configs showed no access-list, route-map, or router BGP changes.

We have 12.0(25)S1 in production on various routers, and it seems to
do the job for us. Some increase in memory consumption compared to

> With 12.2(18)S, the BGP sessions kept dieing with "out of memory"
> errors.  The router has 155MB according to "sho ver".

We found in our lab testing that 12.2(18)S has significantly higher
memory consumption (around 20 MB in our case) than 12.2(14)S. A lot of
this is probably used by the "warm reload" feature of 12.2(18)S.

Steinar Haug, Nethelp consulting, sthaug at nethelp.no

More information about the cisco-nsp mailing list