[nsp] BGP issues after upgrading IOS versions

Stephen J. Wilcox steve at telecomplete.co.uk
Tue Aug 26 00:35:12 EDT 2003

On Mon, 25 Aug 2003, Scott Lambert wrote:

> In hopes of curing this we tried to upgrade the IOS over the weekend.
> We have tried 12.0(25)S1 and 12.2(18)S.  In both cases, everything
> looked like it worked with one exception.  We could not reach anywhere
> outside our network.

There was a BGP bug, not sure what versions .. do sh ip bgp <your pfx> on your 
router and if you see a "r" next to the prefix indicating rib failure then thats 
your problem. workaround for affected ioses is to inject the route locally with 
a network comman in the bgp process on that router.

> With 12.2(18)S, the BGP sessions kept dieing with "out of memory"
> errors.  The router has 155MB according to "sho ver".

Whats your total? I would expect to see more.. you need 256Mb minimum if you're 
going to run full tables on a 7206.. I'm thinking you perhaps only have 192Mb.. 
whats sh mem sum telling you?


More information about the cisco-nsp mailing list