[nsp] c2511 Async line problem
Luis Azevedo
LCarlos at ptinovacao.pt
Mon Feb 3 21:13:04 EST 2003
Hi,
We have 8 x C2511 used as a comm servers. The Async line from "show line"
output shows a lot of noise and overruns:
2511_d#sh line
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns
* 0 CTY - - - - - 0 0 0/0
1 TTY 115200/115200 - inout - - - 0 1970 637/0
2 TTY 115200/115200 - inout - - - 0 0 0/0
3 TTY 115200/115200 - inout - - - 0 0 0/0
4 TTY 115200/115200 - inout - - - 0 0 0/0
5 TTY 115200/115200 - inout - - - 0 0 0/0
6 TTY 115200/115200 - inout - - - 0 394 102/0
7 TTY 115200/115200 - inout - - - 0 0 0/0
8 TTY 115200/115200 - inout - - - 0 0 0/0
9 TTY 115200/115200 - inout - - - 0 0 0/0
10 TTY 115200/115200 - inout - - - 0 0 0/0
11 TTY 115200/115200 - inout - - - 0 0 0/0
12 TTY 115200/115200 - inout - - - 0 1367 467/0
13 TTY 115200/115200 - inout - - - 0 0 0/0
14 TTY 115200/115200 - inout - - - 0 0 0/0
15 TTY 115200/115200 - inout - - - 0 0 0/0
16 TTY 115200/115200 - inout - - - 0 0 0/0
17 AUX 9600/9600 - - 1 - 1 0 0 0/0
18 VTY - - - - 20 0 0 0/0
19 VTY - - - - 20 0 0 0/0
20 VTY - - - - 20 0 0 0/0
21 VTY - - - - 20 0 0 0/0
This seems to be the cause for the connection problems:
01:48:41: Async12: Setup PPP framing on TTY12
01:48:41: As12 PPP: Async Protocol Mode started for 0.0.0.0
01:48:41: As12 AAA/ACCT: Using PPP accounting list ""
01:48:41: As12 PPP: Processed packet cached during autoselect
01:48:41: APPP12: CRC error
01:48:43: %LINK-3-UPDOWN: Interface Async12, changed state to up
01:48:43: As12 PPP: Treating connection as a dedicated line
01:48:43: As12 PPP: Phase is ESTABLISHING, Active Open
01:48:43: As12 LCP: O CONFREQ [Closed] id 59 len 24
01:48:43: As12 LCP: ACCM 0x000A0000 (0x0206000A0000)
01:48:43: As12 LCP: AuthProto PAP (0x0304C023)
01:48:43: As12 LCP: MagicNumber 0x006FC4E3 (0x0506006FC4E3)
01:48:43: As12 LCP: PFC (0x0702)
01:48:43: As12 LCP: ACFC (0x0802)
01:48:43: APPP12: Output packet, len = 28, header = FF 3 C0 21
01:48:43: APPP12: CRC error
01:48:46: As12 LCP: TIMEout: Time 0x6390C8 State REQsent
01:48:46: As12 LCP: O CONFREQ [REQsent] id 60 len 24
01:48:46: As12 LCP: ACCM 0x000A0000 (0x0206000A0000)
01:48:46: As12 LCP: AuthProto PAP (0x0304C023)
01:48:46: As12 LCP: MagicNumber 0x006FC4E3 (0x0506006FC4E3)
01:48:46: As12 LCP: PFC (0x0702)
01:48:46: As12 LCP: ACFC (0x0802)
01:48:46: APPP12: Output packet, len = 28, header = FF 3 C0 21
01:48:46: APPP12: CRC error
01:48:48: As12 LCP: TIMEout: Time 0x639C7C State REQsent
01:48:48: As12 LCP: O CONFREQ [REQsent] id 61 len 24
01:48:48: As12 LCP: ACCM 0x000A0000 (0x0206000A0000)
01:48:48: As12 LCP: AuthProto PAP (0x0304C023)
The PPP messages never reach the other end of the link... The client PC
keeps also sending and resending the 1st PPP negotiation message...
We have replaced cables but this does not solve the problem.
Is there any command we can try under the async configuration to solve the
problem?
Thank you for your help in advance.
This is our present configuration:
2511_d#sh conf
sh conf
Using 1591 out of 32762 bytes
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 2511_d
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default radius local
aaa accounting network default wait-start radius
enable secret 5 $1$xxxxxxxxxxxxx$
!
username xxxxxxxxxxxx password 7 xxxxxxxxxxxxxxxx
username xxxxxxxxx password 7 xxxxxxxxxx
ip subnet-zero
no ip source-route
no ip finger
async-bootp dns-server xxxxxxxxxx
!
!
!
interface Ethernet0
ip address 10.0.14.251 255.255.255.0
!
interface Serial0
no ip address
no ip mroute-cache
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Group-Async1
ip unnumbered Ethernet0
encapsulation ppp
keepalive 60
async mode dedicated
no snmp trap link-status
peer default ip address pool local1
no cdp enable
ppp authentication pap
group-range 1 16
!
ip local pool local1 10.0.14.49 10.0.14.63
ip default-gateway 10.0.14.254
ip classless
!
access-list 20 permit 10.0.14.241 log
radius-server host 10.0.14.241 auth-port 1812 acct-port 1813
radius-server key xxxxxxxxx
!
line con 0
exec-timeout 0 0
password 7 xxxxxxxxxxxxxxx
line 1 16
session-timeout 15
exec-timeout 0 10
password 7 xxxxxxxxxxxxxxxx
modem InOut
transport preferred none
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
access-class 1 in
no exec
rotary 1
transport preferred none
transport input all
line vty 0 4
access-class 20 in
password 7 xxxxxxxxxxxxxxxxxxxxxxx
transport preferred none
!
end
Thanks,
Luis Azevedo
Segurança de Redes e Serviços
Tecnologias da Sociedade da Informação
Portugal Telecom Inovação, S.A.
R. José Ferreira Pinto Basto - 3810 Aveiro, PT
Tel. +351234403311
Mov +351962603289
Fax +351234420722
More information about the cisco-nsp
mailing list