[nsp] gre tunnel using loopback for source

Joshua Sahala joshua.ej.smith at usa.net
Mon Jun 2 17:51:35 EDT 2003


hello all,

i was wondering if it is possible to get a gre tunnel to work using
a loopback for the tunnel source.  i have three interfaces (traffic
is moved from one to another by local preference) that could 
potentially be the active interface, so i am trying to get a tunnel
that will stay up if i move the traffic off the interface.
bgp will come up, and addresses in lan2 can ping my router, but not
any devices in lan 1, and lan1 devices cannot ping the r2 loopback,
or any lan2 devices


lan1
 |
r1
 |
r2
 |
lan2

r1 config:
interface Tunnel17
 description connected_to_test
 ip unnumbered Loopback19
 no ip directed-broadcast
 ip mtu 1580
 tunnel source 192.168.1.194
 tunnel destination 10.10.1.42

interface Loopback19
 ip address 192.168.1.194 255.255.255.255
 no ip redirects
 no ip unreachables
 no ip directed-broadcast
 no ip proxy-arp

router bgp 65056
network 192.168.1.0 mask 255.255.255.0
neigh 172.16.16.1 remote as 65145

ip route 172.16.16.1 255.255.255.255 tun17


r2 config

interface Tunnel1
 description connected_to_test
 ip unnumbered Loopback9
 no ip directed-broadcast
 ip mtu 1580
 tunnel source 10.10.1.42
 tunnel destination 192.168.1.194

interface Loopback9
 ip address 172.16.16.1 255.255.255.255
 no ip redirects
 no ip unreachables
 no ip directed-broadcast
 no ip proxy-arp

router bgp 65145
network 172.16.16.0 255.255.255.0
neigh 192.168.1.194 remote as 65056

ip route 192.168.1.194 255.255.255.255 tun1
ip route 192.168.1.19 255.255.255.255 fas1/1

int fas1/1
ip address 10.10.1.42 255.255.255.252

thanks

/joshua


"Walk with me through the Universe,
 And along the way see how all of us are Connected.
 Feast the eyes of your Soul,
 On the Love that abounds.
 In all places at once, seemingly endless,
 Like your own existence."
     - Stephen Hawking -





More information about the cisco-nsp mailing list