[nsp] nat question
Roger
grunky at rockriver.net
Wed May 19 21:52:10 EDT 2004
I'd like to be able to forward all ports/protocols to an internal
address based upon source ip.
Example:
I need to forwarded all ports/protocols to 192.168.0.100, reachable by
ther routers interface eth0, if it coming from a perticular external ip
interface Ethernet0
ip address 192.168.0.100 255.255.255.0
ip nat inside
!
interface Ethernet1
ip address dhcp
ip nat outside
!
ip nat inside source list nat_acl interface Ethernet1 overload
ip access-list standard nat_acl
permit 192.168.0.0 0.0.0.255
Now I can forward individual ports like so
ip nat inside source static tcp 192.168.0.11 1723 interface Ethernet1 1723
The problem is I'd like to be able to do this
if source ip = x.x.x.x then forward to 192.168.0.100
and putting in a bunch of individual forwards just won't do.
I also have only 1 ip - so I can't do 1 to 1 nat like so
ip nat inside source static 192.168.0.100 <external_ip> extendable
I'm thinking my only choice will be to run a vpn from 192.168.0.100 to
the external ip in question.
Suggestions?
--
Rock River Internet Roger Grunkemeyer
202 W. State St, 8th Floor grunky at rockriver.net
Rockford, IL 61101 815-968-9888 x102
More information about the cisco-nsp
mailing list