[c-nsp] Multiple Static Routes on Cisco

Rodney Dunn rodunn at cisco.com
Tue Nov 30 09:03:39 EST 2004


So you have:

Router -- subint1
       -- subint2

You have traffic coming in destined for what ip addresses?

I'm not a voice expert but I'm guessing you are saying
the traffic is destined to an ip address on the router
since it's voice and the traffic doesn't go out the LAN.

Let's say you have two IP's out on the internet sending
you traffic (1.1.1.1 and 2.2.2.1).

You want traffic coming in subint1 that has a src
of 1.1.1.1 to go back out subint1 and traffic that
has a src of 2.2.2.1 to go back out subint2.
You should be able to do that with PBR.

However, what I'm not sure about is the feature order
processing when the traffic is handed to/from the DSP's.

See, it's not the traffic coming in the ATM's that
you want to change it's the egress traffic going back.

I wonder if that traffic is considered locally generated.
If so you could try doing:

ip local policy route-map trafficout


route-map trafficout permit 10
 match ACL based on src A
 set interface subint1
route-map trafficout permit 20
 match ACL based on src B
 set interface subint2


Rodney


On Tue, Nov 30, 2004 at 12:07:00PM +0500, Saad wrote:
> I'll tell again what I want. I have one ATM interface right now because I took the other out as it wasnt doing anything
> in my scenario right now. My voice traffic comes in from 3 IP's to the ATM interface and then goes back through the
> same interface. As I mentiones earlier it is voice termination so no data/traffic goes to the LAN interface.
> The bandwidth on this ATM interface is choked. What I want to do is to utilize the other interface and define the
> traffic from one IP to come in and go back from one interface and the traffic from other 2 IP's should be going through
> the other ATM interface. I am trying to do load sharing in a way using static routes or PBR because I cant run any
> routing protocol as we are connected to the ISP and it doesnt run protocol.
> 
> 
> Saad
> 
> 
> Rodney Dunn wrote:
> 
> > I guess I'm missing what you want to do.
> >
> > In this configuration you only have one PVC
> > configured with a default pointing to it
> > so all traffic that doesn't have a more specific
> > route will take that path.
> >
> > If all of your voice traffic is between the
> > same couple of ip addresses then when two
> > paths are there it's possible we are hashing
> > to the same path.  If so there isn't anything
> > that can be done fo change that other than
> > doing MLPPP.
> >
> > Rodney
> >
> > On Mon, Nov 29, 2004 at 11:40:38PM +0500, Saad wrote:
> > > Hi,
> > >
> > >
> > >
> > > Here's what you asked for. I hope this is enough. Let me know if you need anything else.
> > >
> > >
> > > Router#clear counter
> > > Clear "show interface" counters on all interfaces [confirm]
> > > Router#clear ip cache
> > > Router#sh int stat
> > > ATM2/0
> > >           Switching path    Pkts In   Chars In   Pkts Out  Chars Out
> > >                Processor         67       6813         74       8557
> > >              Route cache        911      99944       2370     160631
> > >                    Total        978     106757       2444     169188
> > > FastEthernet2/0
> > >           Switching path    Pkts In   Chars In   Pkts Out  Chars Out
> > >                Processor          0          0          0          0
> > >              Route cache          0          0          0          0
> > >                    Total          0          0          0          0
> > > Router#sh int stat
> > > ATM2/0
> > >           Switching path    Pkts In   Chars In   Pkts Out  Chars Out
> > >                Processor        179      19044        189      26755
> > >              Route cache       3933     430520       8751     593406
> > >                    Total       4112     449564       8940     620161
> > > FastEthernet2/0
> > >           Switching path    Pkts In   Chars In   Pkts Out  Chars Out
> > >                Processor          0          0          4        240
> > >              Route cache          0          0          0          0
> > >                    Total          0          0          4        240
> > > Router#sh ip cache
> > > IP routing cache 1 entry, 172 bytes
> > >    247 adds, 246 invalidates, 0 refcounts
> > > Minimum invalidation interval 2 seconds, maximum interval 5 seconds,
> > >    quiet interval 3 seconds, threshold 0 requests
> > > Invalidation rate 0 in last second, 0 in last 3 seconds
> > > Last full cache invalidation occurred 00:00:45 ago
> > >
> > > Prefix/Length           Age       Interface       Next Hop
> > > 213.228.199.0/24        00:00:45  ATM2/0.1        213.228.199.50
> > >
> > > Router#sh ip route
> > > Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
> > >        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> > >        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> > >        E1 - OSPF external type 1, E2 - OSPF external type 2
> > >        i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
> > >        ia - IS-IS inter area, * - candidate default, U - per-user static route
> > >        o - ODR, P - periodic downloaded static route
> > >
> > > Gateway of last resort is 0.0.0.0 to network 0.0.0.0
> > >
> > >      80.0.0.0/24 is subnetted, 1 subnets
> > > C       80.32.170.0 is directly connected, ATM2/0.1
> > > C    192.168.1.0/24 is directly connected, FastEthernet2/0
> > > S*   0.0.0.0/0 is directly connected, ATM2/0.1
> > > Router#sh ip route 0.0.0.0
> > > Routing entry for 0.0.0.0/0, supernet
> > >   Known via "static", distance 1, metric 0 (connected), candidate default path
> > >   Routing Descriptor Blocks:
> > >   * directly connected, via ATM2/0.1
> > >       Route metric is 0, traffic share count is 1
> > >
> > > Router#sh run
> > > Building configuration...
> > >
> > > Current configuration : 3176 bytes
> > > !
> > > ! Last configuration change at 16:08:45 spain Mon Nov 29 2004 by admin
> > > ! NVRAM config last updated at 16:09:34 spain Mon Nov 29 2004 by admin
> > > !
> > > version 12.3
> > > service timestamps debug uptime
> > > service timestamps log datetime msec localtime
> > > service password-encryption
> > > !
> > > hostname Router
> > > !
> > > boot-start-marker
> > > boot-end-marker
> > > !
> > > enable secret 5 123456
> > > clock timezone spain 1
> > > voice-card 1
> > > !
> > > !
> > > !
> > > !
> > > !
> > > voice call send-alert
> > > !
> > > !
> > > !
> > > !
> > > controller E1 1/0
> > >  ds0-group 0 timeslots 1-15,17-31 type r2-digital dtmf dnis
> > >  ds0 busyout 1-15,17-31 hard
> > > !
> > > controller E1 1/1
> > >  ds0-group 0 timeslots 1-15,17-31 type r2-digital dtmf dnis
> > > !
> > > !
> > > !
> > > interface ATM2/0
> > >  no ip address
> > >  no atm ilmi-keepalive
> > >  dsl operating-mode auto
> > > !
> > > interface ATM2/0.1 point-to-point
> > >  bandwidth 512
> > >  ip address 80.32.170.82 255.255.255.0
> > >  pvc 8/32
> > >   encapsulation aal5snap
> > >  !
> > > !
> > > interface FastEthernet2/0
> > >  ip address 192.168.1.2 255.255.255.0
> > >  duplex auto
> > >  speed auto
> > > !
> > > no ip http server
> > > !
> > > ip classless
> > > ip route 0.0.0.0 0.0.0.0 ATM2/0.1
> > > !
> > > !
> > > snmp-server community spn RO
> > > snmp-server enable traps tty
> > > !
> > > !
> > > control-plane
> > > !
> > > !
> > > !
> > > voice-port 1/0:0
> > >  timeouts initial 1
> > > !
> > > voice-port 1/1:0
> > >  timeouts initial 1
> > > !
> > > !
> > > !
> > > !
> > > dial-peer cor custom
> > > !
> > > !
> > > !
> > > dial-peer voice 1 pots
> > >  destination-pattern 45#34T
> > >  port 1/1:0
> > >  prefix ,,,
> > > !
> > > !
> > > alias exec ac show call active voice brief
> > > alias exec av show voice call summary
> > > alias exec as show voice call status
> > > !
> > > line con 0
> > > line aux 0
> > > line vty 0 4
> > >  password 7 082A4D5C081A0D1E
> > > !
> > > !
> > > end
> > >
> > > Router#
> > >
> > >
> > >
> > > Rodney Dunn wrote:
> > >
> > > > Do:
> > > >
> > > > clear counters
> > > > clear ip cache
> > > >
> > > > Then get:
> > > >
> > > > sh int stat
> > > >
> > > > wait 30 seconds
> > > >
> > > > sh int stat
> > > > sh ip cache
> > > >
> > > > Then get:
> > > > sh ip route
> > > > sh ip route 0.0.0.0
> > > > sh run
> > > >
> > > > And provide that information.
> > > >
> > > > Rodney
> > > >
> > > > On Mon, Nov 22, 2004 at 04:58:07PM +0500, Saad wrote:
> > > > >
> > > > >
> > > > > I tried CEF by giving default route 0.0.0.0  0.0.0.0  to both the
> > > > > interfaces and then enabling per-packet load-sharing but it didnt work.
> > > > > Only one interface is accessable whose route is first in the list. Am I
> > > > > missing something?
> > > > > I also tried Policy based routing but everytime I tried it in past also
> > > > > I am unable to give the appropriate commands. As this is destination
> > > > > based so its trciky. If I can have a practical scenario config example
> > > > > then it would be better. I have the whole documentation but can you send
> > > > > me the exact commands I require. I am confused about giving the next-hop
> > > > > IP or interface. Please help me out here.
> > > > >
> > > > >
> > > > > Saad
> > > > >
> > > > >
> > > > > Sarkis Karagozian wrote:
> > > > >
> > > > > > HI Saad,
> > > > > >
> > > > > > Here is What you can do on your Cisco router try the Per packet
> > > > > >
> > > > > > > load-balancing method. with CEF enabled 1st.
> > > > > >
> > > > > >
> > > > > > ttp://cisco.com/en/US/products/sw/iosswrel/ps1831/products_configuration_guide_chapter09186a00800ca6ca.html
> > > > > >
> > > > > > > Just make sure that your router processor can handle CEF, as it is
> > > > > >
> > > > > > > Processor intensive....
> > > > > >
> > > > > > Sarkis Karagozian
> > > > > >
> > > > > > -----Original Message-----
> > > > > > From: cisco-nsp-bounces at puck.nether.net
> > > > > > [mailto:cisco-nsp-bounces at puck.nether.net] On Behalf Of Brian Feeny
> > > > > > Sent: Saturday, November 20, 2004 6:47 AM
> > > > > > To: Saad
> > > > > > Cc: cisco-nsp at puck.nether.net
> > > > > > Subject: Re: [c-nsp] Multiple Static Routes on Cisco
> > > > > >
> > > > > > Saad,
> > > > > >
> > > > > > Default route CAN be used in that scenerio.  Yes if you have 2 ADSL
> > > > > >
> > > > > > cards,
> > > > > >
> > > > > > you probably would have 2 IP addresses.  However, you can do a default
> > > > > >
> > > > > > route over multiple interfaces.  You can use CEF per-session or
> > > > > >
> > > > > > per-packet
> > > > > >
> > > > > > load sharing as well.
> > > > > >
> > > > > > Brian
> > > > > >
> > > > > > On Nov 20, 2004, at 2:22 AM, Saad wrote:
> > > > > >
> > > > > > > Hi,
> > > > > >
> > > > > > >
> > > > > >
> > > > > > >
> > > > > >
> > > > > > > I have a Cisco 3640 router with internet connectivity using
> > > > > > WIC-1ADSL
> > > > > >
> > > > > > > card. There is no LAN connected to the router and no traffic
> > > > > > orignating
> > > > > >
> > > > > > > from the router because we have a voice termination setup. Voice
> > > > > >
> > > > > > > traffic
> > > > > >
> > > > > > > comes in from 3 IP's. I have a default route to the ATM0 interface
> > > > > > on
> > > > > >
> > > > > > > router. What I want is to add another WIC-1ADSL card on the router
> > > > > > to
> > > > > >
> > > > > > > increase the bandwidth. Default route can not be used in that
> > > > > > scenario
> > > > > >
> > > > > > > because we'll have 2 IP's assigned to the router. I want complete
> > > > > > step
> > > > > >
> > > > > > > by step configuration of static routes on the Cisco so that the
> > > > > > traffic
> > > > > >
> > > > > > > coming in from one IP goes through ATM0 interface and the traffic
> > > > > > from
> > > > > >
> > > > > > > other 2 IP's passes through the ATM1 interface.
> > > > > >
> > > > > > >
> > > > > >
> > > > > > >
> > > > > >
> > > > > > > Saad
> > > > > >
> > > > > > >
> > > > > >
> > > > > > >
> > > > > >
> > > > > > > _______________________________________________
> > > > > >
> > > > > > > cisco-nsp mailing list  cisco-nsp at puck.nether.net
> > > > > >
> > > > > > > https://puck.nether.net/mailman/listinfo/cisco-nsp
> > > > > >
> > > > > > > archive at http://puck.nether.net/pipermail/cisco-nsp/
> > > > > >
> > > > > > >
> > > > > >
> > > > > > ---------------------------------------------
> > > > > >
> > > > > > Brian Feeny, CCIE #8036, CISSP
> > > > > >
> > > > > > Network Engineer
> > > > > >
> > > > > > ShreveNet Inc.
> > > > > >
> > > > > _______________________________________________
> > > > > cisco-nsp mailing list  cisco-nsp at puck.nether.net
> > > > > https://puck.nether.net/mailman/listinfo/cisco-nsp
> > > > > archive at http://puck.nether.net/pipermail/cisco-nsp/
> 


More information about the cisco-nsp mailing list