[c-nsp] Link aggregation/EtherChannel between Cat and Foundry

David J. Hughes bambi at Hughes.com.au
Thu Jul 28 20:02:13 EDT 2005




On 29/07/2005, at 2:20 AM, Dave Temkin wrote:

> Anyone have a sample working config of the connection?
>
> First time attempting this and it's not working dynamically but would
> rather not force it if at all possible (bad experiences in the past).
>

Yup, have it running in production.  The only problem is the general 
lack of reliability of the foundry devices.  Other than that it works 
OK.  One thing to note is that, on certain IronCore platforms, the 
combination of etherchannel and Dot1Q trunking (running as a one-armed 
router) breaks certain types of traffic.  Anyway, configs below.

----
Cisco end on 6500

interface GigabitEthernet6/5
  description csw1.bne eth 1 - portchannel
  load-interval 30
  switchport
  switchport trunk encapsulation dot1q
  switchport trunk allowed vlan 1,10,15,27,97,100,137,178,259,999
  switchport mode trunk
  spanning-tree portfast trunk
  channel-group 10 mode on
!
interface GigabitEthernet6/6
  description csw1.bne eth 2 - portchannel
  load-interval 30
  switchport
  switchport trunk encapsulation dot1q
  switchport trunk allowed vlan 1,10,15,27,97,100,137,178,259,999
  switchport mode trunk
  spanning-tree portfast trunk
  channel-group 10 mode on
!
interface Port-channel10
  description csw1.bne
  switchport
  switchport trunk encapsulation dot1q
  switchport trunk allowed vlan 1,10,15,27,97,100,137,178,259,999
  switchport mode trunk
end

----
Foundry SI-100 end

trunk server ethe 3/1 to 3/2
!
vlan 999 by port
  tagged ethe 3/1 to 3/2
  router-interface ve 1
!
vlan 178 by port
  tagged ethe 3/1 to 3/2
  router-interface ve 3
!
vlan 10 by port
  tagged ethe 3/1 to 3/2
  router-interface ve 10
!
vlan 100 by port
  tagged ethe 3/1 to 3/2
  router-interface ve 4
--- etc, etc etc
----


Note that "trunk server" will give you port aggregation.  Last time I 
tested, using "trunk switch" gave you a backup layer2 path, not link 
aggregation (i.e. one link or the other, not both at the same time).


David
...



More information about the cisco-nsp mailing list