[c-nsp] dot1q question

Tom Sands tsands at rackspace.com
Sun Apr 9 12:50:08 EDT 2006


The problem is likely between the 7204 and the 2950, so I would start 
there.  The connection from the 2950 to the 3550 is fairly simple, 
switch to switch, dot1q, default native vlan 1, speed/duplex set, etc..

If you can take another IP out of the vlan 50 /29, I would create a vlan 
interface on the 2950 to test between the 3 points. (realize you can 
only have 1 active IP interface on the 2950 at a time, so if you have 
another management interface on it, then it will shutdown automatically)

--2950

conf t
interface vlan 50
ip address x.x.x.b 255.255.255.248
no shutdown

-------
7204 = x.x.x.a 255.255.255.248
3550 = x.x.x.c 255.255.255.249


Based on your setup, the 2950 should be able to ping the 3550 already.

If so, try pinging 2950 to 7204.  If this fails it could be a tagging 
issue.  Assuming that vlan 50 is the only sub-interface/VLAN on the 
7204. I would try setting the native VLAN on the 2950 next. Not knowing 
how many VLANs you have on the 2950, I would also recommend performing 
manual pruning on it's trunk links like you did on the 3550.


conf t
interface g0/1
switchport trunk native vlan 50


After setting the native VLAN to 50 on the 2950 trunk to the 7204, try 
pinging again.





Frank Kempermann wrote:

> I currently have a Cisco 7204 connected with a Catalyst 2924 per trunk. On
> another port of the 2924 a 100FETH WAN route is connected. This secondary
> location is connected through a trunk and a VLAN (ISL).
> 
> I now wanted to exchange the Catalyst 2924 with a 2950, which supports dot1q
> only. Besides that the FETH trunk should be exchanged with a GETH trunk in
> the 7204.
> 
> I tried out many possibilities; using the following ISL-setup with a
> 7204FETH and a 2924 everything runs fine, but using dot1q it doesn't work,
> where could be my error? I cannot reach the respective IP's from the 7204 to
> the 3550, which is working when using ISL.
> 
> Do I have to do something with the VTP of the two switches? When using ISL
> this doesn't matter. Is something missing in the configuration?
> 
> I planned the following:
> 
> C7204 i/o GE ---trunk---2950GETH----WAN-FETH(Trunk)----C3550-LAN-FETH
> 
> C7204
> 
> I
> 
> I
> 
> interface Gigabitethernet 0/0.50
> 
> encapsulation dot1q 50
> 
> ip address x.x.x.x 255.255.255.248
> 
> I
> 
> I
> 
> C2950
> 
> I
> 
> I
> 
> interface GigabitEthernet0/1
> 
> switchport mode trunk
> 
> vlan database
> 
> vlan 50 name blabla
> 
> apply
> 
> interface FastEthernet0/23
> 
> switchport mode trunk
> 
> no ip address
> 
> duplex full
> 
> speed 100
> 
> I
> 
> I
> 
> C3550
> 
> I
> 
> interface FastEthernet0/13
> 
> description Uplink blabla
> 
> switchport trunk encapsulation dot1q
> 
> switchport trunk allowed vlan 1,50,1002-1005
> 
> switchport mode trunk
> 
> speed 100
> 
> duplex full
> 
> interface Vlan50
> 
> ip address x.x.x.x 255.255.255.248
> 
>  
> 
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
> 

-- 
------------------------------------------------------
Tom Sands			  				
Chief Network Engineer				
Rackspace Managed Hosting	    	
(210)447-4065		   	
------------------------------------------------------


More information about the cisco-nsp mailing list