[c-nsp] 3750ME QoS

Dmitry Kiselev dmitry at dmitry.net
Tue Oct 3 15:58:45 EDT 2006


Hello!

Here is my 3750-Metro config example:

mls qos
interface FastEthernet1/0/6
 description Customer
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 302,303,304,305
 switchport mode trunk
 mls qos vlan-based

interface GigabitEthernet1/1/1
 description MAN
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2,3,4,303,304,305
 switchport mode trunk

interface Vlan2
 ip address 192.168.0.1 255.255.255.252

interface Vlan3
 ip address 192.168.0.5 255.255.255.252

interface Vlan4
 ip address 192.168.0.9 255.255.255.252

interface Vlan302
 ip address 10.0.0.1 255.255.255.252

ip route 10.0.1.0 255.255.255.0 10.0.0.2


Vlans 2-4 are members of OSPF driven IP MAN with many routes
in it.


I need to do rate-limiting for all traffic arrived via any vlans 2-4
with some dscp value and routed to customer's Vlan302. Something
like this:

class-map match-all DSCP1
  match ip dscp 1
policy-map MAN-TO-CUSTOMER
  class DSCP1
    police 1000000 8000 exceed-action drop

interface Vlan302
 service-policy output MAN-TO-CUSTOMER



And limit all traffic received from customer's Vlan302 that forwarded
to vlan 3 only, but untouch traffic from other vlans

class-map match-all CUSTOMER1
  match input-interface Vlan302
policy-map CUSTOMER-TO-MAN
  class CUSTOMER1
    police 1000000 8000 exceed-action drop

interface Vlan3
  service-policy output CUSTOMER-TO-MAN


Both examples are invalid for 3750-Metro hardware.

Is there any other way to do such things?

Thanks!

P.S. IOS 12.2(25)SEG, but up|down-grade is not a problem

-- 
Dmitry Kiselev


More information about the cisco-nsp mailing list