[c-nsp] 1841 w/2 Internet and NAT

Bruce Pinsky bep at whack.org
Tue Oct 3 20:39:03 EDT 2006


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Charles J. Boening wrote:
> Bruce,
> 
> Just knowing it will work is helpful.  We're going to use the T1
> directly on the 1841 as the primary so detecting it going down should be
> easy barring an ISP routing failure or something that leaves the T1 up
> and the route installed.
> 


Here is a simple example:

interface Ethernet1/0
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
 !
interface Serial1/0
 ip address 10.192.3.9 255.255.255.252
 ip nat outside
 !
interface Serial1/1
 ip address 10.192.3.13 255.255.255.252
 ip nat outside
 !
ip nat pool ISPa-pool 192.168.0.1 192.168.0.254 prefix-length 24
ip nat pool ISPb-pool 192.168.1.1 192.168.1.254 prefix-length 24
ip nat inside source route-map ISPa-map pool ISPa-pool overload
ip nat inside source route-map ISPa-map pool ISPb-pool overload
!
access-list 92 permit 10.0.0.0 0.0.0.255
!
! Adding access-list to route-map insures only addresses that SHOULD appear
! on the ethernet actually get NAT'd
!
route-map ISPa-map permit 10
 match ip address 92
 match interface Serial1/0
!
route-map ISPb-map permit 10
 match ip address 92
 match interface Serial1/1

Now it's simply a matter of pointing out the proper desired interface via
some static or dynamic routing method.

- --
=========
bep

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFFIwKnE1XcgMgrtyYRAvNKAKDvhEOhR3ppfXOh2LLXi6VORkU+xgCfToaw
ObXnufwoiZoPszcBzrM3moY=
=UnNi
-----END PGP SIGNATURE-----


More information about the cisco-nsp mailing list