[c-nsp] What QoS methods are available on ATM IMA lines?

Peter Olsson pol at leissner.se
Mon Feb 5 09:34:54 EST 2007


I'm trying to implement QoS on ATM IMA lines.
It seems the only option available on ATM IMA lines is police,
is this correct?

I have tried bandwidth, priority and shape, but when I have
one of those in the policy-map, the router silently refuses
to accept the service-policy command. I have tried this in
the following IOS:
c3845-advipservicesk9-mz.124-12
c3640-js-mz.122-32

I would like to shape the bulk traffic and use bandwidth or
priority for the priority traffic, but it seems impossible
to do that on ATM IMA? I've searched for documents showing
QoS restrictions on ATM IMA, but haven't been able to find any.
There are probably restrictions because of the underlying ATM,
but I would like to know for sure what works and what doesn't.

Here is my QoS configuration, with the BULK class-map shortened.
I'd be grateful for any ideas for improvement. The IMA interfaces
are 2 * 2 Mbps in some cases and 4 * 2 Mbps in some cases.

class-map match-any BULK
  match protocol http url "*.iso"
  match protocol ftp
  match access-group 121

class-map match-all BULK_OFFICE_HOURS
  match class-map BULK
  match access-group 171

class-map match-any PRIO
  match access-group 102

policy-map LIMIT_BULK_OUT
  class PRIO
    police 2048000 256000 256000 conform-action transmit  exceed-action transmit  violate-action transmit
  class BULK_OFFICE_HOURS
    police 2048000 256000 256000 conform-action transmit  exceed-action transmit  violate-action drop
  class class-default
   fair-queue
   random-detect

interface ATM1/IMA0
  ip address x.x.x.1 255.255.255.252
  ip ospf network point-to-point
  no atm ilmi-keepalive
  pvc 1/42
   protocol ip x.x.x.2 broadcast
   service-policy output LIMIT_BULK_OUT

access-list 102 permit ip host y.y.y.y any

access-list 121 permit ip any host z.z.z.z

access-list 171 permit ip any any time-range BW_LIMIT

time-range BW_LIMIT
  periodic weekdays 7:30 to 17:30

Thanks!

-- 
Peter Olsson                    pol at leissner.se


More information about the cisco-nsp mailing list