[c-nsp] MPLS-VPN migration

Luan Nguyen luan at netcraftsmen.net
Wed Dec 17 21:55:39 EST 2008


You could run routing protocol inside the (DMVPN) tunnel like OSPF and
redistribute using MP-BGP.

router ospf 1 vrf CUSTOMER1  <---VRF instance of OSPF
network [tunnel interface ip network] area 0
redistribute bgp 65535 subnets route-map redis-bgp-vrf-CUSTOMER1-to-ospf  
!
Router ospf 2
Network [tunnel interface ip network] area 0
!
router bgp 65535
address-family ipv4 vrf CUSTOMER1
redistribute ospf 1 vrf CUSTOMER1 route-map redis-ospf-to-bgp-vrf

Regards,

Luan Nguyen
Chesapeake NetCraftsmen, LLC.
www.NetCraftsmen.net



-----Original Message-----
From: Tim Durack [mailto:tdurack at gmail.com] 
Sent: Wednesday, December 17, 2008 1:21 PM
To: Luan Nguyen
Cc: cisco-nsp at puck.nether.net
Subject: Re: [c-nsp] MPLS-VPN migration

On Wed, Dec 17, 2008 at 12:25 PM, Luan Nguyen <luan at netcraftsmen.net> wrote:
> Let me try thinking out loud :)
> There BGP support for IP prefix import into VRF table:
>
http://www.cisco.com/en/US/docs/ios/12_3t/12_3t14/feature/guide/gt_bgivt.htm
> l
> You could use static routes as well.

Looked at that. Trouble is the static routes have to specify next-hop,
which isn't going to be very scalable for directly-connected VLAN
interfaces.

> For dynamic, some people create two tunnels, same router, same subnet,
> sourced from different loopbacks.  With one tunnel interface in the vrf,
one
> in the global routing table
>
>
> ip vrf CUSTOMER1
> rd
> route-target export
> route-target import
> !
> interface Tunnel100
> description VRF_CUSTOMER1_BRIDGE_TO_GLOBAL_ROUTING_TABLE
> bandwidth 50000
> ip vrf forwarding CUSTOMER1
> ip address 172.31.254.254 255.255.255.252
> load-interval 30
> tunnel source x.x.x.x
> tunnel destination y.y.y.y
> !
> interface Tunnel200
> description GLOBAL_ROUTING_TABLE_BRIDGE_TO_VRF_CUSTOMER1
> bandwidth 50000
> ip address 172.31.254.253 255.255.255.252
> ip virtual-reassembly
> load-interval 30
> tunnel source y.y.y.y
> tunnel destination x.x.x.x

And point statics at the tunnel? I guess that could work.

I was hoping to do something along the lines of:

http://www.cisco.com/en/US/docs/ios/iproute/configuration/guide/bgp_router_i
d_ps6017_TSD_Products_Configuration_Guide_Chapter.html#wp1055073

But it looks like this only works for VRF<->VRF BGP sessions, not
VRF<->GLOBAL.

Tim:>



More information about the cisco-nsp mailing list