[c-nsp] QOS Configuration Help

Dan Letkeman danletkeman at gmail.com
Wed Mar 5 17:32:26 EST 2008


Hello,

I am in the process of configuring QOS for our video system.
Currently I'm having trouble configuring our 2960's with srr queuing.
I have not yet tackled the 3560's.

Here is the config I'm working with, there are more 3560's and 2960's,
but this should give an idea on how I have configured them:

3560:

class-map match-any VIDEO
  match access-group name POLYCOM
!
policy-map in
  class VIDEO
   set dscp af41
!
interface FastEthernet0/24
description test trunk to 2960
switchport trunk encapsulation dot1q
switchport trunk native vlan 500
switchport trunk allowed vlan 500
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
srr-queue bandwidth limit 20
priority-queue out
mls qos trust cos
spanning-tree portfast
!
ip access-list extended POLYCOM
 permit ip host 192.168.50.12 any


2960:

class-map match-any VIDEO
  match access-group name POLYCOM
!
policy-map in
  class VIDEO
   set precedence 4
!
interface FastEthernet0/1
 description - Codec plugged in here
 switchport access vlan 500
 switchport mode access
 ip access-group POLYCOM in
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 auto qos voip trust
 spanning-tree portfast trunk
 service-policy input in

interface FastEthernet0/24
 description - trunk to 3560
 switchport trunk native vlan 500
 switchport trunk allowed vlan 500
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 srr-queue bandwidth limit 35
 priority-queue out
 auto qos voip trust
 spanning-tree portfast trunk

ip access-list extended POLYCOM
 permit ip host 192.168.50.12 any

I'm not exactly sure what is happening, but i'm not getting any hits
on the acl's.  The Codec is 192.168.50.12, the trunk's are all
working, and the network is working fine.

Is there something i'm missing?

Thanks,
Dan.


More information about the cisco-nsp mailing list