[c-nsp] MPLS T.E Autoroute problem

Ibrahim Abo Zaid ibrahim.abozaid at gmail.com
Fri Dec 11 12:49:41 EST 2009


Hi All

I have strange behaviour with MPLS T.E with autoroute

Topology

R4 (AS100)
|
|
R1-------R2-------R3-------R5 -----> (AS 200)
|-----Tun13---------|

both AS200 runs OSPF (single area) and Tunnel13 on R1 is between R1-Lo0 and
R3-Lo0 and as shown R5 is reachable from R3

the problem is when enabling autoroute

and in LFIB , R5-Lo0 is reachable over the tunnel with untagged label and
R3-Lo0 has Pop label so any VPN traffic sourced on R4 and destinted to CE
connected to R5 will be routed to R1 which removes ALL  labels and forward
it out the tunnel and it will be dropped on R3 and never reaches it is
destination

by disabling autoroute

R5 is still reachable via R3 BUT LFIB has label assigned other than untag
and traffic flow seamlessly

enabling MPLS over the tunnel didn't fix the problem

is there any feature or command i can use so routes reachable over tunnel
and behind tunnel tailend can have a label other than untag ?

configuration

R1

mpls label protocol ldp
mpls traffic-eng tunnels
mpls ldp router-id Loopback0
mpls label range 100 199
!
interface Loopback0
 ip address 20.1.1.1 255.255.255.255
!
interface Tunnel13
 ip unnumbered Loopback0
 tunnel destination 20.1.3.3
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng priority 0 0
 tunnel mpls traffic-eng bandwidth  1000
 tunnel mpls traffic-eng path-option 1 dynamic
 no routing dynamic
!
interface FastEthernet0/0.12
 encapsulation dot1Q 12
 ip address 20.1.12.1 255.255.255.0
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth 10000 10000
!
interface Serial2/0
 ip address 20.1.14.1 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 20.1.14.4 104 broadcast
 no frame-relay inverse-arp
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 router-id 20.1.1.1
 log-adjacency-changes
 redistribute bgp 200 subnets route-map bgp-to-ospf
 network 20.1.1.1 0.0.0.0 area 0
 network 20.1.12.1 0.0.0.0 area 0
!
router bgp 200
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 20.1.3.3 remote-as 200
 neighbor 20.1.3.3 update-source Loopback0
 neighbor 20.1.14.4 remote-as 100
 !
 address-family ipv4
  neighbor 20.1.14.4 activate
  neighbor 20.1.14.4 send-community both
  neighbor 20.1.14.4 send-label
  no auto-summary
  no synchronization
  network 20.1.1.1 mask 255.255.255.255
  network 20.1.2.2 mask 255.255.255.255
  network 20.1.3.3 mask 255.255.255.255
  network 20.1.5.5 mask 255.255.255.255
 exit-address-family
 !
 address-family vpnv4
  neighbor 20.1.3.3 activate
  neighbor 20.1.3.3 send-community extended
 exit-address-family
 !



R2
===
mpls label protocol ldp
mpls traffic-eng tunnels
mpls ldp router-id Loopback0
mpls label range 200 299
!
interface Loopback0
 ip address 20.1.2.2 255.255.255.255
!
interface FastEthernet0/0.12
 encapsulation dot1Q 12
 ip address 20.1.12.2 255.255.255.0
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth 10000 10000
!
interface Serial2/1
 ip address 20.1.23.2 255.255.255.0
 encapsulation ppp
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth 10000 10000
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 router-id 20.1.2.2
 log-adjacency-changes
 summary-address 217.1.0.0 255.255.252.0
 redistribute bgp 200 subnets route-map bgp-to-ospf
 network 20.1.2.2 0.0.0.0 area 0
 network 20.1.12.2 0.0.0.0 area 0
 network 20.1.23.2 0.0.0.0 area 0
!


R3
===
mpls label protocol ldp
mpls traffic-eng tunnels
mpls ldp router-id Loopback0
mpls label range 300 399
!
interface Loopback0
 ip address 20.1.3.3 255.255.255.255
!
interface Ethernet1/1
 ip address 20.1.35.3 255.255.255.0
 full-duplex
 tag-switching ip
!
interface Serial2/2
 ip address 20.1.23.3 255.255.255.0
 encapsulation ppp
 mpls traffic-eng tunnels
 tag-switching ip
 serial restart-delay 0
 no dce-terminal-timing-enable
 ip rsvp bandwidth 10000 10000
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 router-id 20.1.3.3
 log-adjacency-changes
 network 20.1.3.3 0.0.0.0 area 0
 network 20.1.13.3 0.0.0.0 area 0
 network 20.1.23.3 0.0.0.0 area 0
 network 20.1.35.3 0.0.0.0 area 0
!
router bgp 200
 no bgp default route-target filter
 bgp log-neighbor-changes
 neighbor 20.1.1.1 remote-as 200
 neighbor 20.1.1.1 update-source Loopback0
 neighbor 20.1.5.5 remote-as 200
 neighbor 20.1.5.5 update-source Loopback0
 !
 address-family vpnv4
 neighbor 20.1.1.1 activate
 neighbor 20.1.1.1 send-community extended
 neighbor 20.1.1.1 route-reflector-client
 neighbor 20.1.5.5 activate
 neighbor 20.1.5.5 send-community extended
 neighbor 20.1.5.5 route-reflector-client
 exit-address-family
 !



R5
===
mpls label protocol ldp
mpls traffic-eng tunnels
mpls ldp router-id Loopback0
mpls label range 500 599
!
interface Loopback0
 ip address 20.1.5.5 255.255.255.255
!
interface Ethernet1/0
 ip address 20.1.35.5 255.255.255.0
 full-duplex
 tag-switching ip
!
router ospf 1
 router-id 20.1.5.5
 log-adjacency-changes
 network 20.1.5.5 0.0.0.0 area 0
 network 20.1.35.5 0.0.0.0 area 0
!
outer bgp 200
 no synchronization
 bgp log-neighbor-changes
 neighbor 20.1.3.3 remote-as 200
 neighbor 20.1.3.3 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
 neighbor 20.1.3.3 activate
 neighbor 20.1.3.3 send-community extended
 exit-address-family



show commands

when autoroute enabled

R1#sh mpls forwarding-table 20.1.5.5
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
115    Untagged[T] 20.1.5.5/32       0          Tu13       point2point
[T]     Forwarding through a TSP tunnel.
        View additional tagging info with the 'detail' option
R1#
R1#sh mpls forwarding-table 20.1.3.3
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
101    Pop tag [T] 20.1.3.3/32       2226       Tu13       point2point
[T]     Forwarding through a TSP tunnel.
        View additional tagging info with the 'detail' option


by disbaling autorouet and use static route to R3-Lo0 instead

R1#sh ip route 20.1.3.3
Routing entry for 20.1.3.3/32
  Known via "static", distance 1, metric 0 (connected)
  Redistributing via ospf 1
  Advertised by ospf 1
                bgp 200
  Routing Descriptor Blocks:
  * directly connected, via Tunnel13
      Route metric is 0, traffic share count is 1
R1#sh ip route 20.1.5.5
Routing entry for 20.1.5.5/32
  Known via "ospf 1", distance 110, metric 76, type intra area
  Advertised by bgp 200
  Last update from 20.1.12.2 on FastEthernet0/0.12, 00:00:50 ago
  Routing Descriptor Blocks:
  * 20.1.12.2, from 20.1.5.5, 00:00:50 ago, via FastEthernet0/0.12
      Route metric is 76, traffic share count is 1
R1#
R1#sh mpls forwarding-table 20.1.3.3
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
101    Pop tag [T] 20.1.3.3/32       62         Tu13       point2point
[T]     Forwarding through a TSP tunnel.
        View additional tagging info with the 'detail' option
R1#sh mpls forwarding-table 20.1.5.5
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
115    211         20.1.5.5/32       0          Fa0/0.12   20.1.12.2



best regards
--Ibrahim


More information about the cisco-nsp mailing list