[c-nsp] Frame-relay to MLPPP traffic shaping and QoS?

Rodney Dunn rodunn at cisco.com
Wed Feb 11 09:24:11 EST 2009


This is a common question when the SP QOS isn't being used.

Your only option is to use what we call hierarchical shaping
at the hub to create a "fake" congestion point there to do the
QOS before it's sent to the cloud.

It looks like this sorta:


policy-map spokeqos
 class spoke1
   policy-map spoke1
 class spoke2
   policy-map spoke2
 ...


Then you define a class for each spoke to match on it's
ip subnet:

class-map match-any spoke1
 match ip address 101

access-list 101 permit ip any <spoke1subnet>

...



Then for your spoke QOS policy you shape it down and do the QOS
for the traffic.

 On Tue, Feb 10, 2009 at 10:39:23AM -0600, Dave Edmondson wrote:

ie:

class-map match-all data
 match ip precedence 4 
class-map match-any spoke2
 match access-group 102
class-map match-any spoke1
 match access-group 101
class-map match-all voice
 match ip precedence 5 
!
!
policy-map spokecbwfq
 class voice
  priority 200
 class data
  bandwidth 200
policy-map spokeqos
 class spoke1
  shape average 3000000
  service-policy spokecbwfq
 class spoke2
  shape average 3000000
  service-policy spokecbwfq


...

R2_#sh policy-map int e0/0
 Ethernet0/0 

  Service-policy output: spokeqos

    Class-map: spoke1 (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group 101
        0 packets, 0 bytes
        5 minute rate 0 bps
      Traffic Shaping
           Target/Average   Byte   Sustain   Excess    Interval  Increment
             Rate           Limit  bits/int  bits/int  (ms)      (bytes)  
          3000000/3000000   18750  75000     75000     25        9375     

        Adapt  Queue     Packets   Bytes     Packets   Bytes     Shaping
        Active Depth                         Delayed   Delayed   Active
        -      0         0         0         0         0         no

      Service-policy : spokecbwfq

        Class-map: voice (match-all)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 5 
          Queueing
            Strict Priority
            Output Queue: Conversation 136 
            Bandwidth 200 (kbps) Burst 5000 (Bytes)
            (pkts matched/bytes matched) 0/0
            (total drops/bytes drops) 0/0

        Class-map: data (match-all)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 4 
          Queueing
            Output Queue: Conversation 137 
            Bandwidth 200 (kbps)Max Threshold 64 (packets)
            (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

        Class-map: class-default (match-any)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any 
          
    Class-map: spoke2 (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group 102
        0 packets, 0 bytes
        5 minute rate 0 bps
      Traffic Shaping
           Target/Average   Byte   Sustain   Excess    Interval  Increment
             Rate           Limit  bits/int  bits/int  (ms)      (bytes)  
          3000000/3000000   18750  75000     75000     25        9375     

        Adapt  Queue     Packets   Bytes     Packets   Bytes     Shaping
        Active Depth                         Delayed   Delayed   Active
        -      0         0         0         0         0         no

      Service-policy : spokecbwfq

        Class-map: voice (match-all)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 5 
          Queueing
            Strict Priority
            Output Queue: Conversation 136 
            Bandwidth 200 (kbps) Burst 5000 (Bytes)
            (pkts matched/bytes matched) 0/0
            (total drops/bytes drops) 0/0

        Class-map: data (match-all)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 4 
          Queueing
            Output Queue: Conversation 137 
            Bandwidth 200 (kbps)Max Threshold 64 (packets)
            (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

        Class-map: class-default (match-any)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any 

    Class-map: class-default (match-any)
      37 packets, 3872 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any 

...


the problem though is I can't remember if we could support a two level
shaper such that you could do shaping at the top parent level
to control burst above the 12Mbps limit.

Rodney




> Hello all,
> 
> I have inherited a network used for data, VoIP, and video conferencing. The
> central site has a DS3 with a 12 mbps frame-relay interface into a
> Juniper-based MPLS and a 12 mbps frame-relay interface to the Internet. 
> 
> The remote sites on the MPLS network have 2XT1 MLPPP interfaces, with all
> Internet access via the central site. My central site has a Cisco 3845
> (12.4(3f)) with an NM1-T3/E3 card, the remotes all have Cisco 1841
> (12.3(10.3)T2).
> 
> We do video conferences between sites on the MPLS and FTP is used to move
> multi-gigabyte files from the central site to the remote sites and from
> remote site to remote site. Email servers are all at the main site. We are
> moving toward central storage as well, so some backups are done from remote
> sites to the central site. And they want to provide streaming media for
> training...
> 
> We are not doing any BGP or OSPF, just static routes. Each site has a /16
> assigned. 
> 
>                          3 meg MLPPP 1841, 10.20.X.X
>                                                  |
>                                                  |
> 
> 3 meg MLPPP 1841, 10.20.X.X--- MPLS ---3 meg MLPPP 1841, 10.30.X.X
> 
>                                                  |
>                                                  |
>             DS3 w/12 meg frame relay PVC to 3845, 10.10.X.X 
> 
> My challenge: 
> 
> 1) Shape traffic or rate limit to 3 megs from the central site to each of
> the remote sites so I don't overrun the remote site bandwidth.
> 
> 2) Apply QoS to traffic destined for each specific remote originating from
> the central site, rate-limiting some protocols (like FTP). 
> 
> I am familiar with QoS configs on MLPPP bundles in Cisco, but I know nothing
> about traffic shaping and QoS on frame relay interfaces. If ignorance is
> bliss, I've been pretty happy until now....
> 
> Suggestions?
> 
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/


More information about the cisco-nsp mailing list