[c-nsp] untagged to QinQ switch ports
Ross McConner
rmcconner at gmail.com
Fri Feb 13 14:05:50 EST 2009
Maybe I'm just hitting my head against a wall and therefore can't see the
answer..
I'm looking for a way to take a non-trunked ethernet port and encapsulate
any of the L2 packets into a double-tagged dot1q vlan.
Basically my provider gives me a single circuit with 802.1q and then tunnels
vlans to different destinations (most likely via xconnects). At this
(small) location I don't need to have all the vlans in use, just specific
ones - so I'm looking for a way to do it without installing a 2nd switch in
front of the cisco just to create the inner vlan tags, which is what all of
cisco's documentation assumes.
In psuedo IOS - what I'd like to do:
!
interface FastEthernet 0/0
switchport access vlan 10 20
!
interface FastEthernet 0/1
switchport access vlan 50 60
!
interface FastEthernet 1/0
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 20,60
!
Is this possible at all?
More information about the cisco-nsp
mailing list