[c-nsp] QoS on 837 using PPPoE

Thomas.Sillaber at nextiraone.de Thomas.Sillaber at nextiraone.de
Tue Jul 7 17:55:53 EDT 2009


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi Clue,

yes your right. applying the sp to the dialer interface is a bad idea (see IP's ioshints blog) - also IMHO to the virt template (never tried it). To support LLQ and CBWFQ on DSL Interfaces you have to:

   	- change the vc to vbr-nrt
   	- apply the sp on the vc (per vc queueing)
  	[- optionally tune tx-ring on the vc in case of low speed upload]
  	[- optionally change tcp mss on low speed interfaces (dialer) to prevent cell padding - a lot of validation in lab env shows that 	cell padding introduce higher delays than packets matching n x atm cells without padding. In worse situation with very slow upstreams  	using very low mss sizes (IOS min 500) matching cells without padding might help (TCP performance is already bad..)
    	- better use dscp based classification on eth ingress interface.

	
Take care when calculation the needed bandwidth per call with this setup. You have to calc all the overhead introduced by the DSL Interface:

Here's a example of different coders with different coder intervals measured @ the ATM interface (simulated with Chariot):

- ---------------------------------------------------------------------
G.711A(10ms)      30 second offered rate 124000 bps, drop rate 0 bps
G.711A(20ms)  	30 second offered rate 94000 bps, drop rate 0 bps
G.711A(30ms)	30 second offered rate 84000 bps, drop rate 0 bps
- ---------------------------------------------------------------------
G.729A(10ms)	30 second offered rate 69000 bps, drop rate 0 bps
G.729A(20ms)	30 second offered rate 38000 bps, drop rate 0 bps
G.729A(30ms)	30 second offered rate 28000 bps, drop rate 0 bps
- ---------------------------------------------------------------------

==> a little bit higher than expected :-)

Basic Setup
- ----------------
!
policy-map QOS
class RT
   Priority 256
class SIG
   Bandwith x
!
interface ATM0.1 point-to-point
 pvc 1/100
   tx-ring-limit 2			//aggressive - only for slow speed upstreams...
   vbr-nrt <upstream> <upstream>  	//use sh dsl int atm0 to determine the upstream rate or ?
   service-policy output QOS
!
Interface Dialer 0
	Ip tcp adjust-mss 544		// minimum used for slow speed upstream rate (without vpn or other overhead)
!

MSS is calculated like this:

13 ATM Cells x 48 - 80 [Overhead]

Overhead:

AAL5 Header		10	Byte
AAL5 Trailer	8	Byte
PPPOE Header	8	Byte
Ethernet Header	14	Byte
IP Header		20	Byte
TCP Header		20	Byte

==> 80Byte

Hope this helps.
==> Do not forget the downstream! Shaping + HQOS @ BRAS or Central Site is needed!

Brgds

TS

- -----Ursprüngliche Nachricht-----
Von: cisco-nsp-bounces at puck.nether.net [mailto:cisco-nsp-bounces at puck.nether.net] Im Auftrag von Clue Store
Gesendet: Dienstag, 7. Juli 2009 22:43
An: cisco-nsp at puck.nether.net
Betreff: [c-nsp] QoS on 837 using PPPoE

Hi All,


I am having a hard time trying to figure how to apply a QoS policy on this
router. I have applied a few typical service-policies on the dialer
interfaces, but a "show policy interface di0" shows packets being matched
but nothing being dropped and the link is saturated. I believe the policy
needs to be applied to the virtual-access interface that comes up when PPP
negotiates, but i'm not quite sure how this would be done since the use of
vpdn-groups are no longer used. Relevent config posted. Any suggestions are
greatly appreciated. *And yes I know the service-policy is not applied to
the dialer interface...this was due to it not working.


class-map match-any VoIP
 match ip rtp 16384 16383
 match access-group name VoicePorts
!
!
policy-map Voice
 class VoIP
  priority 256
!
!
!
!
!
interface Ethernet0
 ip address 192.168.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Ethernet2
 no ip address
 shutdown
 hold-queue 100 out
!
interface ATM0
 no ip address
 load-interval 30
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 pvc 1/100
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
 !
!
interface FastEthernet1
 duplex auto
 speed auto
!
interface FastEthernet2
 duplex auto
 speed auto
!
interface FastEthernet3
 duplex auto
 speed auto
!
interface FastEthernet4
 duplex auto
 speed auto
!
!
interface Dialer0
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1412
 dialer pool 1
 no cdp enable
<ppp info ************>
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
no ip http secure-server
!
no ip nat service skinny tcp port 2000
no ip nat service sip udp port 5060
ip nat inside source list 10 interface Dialer0 overload
!
!
ip access-list extended VoicePorts
 permit udp any host *.*.*.* range 22026 62025
 permit udp any host *.*.*.* range 22026 62025
access-list 10 permit 192.168.10.0 0.0.0.255
_______________________________________________
cisco-nsp mailing list  cisco-nsp at puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (MingW32)

iQEVAwUBSlPEZ2Z0NRmWJ+KQAQIdzAgAoDtyyfVXkKR43ZI5LlPM/XXakdHeRh07
kB5XjnsY7PB+sog65YGZQaZTwm5B9dHWsNFgmQUD04MdXd/QwVwnKildh7haVvqg
6PPT8GntculzXx010MTzTbJ44dUlWmksSibdKJWgdNx8vBNk0GXOpP0yuCGoc3/s
U6S9qzmv3jhtXn+rbWBP9Hh0g3LJ8SnOAp0YXSc5szSeC4JUlwNp6uq2rQC488m3
ji5JG2wIeZ/JCZ/5y+rCI66dx0iYd5bac27qLo29UIrx7LJpVVK/gwvE1FeJUBiR
2C0WDThjO3/H24cOJz9NRgh3O4kTxKs6jwU56OsVZ/Hu32fuZETAUw==
=KNVj
-----END PGP SIGNATURE-----


More information about the cisco-nsp mailing list