[c-nsp] Quick question regarding trunking and routing.

Stig Johansen Stig.Johansen at atea.no
Fri Mar 13 09:11:10 EDT 2009


>We have a 3550 which connects to two 6500s.
>The 3550 has some L3 vlans on it, but we also need to trunk a few of the ports up to the 6500s.
>I've been banging my head because I cannot figure out how to make the two uplink ports on the 3550 both trunk and route.
>What I mean is, currently the ports have ip addresses assigned directly to them (/30s).
>I have to remove the IP to enable trunking, but then the L3 VLANs that originate directly on the 3550 no longer function.
>I'm thinking there has to be some way to use uplink ports for both trunking and routing but I just can't seem to figure it out.
>I realize that the "normal" network topology would be to just create all the vlans on the 6500s and just trunk everything from the 3550 to the 6500s but for legacy purposes that isn't really an option.
>Any advice would be great.

You'll have to establish one or two VLAN's between the 3550 and the 6500'es and let this VLAN over the trunk.

As in:

Old config:
interface FastEthernet0/1
 description to 6500-1
 ip address 1.2.3.2 255.255.255.252
!
interface FastEthernet0/2
 description to 6500-2
 ip address 2.3.4.2 255.255.255.252

New config:
vlan 100
 name 3550-to-6500-1
!
vlan 200
 name 3550-to-6500-2
!
interface FastEthernet0/1
 description L2 to 6500-1
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 100   ! And all of the other VLAN's you want to trunk up to 6500-1.
 switchport mode trunk
!
interface FastEthernet0/2
 description L2 to 6500-2
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 200   ! And all of the other VLAN's you want to trunk up to 6500-2.
 switchport mode trunk
!
interface Vlan100
 description L3 to 6500-1
 ip address 1.2.3.2 255.255.255.252
!
interface Vlan200
 description L3 to 6500-2
 ip address 2.3.4.2 255.255.255.252
!

Best regards,
Stig Meireles Johansen


More information about the cisco-nsp mailing list