[c-nsp] QoS Cisco Serie 800 and 1800
Alejandro Selios
aselios at gmail.com
Fri Nov 20 12:51:01 EST 2009
Thanks Clue for your quick answer.
In the original mail I didn't mention it, but I applied the service-policy
to the PVC like you said. (Below attach the complete configuration for both
cases).
Another issue is that Cisco's 800 and 1800 series routers only have 2 level
of prioritization. Cisco's routers allow to configure a priority queue and
CBWFQ (class base weighted fair queue) but does not has the flexibly to
specify a scheduler policy or any other queuing policies.
I think that weighted fair queue will leave as dead end, I think the way to
follow is a strict priority queuing with a customizable scheduler policy.
I'm looking for a way to do that in Cisco's routers.
I'll appreciate any help you can give me.
Cisco 878/877
--------------------------------------
class-map match-all GOLD
match access-group name GOLD_ACL
class-map match-all SILVER
match access-group name SILVER_ACL
policy-map QoS_POLICY
class GOLD
priority percent 25
police cir percent 25 pir percent 25
set dscp ef
class SILVER
set dscp af41
bandwidth percent 50
shape average percent 75
class class-default
fair-queue
set dscp af12
bandwidth percent 25
interface ATM0
no ip address
load-interval 30
no atm ilmi-keepalive
max-reserved-bandwidth 100
!
interface ATM0.35 point-to-point
description INTERFAZ DE ACCESO
ip address x.x.x.x 255.255.255.254
atm route-bridged ip
pvc 0/35
vbr-nrt 576 576
oam-pvc 0
encapsulation aal5snap
service-policy output QoS_POLICY
Cisco 1841
--------------------------------------
class-map match-all GOLD
match access-group name GOLD_ACL
class-map match-all SILVER
match access-group name SILVER_ACL
policy-map QoS_POLICY
class GOLD
priority percent 25
police cir percent 25 pir percent 25
set dscp ef
class SILVER
set dscp af41
bandwidth percent 50
shape average percent 75
class class-default
fair-queue
set dscp af12
bandwidth percent 25
policy-map SHAPER
class class-default
shape average 1000000
service-policy QoS_POLICY
!
!
!
interface FastEthernet0/0
description INTERFAZ DE ACCESO
no ip address
load-interval 30
duplex auto
speed auto
!
interface FastEthernet0/0.100
encapsulation dot1Q 100
ip address x.x.x.x 255.255.255.252
service-policy output SHAPER
Thanks,
2009/11/20 Clue Store <cluestore at gmail.com>
> Hi Alejandro,
>
> If you're doing this with xDSL, you will have to apply the service-policy
> to the PVC for outgoing to make it work. Here's an example of what I use. I
> know your class-maps and policy-maps are different, but you should be able
> to get the point.
>
> class-map match-any VoIP
> match ip rtp 16384 16383
> match access-group name VoicePorts
>
> policy-map Voice
> class VoIP
> priority percent 75
>
> class class-default
> fair-queue
>
>
> interface ATM0.1 point-to-point
> pvc 1/100
> vbr-rt 384 384
> tx-ring-limit 3
> service-policy output Voice
>
>
> ip access-list extended VoicePorts
> permit udp any host x.x.x.x range 22026 62025
> permit udp any host x.x.x.x range 22026 62025
>
>
>
>
> HTH,
> Clue
>
> On Fri, Nov 20, 2009 at 9:26 AM, Alejandro Selios <aselios at gmail.com>wrote:
>
>> Hi,
>>
>> I want to configure QoS on a Cisco's 800 and 1800 series router and I
>> couldn't make it work the way I want. I've configured three classes of
>> service called GOLD, SILVER and BRONZE, designed for low latency, low loss
>> and data respectively.
>>
>> * I want the GOLD class to have a maximum bandwidth of 25%, even if there
>> is
>> traffic in the other classes.
>>
>> * The SILVER class has a minimum bandwidth of 50% and, if there's no
>> traffic
>> in the GOLD queue, I want this class to take the available bandwidth which
>> is not used by the GOLD class. Thats means that the SILVER class has a 50%
>> of assured bandwidth and can increase to a maximum of 75% of the total
>> bandwidth.
>>
>> * The BRONZE class has no assured bandwidth and can only take the
>> bandwidth
>> which is not used for the other classes.
>>
>> The problem is that with Cisco's QoS tools I have not reached the desired
>> goal. I have tried with different configurations and IOS and I couldn't
>> get
>> any successful result . Below I attach the policy configuration that I
>> have
>> tried (just to give you an example).
>>
>> Is there any way in which I can achieve the behavior that was described
>> above?.
>>
>> Thanks in advance.
>>
>>
>> Standard Configuration
>> -------------------------------------
>>
>> policy-map QoS_POLICY
>> class GOLD
>> priority percent 25
>> police cir percent 25 pir percent 25
>> set dscp ef
>> class SILVER
>> set dscp af41
>> bandwidth percent 50
>> shape average percent 75
>> class class-default
>> fair-queue
>> set dscp af12
>> bandwidth percent 25
>>
>>
>>
>>
>> Hierarchical Configuration
>> ---------------------------------------------
>> policy-map GOLD+SILVER
>> class GOLD
>> priority percent 33
>> police rate percent 33
>> class class-default
>> fair-queue
>>
>> policy-map QOS
>> class GOLD+SILVER
>> shape average percent 75
>> bandwidth percent 75
>> service-policy GOLD+SILVER
>> class class-default
>> fair-queue
>>
>>
>> Note: This configuration was applied in a subinterface (xDSL, 802.1q
>> ethernet) and for the outgoing traffic.
>> _______________________________________________
>> cisco-nsp mailing list cisco-nsp at puck.nether.net
>> https://puck.nether.net/mailman/listinfo/cisco-nsp
>> archive at http://puck.nether.net/pipermail/cisco-nsp/
>>
>
>
More information about the cisco-nsp
mailing list