[c-nsp] 6500 xconnect port-channel?

Peter Rathlev peter at rathlev.dk
Wed Jul 14 07:46:58 EDT 2010


Hi,

Would anybody have any comments on doing port-mode EoMPLS xconnects on
port-channels on Sup720 running SXI?

We're contemplating delivering EoMPLS PtP this way. In or "normal" setup
we connect a "switchport trunk" from the downlink device to a port-mode
EoMPLS-port, plain and simple.

My guess is that there's nothing wrong with doing this via port-channels
instead. It seems to work, and the documentation hints at it being
supported[1] but is it a bad idea for some reason?

Example configuration from the "normal" setup:

! *** CE device ***
interface GigabitEthernet0/24
 description Uplink to PE1 Gi1/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!

! *** PE device ***
interface GigabitEthernet1/1
 description Downlink to CE1 Gi0/24
 mtu 9216
 no ip address
 udld port disable
 xconnect 192.0.2.10 1234 encapsulation mpls
!

We would like to do something like this:

! *** CE device ***
interface GigabitEthernet0/23
 description Uplink to PE1 Gi1/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 channel-group 1 mode on
!
interface GigabitEthernet0/24
 description Uplink to PE1 Gi1/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 channel-group 1 mode on
!
interface Port-channel1
 description Uplink to PE1 Po1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!

! *** PE device ***
interface GigabitEthernet1/1
 description Downlink to CE1 Gi0/23
 no ip address
 channel-group 1 mode on
!
interface GigabitEthernet1/2
 description Downlink to CE1 Gi0/24
 no ip address
 channel-group 1 mode on
!
interface Port-channel1
 description Downlink to CE1 Po1
 no ip address
 xconnect 192.0.2.10 1234 encapsulation mpls
!

This is without relevant MTU adjustments and so on. Just the EoMPLS
configuration.

[1]: Catalyst 6500 Release 12.2SXH and Later Software Configuration
Guide, Configuring Multiprotocol Label Switching
http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/pfc3mpls.html

-- 
Peter




More information about the cisco-nsp mailing list