[c-nsp] Redistributing External EIGRP routes through MPLS vpn

Joe Maimon jmaimon at ttec.com
Tue May 18 08:49:51 EDT 2010


Perhaps something like this shows what I ran into better - I'll have to 
try and see if I can build it in a lab.

The CE would not see the connected routes of the other CE's, unless a 
network statement is used instead of redistribute connected.

CE#1

hostname cust1-ce1
int l0
ip address 10.255.255.255 255.255.255.255
!
int fa0/0
ip address 10.1.1.0 255.255.255.0
!
int s0/0
ip address 172.16.0.1 255.255.255.252
!
router eigrp 100
redistribute connected
network 172.16.0.0 0.0.0.255
no auto-summary


PE#1

ip vrf cust1
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
int l0
ip address 1.0.0.0 255.255.255.255
!
int fa0/0
ip address 1.1.1.1 255.255.255.0
mpls ldp discovery transport-address interface
mpls label protocol ldp
mpls ip
mpls mtu 1548
!
int s0/0
desc cust1-ce1
ip vrf for cust1
ip address 172.16.0.2 255.255.255.252
!
router ospf 1
network 1.1.1.0 0.0.0.255 area 0.0.0.0
!
router eigrp 1
passive-interface default
no passive-interface s0/0
!
address-family ipv4 vrf cust1
redistribute bgp 65000 metric 6000 100 255 100 1500
network 172.16.0.0 0.0.0.255
autonomous-system 100
no auto-summry
eigrp router-id 172.16.0.2
!
router bgp 65000
neighbor 1.0.0.1 remote-as 65000
neighbor 1.0.0.1 update-source loopback0
!
address-family ipv4
neighbor 1.0.0.1 send-community both
!
address-family vpnv4
neighbor 1.0.0.1 send-community extended
!
address-family ipv4 vrf cust1
redistribute eigrp 100
no synchronization
!


PE#2


ip vrf cust1
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
int l0
ip address 1.0.0.1 255.255.255.255
!
int fa0/0
ip address 1.1.1.2 255.255.255.0
mpls ldp discovery transport-address interface
mpls label protocol ldp
mpls ip
mpls mtu 1548
!
int s0/0
desc cust1-ce2
ip vrf for cust1
ip address 172.16.0.6 255.255.255.252
!
router ospf 1
network 1.1.1.0 0.0.0.255 area 0.0.0.0
!
router eigrp 1
passive-interface default
no passive-interface s0/0
!
address-family ipv4 vrf cust1
redistribute bgp 65000 metric 6000 100 255 100 1500
network 172.16.0.0 0.0.0.255
autonomous-system 100
no auto-summry
eigrp router-id 172.16.0.6
!
router bgp 65000
neighbor 1.0.0.2 remote-as 65000
neighbor 1.0.0.2 update-source loopback0
!
address-family ipv4
neighbor 1.0.0.2 send-community both
!
address-family vpnv4
neighbor 1.0.0.2 send-community extended
!
address-family ipv4 vrf cust1
redistribute eigrp 100
no synchronization

CE#2



hostname cust1-ce2
int l0
ip address 10.255.255.0 255.255.255.255
!
int fa0/0
ip address 10.1.255.0 255.255.255.0
!
int s0/0
ip address 172.16.0.5 255.255.255.252
!
router eigrp 100
redistribute connected
network 172.16.0.0 0.0.0.255
no auto-summary




Luan Nguyen wrote:
> Just put this into Dynamips and didn't have any problem at all.
>
> CE1#
> router eigrp 1
>   no auto-summary
>   !
>   address-family ipv4 vrf BLUE
>   redistribute bgp 1 metric 1 1 1 1 1
>   network 10.10.10.254 0.0.0.0
>   no auto-summary
>   autonomous-system 1
>   exit-address-family
>
> PE1#
> router eigrp 1
>   no auto-summary
>   !
>   address-family ipv4 vrf BLUE
>   network 10.10.10.254 0.0.0.0
>   no auto-summary
>   autonomous-system 1
>   exit-address-family
>
>
> router bgp 1
> !
>   address-family ipv4 vrf BLUE
>   redistribute eigrp 1
>   no auto-summary
>   no synchronization
>   exit-address-family
>
> Maybe check the EIGRP configuration to see if you have thing like eigrp stub
> connected :)
>
> -------------------------------------
> Luan Nguyen
> Chesapeake NetCraftsmen, LLC.
> -------------------------------------
>
>
> -----Original Message-----
> From: cisco-nsp-bounces at puck.nether.net
> [mailto:cisco-nsp-bounces at puck.nether.net] On Behalf Of Joe Maimon
> Sent: Monday, May 17, 2010 8:19 PM
> To: shimshah at cisco.com
> Cc: cisco-nsp at puck.nether.net
> Subject: Re: [c-nsp] Redistributing External EIGRP routes through MPLS vpn
>
> Metric Must Be Configured for Routes from Other Autonomous Systems and
> Non-EIGRP Networks
>
> Yes, it is.
>
> Native EIGRP VRF to VRF Redistribution Is Not Supported
>
> Not what I am trying to do.
>
> Thanks,
>
> Joe
>
> Shimol Shah wrote:
>> Are you sure you are not running into restriction cited in below section
>> of the CCO document ?
>>
>>
> http://www.cisco.com/en/US/docs/ios/12_2t/12_2t15/feature/guide/fteipece.htm
> l#wp1027175
>>
>>
>> Shimol Shah
>>
>>
>> On 5/17/10 2:57 PM, Joe Maimon wrote:
>>> Hey All,
>>>
>>> Seems like I have run into a difficulty where CE#1 external EIGRP routes
>>> (redistribute connected/redistribute static) are learned by PE#1,
>>> redistributed to PE#2, but not redistributed to CE#2
>>>
>>> CE<->  PE, EIGRP
>>>
>>> PE<->  PE, MPLS/BGP
>>>
>>> The workaround is to use network statements, making the EIGRP routes on
>>> the CE internal. Those redistribute fine and show up on CE#2 as internal.
>>>
>>> Am I missing something and is there a simple clean way to redistribute
>>> from CE#1 to CE#2 external EIGRP routes?
>>>
>>> Thanks,
>>>
>>> Joe
>>> _______________________________________________
>>> cisco-nsp mailing list cisco-nsp at puck.nether.net
>>> https://puck.nether.net/mailman/listinfo/cisco-nsp
>>> archive at http://puck.nether.net/pipermail/cisco-nsp/
>> _______________________________________________
>> cisco-nsp mailing list cisco-nsp at puck.nether.net
>> https://puck.nether.net/mailman/listinfo/cisco-nsp
>> archive at http://puck.nether.net/pipermail/cisco-nsp/
>>
>>
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
>
> __________ Information from ESET NOD32 Antivirus, version of virus signature
> database 5123 (20100518) __________
>
> The message was checked by ESET NOD32 Antivirus.
>
> http://www.eset.com
>
>
>
>
> __________ Information from ESET NOD32 Antivirus, version of virus signature
> database 5123 (20100518) __________
>
> The message was checked by ESET NOD32 Antivirus.
>
> http://www.eset.com
>
>
>


More information about the cisco-nsp mailing list