[c-nsp] Leaking global into VRF

Jason Lixfeld jason at lixfeld.ca
Mon Nov 8 16:38:13 EST 2010


I'm trying to lab up a scenario where I can leak routes from the global table into a VRF, but I'm running up against an issue and I'm hoping someone here can point out where I might be misstepping.

My P router is also my peering router.  That is, in addition to it's P duties, it also speaks eBGP to another autonomous system.  I want to take the eBGP learned prefixes and import them into a VRF.  This part seems to work, but the issue is that the adjacent PE doesn't seem to see the prefix that has been imported.  The PE sees the global entry, but it doesn't see the prefix in the vpnv4 AF for the VRF in question.

I'm not really sure what to share in terms of configs or command output, but here's a start.

Thanks in advance.

! P router
!
ip vrf INTERNET
 rd 6666:0
 import ipv4 unicast map VRF-IMPORT
 route-target export 6666:0
 route-target import 6666:0
!
mpls label protocol ldp
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 ip router isis 
!
interface FastEthernet0/0
 ip address 7.0.0.0 255.255.255.254
 speed 100
 duplex full
!
interface POS1/0
 ip address 10.0.0.1 255.255.255.254
 ip router isis 
 encapsulation ppp
 mpls ip  
!         
router isis
 net 40.0000.0030.0300.3003.00
!
router bgp 6666
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 6666
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 7.0.0.1 remote-as 1
!
 address-family ipv4
  no synchronization
  network 1.1.1.0 mask 255.255.255.0
  network 2.2.2.0 mask 255.255.255.0
  network 3.3.3.0 mask 255.255.255.0
  network 4.4.4.0 mask 255.255.255.0
  network 5.0.0.0 mask 255.255.255.0
  network 6.0.0.0 mask 255.255.255.0
  network 6.1.1.0 mask 255.255.255.0
  network 10.0.0.0 mask 255.255.255.0
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 next-hop-self
  neighbor 7.0.0.1 activate
  no auto-summary
 exit-address-family
!
 address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community both
  neighbor 1.1.1.1 route-reflector-client
 exit-address-family
 !
 address-family ipv4 vrf INTERNET
  no synchronization
  redistribute connected
  redistribute static
  default-information originate
 exit-address-family
!         
!
ip bgp-community new-format
!
route-map VRF-IMPORT permit 10
!
mpls ldp router-id Loopback0 force
!

! PE router
!
ip vrf INTERNET
 rd 6666:0
 route-target export 6666:0
 route-target import 6666:0
!
mpls label protocol ldp
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ip router isis 
!
interface POS3/0
 ip address 10.0.0.0 255.255.255.254
 ip router isis 
 encapsulation ppp
 mpls ip  
!
router isis
 net 04.0000.0010.0100.1001.00
!
router bgp 6666
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 6666
 neighbor 3.3.3.3 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  redistribute static
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 next-hop-self
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community both
 exit-address-family
 !        
 address-family ipv4 vrf INTERNET
  no synchronization
  redistribute connected
 exit-address-family
!
mpls ldp router-id Loopback0 force
!



! P router BGP table
!
P1#show ip bgp all
For address family: IPv4 Unicast

BGP table version is 10, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24       0.0.0.0                  0         32768 i
*> 2.2.2.0/24       0.0.0.0                  0         32768 i
*> 3.3.3.0/24       0.0.0.0                  0         32768 i
*> 4.4.4.0/24       0.0.0.0                  0         32768 i
*> 5.0.0.0/24       0.0.0.0                  0         32768 i
*> 6.0.0.0/24       0.0.0.0                  0         32768 i
*> 6.1.1.0/24       0.0.0.0                  0         32768 i
*> 7.7.7.7/32       7.0.0.1                  0             0 1 i
*> 10.0.0.0/24      0.0.0.0                  0         32768 i

For address family: VPNv4 Unicast

BGP table version is 17, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
   Network          Next Hop            Metric LocPrf Weight Path
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 6666:0 (default for vrf INTERNET)
Import Map: VRF-IMPORT, Address-Family: IPv4 Unicast, Pfx Count/Limit: 18/1000
*> 0.0.0.0          0.0.0.0                  0         32768 ?
*> 1.1.1.0/24       0.0.0.0                  0         32768 i
*> 2.2.2.0/24       0.0.0.0                  0         32768 i
*> 3.3.3.0/24       0.0.0.0                  0         32768 i
*> 4.4.4.0/24       0.0.0.0                  0         32768 i
*>i5.0.0.0/26       1.1.1.1                  0    100      0 ?
*> 5.0.0.0/24       0.0.0.0                  0         32768 i
*>i6.0.0.0/26       2.2.2.2                  0    100      0 ?
*> 6.0.0.0/24       0.0.0.0                  0         32768 i
*>i6.1.1.0/26       2.2.2.2                  0    100      0 ?
*> 6.1.1.0/24       0.0.0.0                  0         32768 i
*> 7.7.7.7/32       7.0.0.1                  0             0 1 i
*> 10.0.0.0/24      0.0.0.0                  0         32768 i

For address family: IPv4 Multicast
   Network          Next Hop            Metric LocPrf Weight Path

P1#


! PE router BGP table
!
PE1#show ip bgp all
For address family: IPv4 Unicast

BGP table version is 40, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.0/24       3.3.3.3                  0    100      0 i
*>i2.2.2.0/24       3.3.3.3                  0    100      0 i
*>i3.3.3.0/24       3.3.3.3                  0    100      0 i
*>i4.4.4.0/24       3.3.3.3                  0    100      0 i
*>i5.0.0.0/24       3.3.3.3                  0    100      0 i
*>i6.0.0.0/24       3.3.3.3                  0    100      0 i
*>i6.1.1.0/24       3.3.3.3                  0    100      0 i
*>i7.7.7.7/32       3.3.3.3                  0    100      0 1 i
*>i10.0.0.0/24      3.3.3.3                  0    100      0 i

For address family: VPNv4 Unicast

BGP table version is 23, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
   Network          Next Hop            Metric LocPrf Weight Path
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 6666:0 (default for vrf INTERNET)
*>i0.0.0.0          3.3.3.3                  0    100      0 ?
*> 5.0.0.0/26       0.0.0.0                  0         32768 ?
*>i6.0.0.0/26       2.2.2.2                  0    100      0 ?
*>i6.1.1.0/26       2.2.2.2                  0    100      0 ?

For address family: IPv4 Multicast

PE1#

 


More information about the cisco-nsp mailing list