[c-nsp] setup for LAN party

Tim Pozar pozar at lns.com
Thu Apr 21 11:41:20 EDT 2011


Heh... Hard interfaces work well.

If you want to use cisco's rate limiting you can do something like...
---
interface FastEthernet 0/0
 description Inside of NAT
[...]
 rate-limit output access-group 101 64000 5000 5000 conform-action
transmit exceed-action drop
 rate-limit output access-group 102 192000 5000 10000 conform-action
transmit exceed-action drop
---

This bandwdith may be too severely restricted for your clients, so you
may want to bump this up. :-)  You can see more details at:

http://www.cisco.com/en/US/docs/ios/12_0/qos/configuration/guide/qccar.html

Put the camera on some static IP address and put the DHCP clients in an
ACL like...

---
access-list 101 permit ip any host 192.168.88.99
access-list 101 permit ip host 192.168.88.99 any
access-list 102 permit ip any 192.168.88.128 0.0.0.127
access-list 102 permit ip 192.168.88.128 0.0.0.127 any
---

You don't say how yo are doing your dhcp for your clients.  On the cisco
box you would exclude some space for devices with static IP's like...

---
ip dhcp excluded-address 192.168.88.1 192.168.88.128
---

And then create the lease pool...

---
ip dhcp pool 0
   network 192.168.88.0 255.255.255.0
   domain-name domain.com
   dns-server 4.2.2.2
   default-router 192.168.88.1
   lease 3
---

Of course change this into your address space.

Using a different platform... I have had very good luck with PFSense in
doing this.  We use the Priority Queuing and for an event that had only
22Mb/s of pipe with 400 heavy users at a conference, I was able to
guarantee 3 Mb/s for a video stream that came out of there.  Worked great.

Tim

on 4/21/11 8:14 AM Alan Buxey said the following:
> The quick easy way with no qos etc?
> 
> Connect 2950 to the router. Connect web server to that, with port at 10mbps, connect 3 ports to a gig switch beneath it as port-channel all at 10 mbits... then feed each of your LAN party switches from that gig switch ...and the fileservers too.
> 
> 
> End result is better lanparty LAN and nice solid 10mbit for webserver and 30mbits for the lanparty
> 
> 
> Quick, dirty but 'effective' :)
> 
> 
> Alan
> 
> ----- Reply message -----
> From: "harbor235" <harbor235 at gmail.com>
> Date: Thu, Apr 21, 2011 15:58
> Subject: [c-nsp] setup for LAN party
> To: "Martin T" <m4rtntns at gmail.com>
> Cc: "cisco-nsp at puck.nether.net" <cisco-nsp at puck.nether.net>
> 
> Did you really daisy chain your switches like that?
> 
> 
> mike
> 
> On Thu, Apr 21, 2011 at 10:36 AM, Martin T <m4rtntns at gmail.com> wrote:
> 
>> I have a following setup:
>> http://img534.imageshack.us/img534/7190/lanparty.png
>>
>> I can manage all the switches + Cisco 2801 router. Cisco 7206VXR is
>> managed by university IT staff- they will allocate an IP address with
>> DHCP server to Cisco 2801 Fa0/1. In total, there are <200 hosts in the
>> LAN divided between 8 switches. Main communication will take place
>> between the hosts via switches and only Internet traffic will move
>> over the WS-C2950T-24[Fa0/1] <-> [Fa0/0]Cisco2801 link. Internet
>> connection provided by ISP is 40Mbps.
>>
>>
>> The main question is how to allocate guaranteed bandwidth to
>> WWW-server(~3-4Mbps). There is a camera connected to WWW-server, which
>> will broadcast the live stream from the event to justin.tv(or similar
>> site). Is it possible to configure Cisco 2801 in such manner, that 10%
>> of all Internet traffic is guaranteed to WWW-server+camera and rest is
>> for all the hosts in the LAN?
>>
>>
>> regards,
>> martin
>> _______________________________________________
>> cisco-nsp mailing list  cisco-nsp at puck.nether.net
>> https://puck.nether.net/mailman/listinfo/cisco-nsp
>> archive at http://puck.nether.net/pipermail/cisco-nsp/
>>
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/

-- 
 GPG Fingerprint: 4821 CFDA 06E7 49F3 BF05  3F02 11E3 390F 8338 5B04
       http://www.lns.com/house/pozar/pozar_4096_rsa_public.asc


More information about the cisco-nsp mailing list