[c-nsp] Dual homed EIGRP CE MPLS connection

Andrew Miehs andrew at 2sheds.de
Sat Dec 17 20:10:51 EST 2011


Hi Gert,

On 16/12/2011, at 6:40 PM, Gert Doering wrote:
> We've used EIGRP on PE-CE links in the past and used prefix-list filters
> incoming and outoing to enforce policy - which worked as well as for BGP,
> and it's about the same amount of config work, so I think that approach
> is fine.

Below is my current config (GNS3 extract) on one of the two PEs. The customer RED Site 1 has the IP address range 10.99.1.0/24.

I am filtering the incoming routes in the EIGRP process as mentioned, and I have added route maps to the distribution so that I do not re-import the routes I exported via BGP on either of the PEs.
(Both PEs have similar configs).

The question is should I use the "Site of Origin" feature on the (in this example) FastEthernet interfaces between the CE and PE, or would I be better off including this in the redistribution from EIGRP to BGP on the PE or should I do both?

ie:
  interface FastEthernet6/0
   ip vrf forwarding RED
   ip vrf sitemap RED-SITE1-SoO
   ip address 10.6.0.1 255.255.255.252

or (next 10 lines an approximation)

  route-map RED-SITE1-e2b deny 10
   match tag 65000
  route-map RED-SITE1-e2b permit 20
   match prefix-list RED-SITE1
   set extcommunity soo 65000:3
  !
  route-map RED-SITE1-b2e deny 10
   match extcommunity soo 65000:3
  route-map RED-SITE1-b2e permit 20
   set tag 65000

Will this even scale? 


Thanks for any suggestions,

Andrew
PS: Yes - and I will probably use eBGP next time.

====
PE Config Example:

ip vrf RED
 rd 192.168.255.12:1
 route-target export 65000:1
 route-target import 65000:1

interface FastEthernet6/0
 description RED-SITE1-CE1
 ip vrf forwarding RED
 ip address 10.6.0.1 255.255.255.252
!
interface FastEthernet6/1
  description RED-SITE1-CE2
 ip vrf forwarding RED
 ip address 10.6.0.5 255.255.255.252
!
!
router eigrp 12
 !
 address-family ipv4 vrf RED autonomous-system 10
  no auto-summary
  redistribute bgp 65000 metric 1000000000 10 255 1 1500 route-map RED-SITE1-b2e
  network 10.6.0.0 0.0.0.3
  network 10.6.0.4 0.0.0.3
  distribute-list prefix RED-SITE1 in 
 exit-address-family
!
router bgp 65000
 !
 address-family ipv4 vrf RED
  no synchronization
  redistribute connected metric 50
  redistribute eigrp 10 route-map RED-SITE1-e2b
 exit-address-family
!
!
ip prefix-list RED-SITE1 seq 10 permit 10.99.1.0/24 le 32
!
route-map RED-SITE1-SoO permit 10
 set extcommunity soo 65000:3
!
route-map RED-SITE1-b2e permit 10
 set tag 65000
!
route-map RED-SITE1-e2b deny 10
 match tag 65000
!
route-map RED-SITE1-e2b permit 20
!








More information about the cisco-nsp mailing list