[c-nsp] Rewritting DSCP values on input - Bug? Not supported? User Error?
Brad Roldan
broldan at gmail.com
Fri May 27 13:26:22 EDT 2011
Here's my setup:
Test PC1 -----7609----Test PC2
The 7609 is running a variant of 12.2(33)SR. And the line card I am trying
to do this on is a WS-X6724-SFP. There are actually other routers in the
setup, but for the sake of simplicity, we only need to loop at the above
topology.
The task:
Rewrite DSCP on packets received from Test PC2 from CS3 (Class Selector 3)
to CS2 (Class Selector 2).
Here is the configuration I'm using:
! First create a class map to identify packets of interest
class-map match-all Priority
match ip dscp cs2 cs3 cs4
!
! Now define service policy that will do the re-writing
policy-map Priority-Rewrite
class Priority
set dscp cs2
!
! Now I apply this to an interface (inbound)
interface GigabitEthernet1/1
description Aggregation Port
no ip address
speed nonegotiate
mls qos trust dscp
!
interface GigabitEthernet1/1.25
description Test PC 2
encapsulation dot1Q 25
ip address 10.154.0.2 255.255.255.252
service-policy input Priority-Rewrite
!
When I send traffic marked with CS3 (0x60) through the router from Test PC2,
I noticed that the value is preserved all the way to Test PC1. What really
has me scratching my head is that when I reverse the logic and set the
service-policy as outbound, traffic from Test PC1 marked with 0x60 is
properly remarked to 0x40.
I'm hoping that I am just doing this wrong, and that it is possible to
re-write the DSCP tag on inbound.
I've tried using dscp-mutation, but that does not seem to work for inbound
traffic either.
Thanks,
Brad
More information about the cisco-nsp
mailing list