[c-nsp] Sup720 hanging after rommon starts loading IOS

Brielle Bruns bruns at 2mbit.com
Thu Apr 25 09:58:19 EDT 2013

On 4/24/13 2:31 PM, Paul wrote:
> For compact flash cards you need to put them in a PC, and remove the
> partition table (or format it FAT16).
> Once the partition table is completely removed , format it in your
> supervisor and it will work every time.
> The issue is that most flash cards come with the partition table already
> created and already formatted.

You also can't boot from a flash disk that hasn't been 
formatted/'blessed' by the platform its been inserted into.  This 
platform limitation also applies to differences in SUPs, such as between 
SUP32, SUP720, etc.

We had gotten a 720 with no flash, its internal flash had been wiped 
completely.  Tried using a flash formatted and loaded in the SUP32 we 
have - wouldn't successfully boot, then tried with a RSP16 from a 7500 
series, and still couldn't make it boot off the flash.

Finally succeeded in tickling the 720 to boot off of the one made in the 
RSP16 after fooling with its ROMMON.  Apparently, the format command 
adds some hidden flags or files to the flash which when not present or 
of the wrong type, it will cause the boot loader to pretend like the 
flash is unbootable even with the right files on it.

Important side note for anyone with a SUP720 - you can't load an IOS 
image over serial or TFTP with the ROMMON.  For serial, its particularly 
deceptive in that the command is there, but will fail every single time.

Yay Cisco!

Brielle Bruns
The Summit Open Source Development Group
http://www.sosdg.org    /     http://www.ahbl.org

More information about the cisco-nsp mailing list