[c-nsp] FW: Cisco blade switch config

Kevin Berry kevin.berry.70 at gmail.com
Wed Feb 20 08:45:27 EST 2013


 

 

From: Kevin Berry [mailto:kevin.berry.70 at gmail.com] 
Sent: Wednesday, February 20, 2013 11:02 AM
To: Nicolas KARP; Rich Davies
Subject: Re: [c-nsp] Cisco blade switch config

 

OK, so now we have:

 

CISCO-SW2#show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-------------------------------------------
----
1      Po1(SU)         LACP      Gi0/20(P)   Gi0/22(P)

 

And this seems fine, for the bundle, successfully.

 

show vlans still shows:

 

VLAN Name                             Status    Ports
---- -------------------------------- ---------
-------------------------------
1    default                          active    Gi0/1, Gi0/2, Gi0/4, Gi0/5
                                                Gi0/7, Gi0/9, Gi0/10, Gi0/11
                                                Gi0/12, Gi0/13, Gi0/14,
Gi0/15
                                                Gi0/16, Gi0/17, Gi0/23,
Gi0/24
2    DMZ                              active
3    VLAN0003                         active

 

So, VLAN 1 will talk. I can be on the Cisco switch, 10.10.0.13 for example,
and ping 10.10.0.13 (root) with no problem, obviously. However, I have other
vlans, 2,3,100......and they are on other IP segments, 172.x.x.x and
192.x.x.x and I cannot ping the root switch and nor can they talk to other
machines on the same segments.

 

My esx hosts are indeed configured on 10.10.0.x, but they have virtual
switches that have nics on those other segments and they used to talk fine.
Since unknown changes to Cisco, now they do not. I am at the switch console,
and cannot ping those vlans. !!!

 

show run

 

Current configuration : 4193 bytes
!
! Last configuration change at 17:19:02 UTC Mon Mar 1 1993
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CISCO-SW2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$9w6E$.RKflJhoBI76xeUabmMTC.
enable password D1 at bl0
!
no aaa new-model
system mtu routing 1500
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface Port-channel1
 description HP CORE-SWITCH
 switchport trunk allowed vlan 1-3,100
 switchport mode trunk
 spanning-tree portfast trunk
 spanning-tree vlan 1-10,100 cost 25
!interface FastEthernet0
 description ILO connection
 no ip address
 no ip route-cache cef
 no ip route-cache
 shutdown
!
interface GigabitEthernet0/1
 switchport trunk allowed vlan 1-3,90,100
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/2
 switchport trunk allowed vlan 1-3,90,100
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/3
 switchport trunk allowed vlan 1-3,90,100
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/4
switchport trunk allowed vlan 1-3,90,100
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/5
 switchport trunk allowed vlan 1-3,90,100
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/6
 switchport trunk allowed vlan 1-3,90,100
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/7
 switchport trunk allowed vlan 1-3,90,100
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/8
 switchport trunk allowed vlan 1-3,90,100
 switchport mode trunk
 spanning-tree portfast


interface GigabitEthernet0/17
 description ON-BOARD ADMIN
 spanning-tree portfast
!
interface GigabitEthernet0/18
 no switchport
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet0/19
 no switchport
 no ip address
 shutdown
 spanning-tree portfast trunk
!
interface GigabitEthernet0/20
 description HP CORE
 switchport trunk allowed vlan 1-3,100
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
 spanning-tree portfast trunk
!
interface GigabitEthernet0/21

 

no switchport
 no ip address
 shutdown
 spanning-tree portfast trunk
!
interface GigabitEthernet0/22
 description HP CORE
 switchport trunk allowed vlan 1-3,100
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
 spanning-tree portfast trunk
!
interface GigabitEthernet0/23
 description INTERNAL  CROSSCONNECT
 switchport trunk allowed vlan 1-3,100
 switchport mode trunk
 shutdown
 media-type internal
 spanning-tree portfast
!
interface GigabitEthernet0/24
 description INTERNAL  CROSSCONNECT
 switchswitchport mode trunk
 shutdown
 media-type internal
 spanning-tree portfast
!
interface Vlan1
 ip address 10.10.0.19 255.255.0.0
 no ip route-cache cef
 no ip route-cache
!
interface Vlan2
 ip address 192.168.1.234 255.255.255.0
 no ip route-cache cef
 no ip route-cache
!
interface Vlan3
 ip address 172.18.133.2 255.255.254.0
 no ip route-cache cef
 no ip route-cache
!
interface Vlan90
 ip address 10.15.0.1 255.255.248.0
 no ip route-cache cef
 no ip route-cacheport trunk allowed vlan 1-3,100

interface Vlan2
 ip address 192.168.1.234 255.255.255.0
 no ip route-cache cef
 no ip route-cache
!
ip default-gateway 10.10.1.1
ip http server
!
logging esm config
snmp-server community public RO

!
line con 0
line vty 0 4

 login
line vty 5 15
 
 login
!
end

On Wed, Feb 20, 2013 at 3:31 AM, Nicolas KARP <liste at karp.fr> wrote:

Hi Kevin,

 

to 16 are internal - - > ports connected to a blade server

Ports 17 to 24 are external  - - > ports connected to an external switch 

In your case, the port channel should be configured  between the external
ports and your external switch. 

The blade servers should not be part of the port channel. If you have a
blade which is using more than one slot, you can create another Port channel
between the Internal ports and the blade servers. You can't use the same
port-channel between multiple devices. 

What you can do is : 
++ remove the port-channel from port1 to 16.

++ Use one or 2 port channels between the blade center switches and your
core switches

Po1 (G0/20-22) connected to HP Core1

Po2 (G0/23-24) connected to another Blade Switch (Internal port) or
connected to HP-CORE2 direclty

Depends if you wa





Best Regards,

 




# - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - -
# - -   Nicolas KARP
# - -   Network and Security Engineer
# - -    Email : liste at karp.fr <mailto:nicolas at karp.fr> 
# - -    Linkedin :  http://www.linkedin.com/in/nicolaskarp
<http://www.linkedin.com/in/nicolaskarp> 
# - -    Viadeo :  <http://www.viadeo.com/fr/profile/nicolas.karp%20>
http://www.viadeo.com/fr/profile/nicolas.karp 
# - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - -



 

2013/2/19 Kevin Berry <kevin.berry.70 at gmail.com>

I have (2) Cisco blade switches running in redundant mode and each is
connected to the same HP ROOT switch on the other end. Each blade switch
has an LACP / Etherchannel link of 2 cables going to the HP root. STP
enabled on the Cisco's.

Noticed this on my Cisco-SW1 today:

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-------------------------------------------
----
1      Po1(SU)         LACP      Gi0/1(I)    Gi0/2(I)    Gi0/3(I)
                                 Gi0/4(D)    Gi0/5(D)    Gi0/6(I)
                                 Gi0/7(D)    Gi0/8(I)    Gi0/20(P)
                                 Gi0/22(P)

This shows that gi 0/20 & 0/22 are in use and bundled in port channel as
they should be. My blade servers (gi 0/1 - 0/8)  (some of which are down I
know) show (I) independant? Can anyone advise why?

Also, anyone know why a server like gi 0/1 for example will not talk on
multiple vlans?
I mean, they are set correctly on the HP, as I can ping out fine to those
vlans over there. Here is the Cisco config for those vlans. Cisco talks on
VLAN 1 fine. But Vlans 2 & 3, it doesnt.

!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree uplinkfast
no spanning-tree vlan 4-99
!
vlan internal allocation policy ascending
!
!
!
interface Port-channel1
 description HP CORE
 switchport trunk allowed vlan 1-3,100
 switchport mode trunk
 spanning-tree portfast trunk
 spanning-tree vlan 4-99 cost 20
!
!
interface GigabitEthernet0/1
 switchport trunk allowed vlan 1-3,100
 switchport mode trunk
 speed 1000
 channel-group 1 mode active
 spanning-tree portfast
!
interface GigabitEthernet0/2
 switchport trunk allowed vlan 1-3,100
 switchport mode trunk
 speed 1000
 channel-group 1 mode active
 spanning-tree portfast
interface GigabitEthernet0/20
 description HP CORE
 switchport trunk allowed vlan 1-3,100
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
 spanning-tree portfast trunk
!
interface GigabitEthernet0/21
 no switchport
 no ip address
 shutdown
 spanning-tree portfast trunk
!
interface GigabitEthernet0/22
 description HP CORE
 switchport trunk allowed vlan 1-3,100
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
 spanning-tree portfast trunk
!
interface GigabitEthernet0/23
 description INTERNAL CROSSCONNECT
 switchport trunk allowed vlan 1-3,100
 switchport mode trunk
 media-type internal
 channel-protocol lacp
 spanning-tree portfast trunk

interface GigabitEthernet0/24
 description INTERNAL CROSSCONNECT
 no switchport
 no ip address
 no ip route-cache
 media-type internal
 spanning-tree portfast
!
interface Vlan1
 ip address 10.10.0.18 255.255.0.0
 no ip route-cache
 no ip mroute-cache
!
interface Vlan2
 no ip address
 no ip route-cache
 no ip mroute-cache
!
interface Vlan3
 no ip address
 no ip route-cache
 no ip route-cache
--------------------------------------------------

Anyone can help?????
_______________________________________________
cisco-nsp mailing list  cisco-nsp at puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/

 

 



More information about the cisco-nsp mailing list