[c-nsp] Peering between VRF's in the same 6500 VSS

Oliver Boehmer (oboehmer) oboehmer at cisco.com
Fri Oct 4 06:07:43 EDT 2013


not sure how you set this up, but best force an eBGP session between the
two VRFs, using a config like below which also uses unique BGP router-ids
per VRF, otherwise the updates would be dropped..

	oli


int <interface1>
 ip vrf forwarding VRF-A
 ip address 10.0.9.1 255.255.255.0
int <interface2>
 ip vrf forwarding VRF-B
 ip address 10.0.9.2 255.255.255.0
!

router bgp 65000
 address-family ipv4 vrf VRF-A
  neighbor 10.0.9.2 remote-as 65112
  neighbor 10.0.9.2 local-as 65111 no-prepend replace-as
  neighbor 10.0.9.2 activate
  bgp router-id 10.0.9.1
 exit-address-family
 !
 address-family ipv4 vrf VRF-B
  redistribute connected
  neighbor 10.0.9.1 remote-as 65111
  neighbor 10.0.9.1 local-as 65112 no-prepend replace-as
  neighbor 10.0.9.1 activate
  bgp router-id 10.0.9.2
 exit-address-family
!



On 04/10/2013 11:09, "Alexander Wågberg" <alex.wagberg at gmail.com> wrote:

>Hi,
>
>I have the following scenario:
>
>ASR1002X -- VRF-A -- 6500 -- IPS -- 6500 -- VRF-B -- ASR1002X
>
>The ASR1002X to the left is the same as the one to the right, as well as
>the 6500. The IPS in this picture acts like a "loop cable". Between the
>vrf's I've setup a BGP-peer, the goal is that traffic should flow though
>the IPS when going from vrf A to B and B to A.
>
>The problem is that, prefixes sent from the ASR in both VRF's are not
>learned in the other vrf on the ASR. The 6500 learns routes from both
>vrf's
>and announce routes to the ASR in both vrf's. The ASR is also
>route-reflector-client for both vrf's.
>
>Why can't I see routes from vrf B in vrf A in the ASR ?
>
>BR,
>
>--
>Alexander "wberg" Wågberg
>_______________________________________________
>cisco-nsp mailing list  cisco-nsp at puck.nether.net
>https://puck.nether.net/mailman/listinfo/cisco-nsp
>archive at http://puck.nether.net/pipermail/cisco-nsp/




More information about the cisco-nsp mailing list