[c-nsp] Sharing a shaping policy?

CiscoNSP List cisconsp_list at hotmail.com
Sun Jul 6 17:54:30 EDT 2014


Thank you very much James!!

Date: Sun, 6 Jul 2014 09:56:12 +0100
Subject: RE: [c-nsp] Sharing a shaping policy?
From: jwbensley at gmail.com
To: cisconsp_list at hotmail.com
CC: cisco-nsp at puck.nether.net



On 5 Jul 2014 00:10, "CiscoNSP List" <cisconsp_list at hotmail.com> wrote:
> Site A will have vlan 10 - 50Mb service, placed in VRF (So all ok to shape on Client side ME3400, and also on our PE at L3)

>

>

> Site B will have two vlans - 20 and 30 - 50Mb service, vlan 20 placed in VRF, vlan 30 trunked to a new colo switch they are now installing in the DataCentre.
The following config should do what you want; you would need to make service instances on the L2 aggregation port for each VLAN coming in and set up a bridge domain for each.  You can match the two VLANs going to site B in one class map and shape that to 50Mbps.

conf t
vlan 10

 name Cust1-SiteA

vlan 20

 name Cust1-SiteB

vlan 30

 name Cust1-SiteB-L2
int gi0/1

 description *L2 Trunk from Tail Provider*

 switchport mode trunk

 switchport trunk allowed vlan none

 !

 service instance 10 ethernet

  description Cust1-VLAN10-SiteA

  encapsulation dot1q 10

  rewrite ingress tag pop 1 symmetric

  bridge-domain 10

 !

 service instance 20 ethernet

  description Cust1-VLAN20-SiteB

  encapsulation dot1q 20

  rewrite ingress tag pop 1 symmetric

  bridge-domain 20

 !

 service instance 30 ethernet

  description Cust1-VLAN30-SiteB-L2

  encapsulation dot1q 30

  rewrite ingress tag pop 1 symmetric

  bridge-domain 30

 !
class-map match-any CM-Cust1-SiteB-50Mbps

match service instance ethernet 20

match service instance ethernet 30
policy-map PM-CPE-OUT-PARENT

 class CM-Cust1-SiteB-20M

  shape average 20000000
Interface Vlan10

 Description *Link to Cust1 Site A*

 ip vrf forwarding Cust1

 ip address 10.0.0.1 255.255.255.252
Interface Vlan 20

 Description *Link to Cust1 Site B*

 ip vrf forwarding Cust1

 ip address 10.0.0.5 255.255.255.252
! VLAN 30 the L2 link is bridge to bridge domain 30. No need for a Layer 3 SVI. On the outgoing port to the Cust DC put that I to VLAN 30 also
Interface gi0/2

 Description Link to DC

 Switchport mode trunk

 Switchport trunk allowed vlan 30
! If you have multiple VLANs going to the DC you can use service instances on that port too, or if the link to the DC is another tail circuit on gi0/1 from the same provider you can modify service instance 30 to bridge both VLANs together (VLAN 30 and the DC VLaN).

Cheers,

James. 		 	   		  


More information about the cisco-nsp mailing list