[cisco-voip] 2821 gateways with g703 cards

Hart, Kevin Kevin.Hart at brooks.com
Mon Feb 27 14:53:15 EST 2006


Hello all,

I'm in the process of configuring two 2821 gateways to use with Call Manager
4.1.3. Both of the gateways have VWIC-IMFT-G703 E1 cards and one of the
gateways also has 3 VIC2-4FXO cards for backup. 
I started to configure the gateways with MGCP thinking I could use the
VWIC-1MFT-E1 option in Call Manager. However, I have been told by Cisco that
the VWIC-1MFT-G703 cards are not supported with MGCP and that I will have to
configure the 2821's as H323 gateways.

Does anyone have any experience, tips, pointers, gotchas, IOS example
configurations for this type of configuration?  The equipment is being
installed in Mexico with the E1 handoffs coming from Aventel.

I've included my current IOS configurations (below), which I got from this
site. 

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186
a0080094636.shtml#cm33

Thanks!
Kevin


2821 with VWIC-1MFT-G703 and VIC2-4FX0
========================================
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname 28214fx0
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0
ip subnet-zero
!
!
ip cef
!
!
ip domain name somedomainname.com
isdn switch-type primary-net5
!
voice-card 0
 dspfarm
!
!
controller E1 0/0/0
 framing NO-CRC4
 pri-group timeslots 1-31
!
!
!
interface GigabitEthernet0/0
 ip address X.X.X.x 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0:15
 no ip address
 isdn switch-type primary-net5
 isdn incoming-voice voice
 no cdp enable
!
ip default-gateway X.X.X.x
ip classless
ip route 0.0.0.0 0.0.0.0 X.X.X.x
!
!
control-plane
!
voice-port 0/0/0:15
!
voice-port 0/1/0
 timing hookflash-out 500
!
voice-port 0/1/1
 timing hookflash-out 500
!
voice-port 0/1/2
 timing hookflash-out 500
!
voice-port 0/1/3
 timing hookflash-out 500
!
voice-port 0/2/0
 timing hookflash-out 500
!
voice-port 0/2/1
 timing hookflash-out 500
!
voice-port 0/2/2
 timing hookflash-out 500
!
voice-port 0/2/3
 timing hookflash-out 500
!
voice-port 0/3/0
 timing hookflash-out 500
!
voice-port 0/3/1
 timing hookflash-out 500
!
voice-port 0/3/2
 timing hookflash-out 500
!
voice-port 0/3/3
 timing hookflash-out 500
!
mgcp
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
!
!
dial-peer voice 999010 pots
 port 0/1/0
!
dial-peer voice 999011 pots
 port 0/1/1
!
dial-peer voice 999012 pots
 port 0/1/2
!
dial-peer voice 999013 pots
 port 0/1/3
!
dial-peer voice 999014 pots
 port 0/2/0
!
dial-peer voice 999015 pots
 port 0/2/1
!
dial-peer voice 999016 pots
 port 0/2/2
!
dial-peer voice 999017 pots
 port 0/2/3
!
dial-peer voice 999018 pots
 port 0/3/0
!
dial-peer voice 999019 pots
 port 0/3/1
!
dial-peer voice 999020 pots
 port 0/3/2
!
dial-peer voice 999021 pots
 port 0/3/3
!
dial-peer voice 6 voip
 destination-pattern XXXX....
 session target ipv4:X.X.X.X
 dtmf-relay h245-alphanumeric
 codec g711ulaw
!
dial-peer voice 1 pots
 destination-pattern 9T
 direct-inward-dial
 port 0/0/0:15
!
!
line con 0
 login local
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end


2821 with VWIC-1MFT-G703
========================================
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname 2821g703
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0
ip subnet-zero
!
!
ip cef
!
!
ip domain name somedomainname.com
isdn switch-type primary-net5
!
voice-card 0
 no dspfarm

!
controller E1 0/0/0
 framing NO-CRC4
 pri-group timeslots 1-31
!
!
interface GigabitEthernet0/0
 ip address X.X.X.X 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0:15
 no ip address
 isdn switch-type primary-net5
 isdn incoming-voice voice
 no cdp enable
!
ip default-gateway X.X.X.X
ip classless
ip route 0.0.0.0 0.0.0.0 X.X.X.X
!
!
control-plane
!
!
voice-port 0/0/0:15
!
!
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
!
!
!
dial-peer voice 5 voip
 destination-pattern 8863....
 session target ipv4:192.168.73.13
 dtmf-relay h245-alphanumeric
 codec g711ulaw  
!
dial-peer voice 1 pots
 destination-pattern 9T
 direct-inward-dial
 port 0/0/0:15
!
!
!
line con 0
 login local
line aux 0
line vty 0 4
 session-timeout 25
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end





_____________________________________________________________________
This email message, including any attachments, may contain confidential and proprietary information for the sole use of the intended recipient.  If you are not the intended recipient, you are hereby notified that any use, copying or dissemination of this message is strictly prohibited.  If you received this message in error, please notify Brooks Automation, Inc. immediately by reply email or by calling Brooks US Headquarters at +1 978-262-2400. Then delete this message from your system, without making any copy or distribution.  Thank you.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://puck.nether.net/pipermail/cisco-voip/attachments/20060227/cb1b2c5a/attachment-0001.html


More information about the cisco-voip mailing list