[cisco-voip] Cannot transfer an off net call to another codec through an h323 gw

Anthony Kouloglou akoul at dataways.gr
Fri May 4 10:53:17 EDT 2007


Here it is

all 9xx extensions and voice gateway are in a region that uses g711.

only 964 is on a region that uses g729.


!
resource policy
!
network-clock-participate wic 0
!
!
ip cef
!
!
no ip domain lookup
!
isdn switch-type basic-net3
!
voice-card 0
 no dspfarm
!
!
voice call disc-pi-off
voice rtp send-recv
!
voice service voip
!
!
!
!
!        
!
!
!
!
!
!
!
!
voice translation-rule 1
 rule 1 /^51/ /951/
 rule 2 /^52/ /952/
 rule 3 /^53/ /290/
 rule 4 /^54/ /954/
 rule 5 /^55/ /955/
 rule 6 /^56/ /956/
 rule 7 /^57/ /957/
 rule 8 /^61/ /961/
 rule 9 /^63/ /963/
 rule 10 /^64/ /964/
 rule 15 /.*/ /290/
!
!
voice translation-profile TP01
 translate called 1
!
!
!
!

!
!
!
!
!
interface FastEthernet0/0
 no ip address
 no ip route-cache cef
 no ip route-cache
 duplex full
 speed 100
 no mop enabled
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 213.140.132.21 255.255.255.192
 no ip route-cache
!        
interface FastEthernet0/0.100
 encapsulation dot1Q 100
 ip address 192.168.2.254 255.255.255.0
 no ip route-cache
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 192.168.2.254
!
interface FastEthernet0/1
 ip address 192.168.101.1 255.255.255.0
 duplex full
 speed 100
!
interface BRI0/0/0
 no ip address
 isdn switch-type basic-net3
 isdn overlap-receiving
 isdn point-to-point-setup
 isdn incoming-voice voice
 isdn static-tei 0
!
interface BRI0/0/1
 no ip address
 isdn switch-type basic-net3
 isdn overlap-receiving
 isdn point-to-point-setup
 isdn incoming-voice voice
 isdn static-tei 0
!
ip route 0.0.0.0 0.0.0.0 213.140.132.14
!
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:
no ip nat create flow-entries
!
kron policy-list testpl
 cli show runnin
!
dialer-list 1 protocol ip permit
snmp-server community public RO
route-map test permit 10
!
!
!
!        
control-plane
!
!
!
voice-port 0/0/0
 translation-profile incoming TP01
 compand-type a-law
 bearer-cap Speech
!
voice-port 0/0/1
 translation-profile incoming TP01
 compand-type a-law
 bearer-cap Speech
!
voice-port 0/1/0
 cptone GR
 connection plar 953
 caller-id enable
!
voice-port 0/1/1
!
!
!
!
!
dial-peer voice 1 pots
 destination-pattern 0T
 direct-inward-dial
 port 0/0/0
!
dial-peer voice 2 pots
 preference 1
 destination-pattern 0T
 direct-inward-dial
 port 0/0/1
!
dial-peer voice 3 pots
 destination-pattern 069T
 port 0/1/0
 prefix 69
!
dial-peer voice 10 voip
 destination-pattern 9..
 session target ipv4:192.168.2.5
 dtmf-relay h245-alphanumeric
 codec g711alaw
 fax rate disable
 fax protocol pass-through g711alaw
 no vad
!
dial-peer voice 11 voip
 destination-pattern 2..
 session target ipv4:192.168.2.5
 dtmf-relay h245-alphanumeric
 codec g711alaw
 fax rate disable
 fax protocol pass-through g711alaw
 no vad
!
dial-peer voice 4 pots
 preference 1
 destination-pattern 069T
 port 0/0/0
 prefix 178969
!
dial-peer voice 5 pots
 preference 1
 destination-pattern 069T
 port 0/0/1
 prefix 178969
!
dial-peer voice 12 voip
 destination-pattern 97.
 session target ipv4:10.0.0.109
 dtmf-relay h245-alphanumeric
!
dial-peer voice 22 voip
 destination-pattern 14..
 session target ipv4:10.200.4.5
 codec g711alaw
!
dial-peer voice 964 voip
 destination-pattern 964
 session target ipv4:192.168.2.5
 dtmf-relay h245-alphanumeric
!
!
no dial-peer outbound status-check pots
!
!
call-manager-fallback
 max-conferences 8 gain -6
 transfer-system full-consult
 ip source-address 192.168.2.254 port 2000
 max-ephones 20
 max-dn 40
 no huntstop
 pickup 999
 alias 1 121 to 952
 alias 2 122 to 955
 alias 3 123 to 956
 alias 4 124 to 954
 alias 5 125 to 964
 alias 6 126 to 957
 alias 7 127 to 951
 alias 8 128 to 961
 alias 9 110 to 953
 alias 10 999 to 956
 alias 11 999 to 964
!
!
line con 0
line aux 0
line vty 0 4
 

Clouse, Chris wrote:
> Can you send me a copy of your config?
>
> Christopher Clouse, CCNP CCDP CCVP MCP Network+
>
>
> -----Original Message-----
> From: cisco-voip-bounces at puck.nether.net
> [mailto:cisco-voip-bounces at puck.nether.net] On Behalf Of Anthony
> Kouloglou
> Sent: Friday, May 04, 2007 9:24 AM
> To: cisco-voip at puck-nether.net
> Subject: [cisco-voip] Cannot transfer an off net call to another codec
> through an h323 gw
>
> Hi,
> i have problems in transfering an incoming call established with g711 
> codec, to another device that uses g729.
> So, there is a CCM 5.X with extensions 1XXX and 2XXX for example.
>
> 1.VGW (H323)
> 2. ExtA 1000
>    ExtB 1001
>
> 3  ExtC 2000
>
> A, B and voicegw are in the same devicepool and use g711.
> C is in another device pool that use g729 for calls to the other device 
> pool.
>
> GW has 2 different voip dial-peers:
>  one with g711 to connect with extensions A, B, and
>  one with g729 to connect with C
> and one pots dial-peer to call outside to the TELCO numbers
>
> Incoming calls to vgw from the telco, work fine either to extensions A,B
>
> or C directly (depending on the dial-peer, it uses the appropriate
> codec).
> When A, calls B directly, B can tranfer the call to C
> When A, receives a call from the Telco, cannot tranfer it to C: the call
>
> drops and busy tone is played to both ends.
>
> Does, h323 needs something special for this config?
>
> thanks
> anthony
>
>
>
> _______________________________________________
> cisco-voip mailing list
> cisco-voip at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-voip
>
>   


More information about the cisco-voip mailing list