[cisco-voip] MGCP Fallback time...

Jonathan Charles jonvoip at gmail.com
Fri May 25 20:57:21 EDT 2007


Here it is...


Current configuration : 7664 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PINKY1
!
boot-start-marker
boot-end-marker
!
logging buffered 1000000 warnings
enable secret 5 $1$OGFk$TCpZe0TS9B4anq.Q6MJIQ0
!
no aaa new-model
!
resource policy
!
network-clock-participate wic 0
ip subnet-zero
!
!
ip cef
!
!
no ip domain lookup
ip domain name amli.com
isdn switch-type primary-ni
!
voice-card 0
 no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
application
 global
  service alternate Default
 !
!
!
crypto pki trustpoint TP-self-signed-2413116866
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2413116866
 revocation-check none
 rsakeypair TP-self-signed-2413116866
!
!
crypto pki certificate chain TP-self-signed-2413116866
 certificate self-signed 01
  3082024C 308201B5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32343133 31313638 3636301E 170D3037 30353233 31363136
  35385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 34313331
  31363836 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C7DB 31404006 EEE793F7 398F1A35 07509CDB D444F92D 79FF5F4A 73A01D89
  B77EF538 DF19058C CCE57B9C ABF0597B DD60FAE8 3CD96D2E DD46A581 15B15F38
  DC3368D4 074A66F7 9E484DED E36394F6 05EA9FDA F81632FC 31D90520 256D497E
  CE8F91E4 042BD4E6 824C0DE6 F3107769 F0FFA0E0 65321D02 025D7F33 65C6DDE4
  027F0203 010001A3 74307230 0F060355 1D130101 FF040530 030101FF 301F0603
  551D1104 18301682 14414D4C 4944414C 32383131 2E616D6C 692E636F 6D301F06
  03551D23 04183016 80144221 418BAB16 E9B5F101 F02AA6B0 0E6B618D 83BA301D
  0603551D 0E041604 14422141 8BAB16E9 B5F101F0 2AA6B00E 6B618D83 BA300D06
  092A8648 86F70D01 01040500 03818100 905A4A1F 2A2F0BD5 6F3E7634 C6A122D1
  5EB8D0D3 11AC6A79 6C70001C 3E4D1923 6EDE6337 738A9FE1 3B9574C7 CFE4050B
  67CD8790 BC4F8EA1 5C209CB8 8CC175E7 8E27CFFE E3492ADD 874CEBF1 080244B0
  90D92709 B82A7B48 F3EF1DA5 6A32664E 00794B9A 5DBE2060 FDB89303 E0692D39
  4884D825 FB237370 82321596 A079BB75
  quit
username cisco privilege 15 secret 5 $1$sBAo$/JviEK.cbQuLpFFEKRRsb/
!
!
controller T1 0/0/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
!
!
interface FastEthernet0/0
 description IP VOICE SUBNET
 ip address 172.27.128.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.27.128.1
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 23 permit 10.10.10.0 0.0.0.7
!
!
!
control-plane
!
!
!
voice-port 0/0/0:23
 input gain -3
 output attenuation 3
 cptone C1
!
voice-port 0/1/0
 input gain -3
 cptone C1
 timing hookflash-out 50
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
ccm-manager fallback-mgcp
ccm-manager redundant-host 172.28.2.5
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 172.29.128.4
ccm-manager config
ccm-manager download-tones
!
mgcp
mgcp call-agent 172.29.128.5 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp package-capability fxr-package
mgcp package-capability pre-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax rate 9600
mgcp rtp payload-type g726r16 static
!
mgcp profile default
!
!
!
dial-peer voice 100 pots
 incoming called-number .
 direct-inward-dial
 port 0/0/0:23
!
dial-peer voice 101 pots
 incoming called-number .
 direct-inward-dial
!
dial-peer voice 103 pots
 preference 2
 destination-pattern 9[2-9]......
 progress_ind alert enable 8
 progress_ind progress enable 8
 progress_ind connect enable 8
 direct-inward-dial
 port 0/0/0:23
 forward-digits 7
!
dial-peer voice 104 pots
 preference 1
 destination-pattern 91[2-9]..[2-9]......
 progress_ind alert enable 8
 progress_ind progress enable 8
 progress_ind connect enable 8
 direct-inward-dial
 port 0/0/0:23
 forward-digits 11
!
dial-peer voice 107 pots
 preference 2
 destination-pattern 9[369]11
 progress_ind alert enable 8
 progress_ind progress enable 8
 progress_ind connect enable 8
 incoming called-number .
 direct-inward-dial
 forward-digits 3
!
dial-peer voice 110 pots
 preference 1
 destination-pattern 9011T
 incoming called-number .
 direct-inward-dial
 port 0/0/0:23
 prefix 011
!
dial-peer voice 111 pots
 preference 2
 destination-pattern 9011T
 incoming called-number .
 direct-inward-dial
 port 0/0/0:23
 prefix 011
!
dial-peer voice 112 pots
 preference 2
 destination-pattern 9972.......
 incoming called-number .
 direct-inward-dial
 port 0/0/0:23
 forward-digits 10
!
dial-peer voice 113 pots
 preference 2
 destination-pattern 9214.......
 incoming called-number .
 direct-inward-dial
 port 0/0/0:23
 forward-digits 10
!
dial-peer voice 114 pots
 preference 2
 destination-pattern 9469.......
 incoming called-number .
 direct-inward-dial
 port 0/0/0:23
 prefix 011
!
dial-peer voice 115 pots
 preference 2
 destination-pattern 9817.......
 incoming called-number .
 direct-inward-dial
 port 0/0/0:23
 forward-digits 10
!
dial-peer voice 999010 pots
 service mgcpapp
 port 0/1/0
!
dial-peer voice 116 pots
 preference 2
 destination-pattern 911
 incoming called-number .
 direct-inward-dial
 port 0/1/0
 forward-digits 3
!
dial-peer voice 117 pots
 preference 2
 destination-pattern 9911
 incoming called-number .
 direct-inward-dial
 port 0/1/0
 forward-digits 3
!
dial-peer voice 102 pots
 preference 1
 destination-pattern 9[2-9]......
 progress_ind alert enable 8
 progress_ind progress enable 8
 progress_ind connect enable 8
 direct-inward-dial
 port 0/0/0:23
 forward-digits 7
!
dial-peer voice 993310 pots
 service mgcpapp
 port 0/0/0:23
!
dial-peer voice 993311 pots
 service mgcpapp
 port 0/1/0
!
!
!
call-manager-fallback
 max-conferences 8 gain -6
 timeouts interdigit 5
 ip source-address 172.27.128.2 port 2000
 max-ephones 42
 max-dn 144
 default-destination 6712
 voicemail 8000
!
banner login ^CCC
-----------------------------------------------------------------------
This system and its data contents are the property of Pinky the Wonder Sperm
 and/or its subsidiaries,and contains confidential and
proprietary information.  Any unauthorized use of this system or data
is strictly prohibited and may subject you to disciplinary action, up
to and including termination, civil penalties, and/or criminal
prosecution and penalties.  Users have no expectation of privacy
relating to the use of the system.  By using the system, you expressly
consent to the monitoring and review of your use of the system and all
data viewed, entered, created, received, stored, or transmitted through
the system.
-----------------------------------------------------------------------
^C
!
line con 0
 exec-timeout 0 0
 password
 logging synchronous
 login
line aux 0


On 5/25/07, Lelio Fulgenzi <lelio at uoguelph.ca> wrote:
> not sure if this is what's happening in your case, but i had a default route
> in my original setup that caused a delay. i had to put some ACLs on it to
> make sure it didn't try to connect to the ccm server over a different route
> (which was blocked somewhere else).
>
> just a thought.
>
> maybe you can post your config.
>
> ----- Original Message -----
> From: "Jonathan Charles" <jonvoip at gmail.com>
> To: "ciscovoip" <cisco-voip at puck.nether.net>
> Sent: Friday, May 25, 2007 8:34 PM
> Subject: [cisco-voip] MGCP Fallback time...
>
>
> >I have a new SRST router (MGCP back to CCM)...
> >
> > When we yank the WAN, it takes about 13 minutes for the router to
> > realize that CCM is down and kill the PRI... and revert to H.323 mode.
> >
> > If you look at the attached log file, you can see that the phones are
> > registering to the router, and a full 13 minutes later the PRI goes
> > down...
> >
> > Is there a way to change this to make it quicker?
> >
> > IOS is 12.4.3g
> >
> >
> >
> >
> > Jonathan
> >
>
>
> --------------------------------------------------------------------------------
>
>
> > _______________________________________________
> > cisco-voip mailing list
> > cisco-voip at puck.nether.net
> > https://puck.nether.net/mailman/listinfo/cisco-voip
> >
>
>


More information about the cisco-voip mailing list