[cisco-voip] issue with an h.323 gateway analog port
Chris Beck - CEC
CBeck at careered.com
Thu Nov 15 11:37:38 EST 2007
I need some assistance with an h.323 gateway issue.
This gateway has a PRI for inbound/outbound calling, and we select for outbound calling with destination 9T. There are also some analog ports for connecting fax machines, etc. Each of these has a specific 4 digit destination pattern such as 3809.
My problem is with allowing these analog devices to dial outbound over the PRI. They go offhook to dial "96025551212", and the outbound dialpeer matches at 9602. This gets presented to the carrier, who rejects the call.
How do I make the gateway collect and forward all digits? I tried the forward-digits all command, and it didn't work?
Here is the config. Thanks to all in advance for your assistance.
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname S007VGW1
!
boot-start-marker
boot system flash flash:c3825-ipvoicek9-mz.124-15.T1.bin
boot-end-marker
!
logging buffered 51200 warnings
enable password 7 04780A570624425A0C5A
!
no aaa new-model
clock timezone ARIZONA -7
network-clock-participate wic 0
network-clock-select 1 T1 0/0/0
network-clock-select 2 T1 0/0/1
ip cef
!
!
!
!
ip domain name gateways.cec.root.careered.com
ip host-list DDNS
host 10.0.21.200 10.0.21.202
ip name-server 10.0.21.200
ip name-server 10.0.21.202
ip ddns update method ddns
DDNS
interval maximum 0 2 0 0
interval minimum 0 0 5 0
!
ip dhcp-client update dns server none
multilink bundle-name authenticated
!
isdn switch-type primary-ni
voice-card 0
no dspfarm
dsp services dspfarm
!
!
!
voice rtp send-recv
!
voice service voip
h323
call preserve
!
!
voice class codec 100
codec preference 1 g711ulaw
codec preference 2 g729r8
!
!
!
voice class h323 1
h225 timeout tcp establish 3
!
!
!
!
!
!
!
!
!
voice translation-rule 1
rule 1 /4804253143/ /3143/
rule 2 /4804253038/ /3038/
rule 4 /4802463802/ /3802/
rule 5 /4804253210/ /3210/
rule 6 /4804253208/ /3208/
rule 7 /4804253209/ /3209/
!
!
voice translation-profile FXS
translate called 1
!
!
fax receive called-subscriber $d$
fax interface-type fax-mail
mta send server 10.0.21.120 port 25
mta send server 10.0.21.121 port 25
mta send subject FAX RECIEVED AT SCI SCOTTSDALE CAMELBACK (S007VGW1)
mta send postmaster replace at careered.com
mta send mail-from hostname careered.com
mta send mail-from username $s$
mta send success-fax-only
!
application
service fax_detect flash:app_faxmail_onramp.2.0.0.0.tcl
!
!
!
crypto pki trustpoint TP-self-signed-3133192265
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3133192265
revocation-check none
rsakeypair TP-self-signed-3133192265
!
!
crypto pki certificate chain TP-self-signed-3133192265
certificate self-signed 01
30820260 308201C9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 33313333 31393232 3635301E 170D3037 31303035 31393035
33305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 31333331
39323236 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
81009A45 2F47DF22 17E3FB09 AE68B0EF 3A2545E7 DEF8A830 A6730D62 CDB8976D
EF20C24A E16CE747 5E668843 CAB9F47D 4B9FD8F4 49893C20 D70D570D ABA8B249
EFF079C6 EC3C02F3 304559E4 7CD771D1 6834D5A6 6882FB04 463557C7 993ECFE7
FC16FA5E 7FF607D8 94E836CB A5B0AC09 CDDC43A6 1E7D93B7 FB3A2202 A2BCDAE6
579B0203 010001A3 81873081 84300F06 03551D13 0101FF04 05300301 01FF3031
0603551D 11042A30 28822653 30303756 4757312E 766F6963 652E6461 74616365
6E746572 2E636172 65657265 642E636F 6D301F06 03551D23 04183016 80140A68
C51078EB C180650B 9E4747FC 2196386D 9616301D 0603551D 0E041604 140A68C5
1078EBC1 80650B9E 4747FC21 96386D96 16300D06 092A8648 86F70D01 01040500
03818100 98832600 012BBAC4 835F8C7E CA01DAC6 2C4B0549 046B627A 3564CFBE
B05C64BD 968AFB85 1B1BB2D1 836FDC85 40F69A23 D2933AAA 76E50975 A4D509A8
BAC2CC61 831FCA99 B4B6E634 9F315C12 82B0707A 3CD3A53B 80168827 EC29EFDA
D9BCE893 E6E1C056 E75C6C2D 8284C0A4 61225873 B60D5B40 EB69B61C AB23CBC1 94A61BB4
quit
!
!
username cec privilege 15 secret 5 $1$4UWW$3ju6fNIzIa5DrPzQ0Zt3M.
archive
log config
hidekeys
!
!
controller T1 0/0/0
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 0/0/1
shutdown
framing sf
linecode ami
ds0-group 1 timeslots 1-24 type e&m-wink-start
!
!
!
!
!
interface Loopback0
ip address 10.254.7.5 255.255.255.255
!
interface GigabitEthernet0/0
description VoiceGateway Camelback LAN
ip ddns update hostname s007vgw1.gateways.cec.root.careered.com
ip ddns update ddns host-group DDNS
ip address 10.7.21.10 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface Serial0/0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
ip route 0.0.0.0 0.0.0.0 10.7.21.1
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:23
!
voice-port 0/0/1:1
!
voice-port 2/0/0
no battery-reversal
timeouts call-disconnect 5
timeouts wait-release 5
!
voice-port 2/0/1
!
voice-port 2/0/2
!
voice-port 2/0/3
!
voice-port 2/0/4
!
voice-port 2/0/5
!
voice-port 2/0/6
!
voice-port 2/0/7
!
voice-port 2/0/8
!
voice-port 2/0/9
!
voice-port 2/0/10
!
voice-port 2/0/11
!
voice-port 2/0/12
!
voice-port 2/0/13
!
voice-port 2/0/14
!
voice-port 2/0/15
!
voice-port 2/0/16
!
voice-port 2/0/17
!
voice-port 2/0/18
!
voice-port 2/0/19
!
voice-port 2/0/20
!
voice-port 2/0/21
!
voice-port 2/0/22
!
voice-port 2/0/23
!
ccm-manager music-on-hold
!
!
sccp local GigabitEthernet0/0
sccp ccm 10.0.211.7 identifier 2 version 4.1
sccp ccm 10.245.211.5 identifier 1 version 4.1
sccp
!
sccp ccm group 1
description subscriber pair 1
associate ccm 1 priority 1
associate ccm 2 priority 2
associate profile 1 register S007_TCODE1
associate profile 2 register S007_CONF1
!
dspfarm profile 1 transcode
description callcenter transcode
codec g711ulaw
codec g729r8
maximum sessions 6
associate application SCCP
!
dspfarm profile 2 conference
description DG hardware conference
codec g711ulaw
codec g729r8
maximum sessions 12
associate application SCCP
!
!
dial-peer voice 100 voip
translation-profile incoming FXS
preference 1
destination-pattern ....
voice-class codec 100
voice-class h323 1
session target ipv4:10.245.211.5
dtmf-relay h245-alphanumeric
!
dial-peer voice 101 voip
translation-profile incoming FXS
preference 2
destination-pattern ....
voice-class codec 100
session target ipv4:10.0.211.7
dtmf-relay h245-alphanumeric
!
dial-peer voice 1000 pots
paramspace callfeature med-inact-disc-cause 44
paramspace callfeature med-inact-det enable
paramspace callfeature med-inact-action syslog
destination-pattern 9T
direct-inward-dial
port 0/0/0:23
!
dial-peer voice 1001 pots
paramspace callfeature med-inact-det enable
paramspace callfeature med-inact-disc-cause 44
paramspace callfeature med-inact-action syslog
destination-pattern 9T
direct-inward-dial
!
dial-peer voice 3143 pots
destination-pattern 3143
port 2/0/0
!
dial-peer voice 3038 pots
destination-pattern 3038
port 2/0/1
!
dial-peer voice 711 pots
destination-pattern 0711
port 2/0/2
!
dial-peer voice 3810 pots
description FAX
destination-pattern 3810
port 2/0/3
!
dial-peer voice 3808 pots
description CC Machine
destination-pattern 3808
port 2/0/4
!
dial-peer voice 3809 pots
description CC Machine
destination-pattern 3809
port 2/0/5
forward-digits all
!
!
!
call-manager-fallback
max-conferences 8 gain -6
transfer-system full-consult
ip source-address 10.7.21.10 port 2000
max-ephones 168
max-dn 168 dual-line
access-code pri 9 direct-inward-dial
moh S007.ULAW.wav
multicast moh 239.1.1.1 port 16392 route 10.7.21.10 10.254.7.5
time-zone 6
!
banner login ^CC
*********
* *** ******
**** ** ******
***** * * *****
***** * * *****
***** ** * ***** SCOTTSDALE CULINARY INSTITUTE - SCOTTSDALE
**** ** ** ****** SCOTTSDALE, ARIZONA
******* *** ****** ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
****** **** ****** PROPERTY OF CAREER EDUCATION CORPORATION
**** **************
** **************
**************
***************
*************
*********
^C
!
line con 0
password 7 1336471F091E01387B65
login
stopbits 1
line aux 0
stopbits 1
line vty 0 4
privilege level 15
password 7 06355F2C4E5C0C0B5556
login
transport input telnet ssh
line vty 5 15
privilege level 15
password 7 122A551A101909167A6A
login
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp clock-period 17180083
ntp server 130.126.24.24
ntp server 130.126.24.44
!
end
-Chris
Chris Beck
Enterprise Voice Architect
Technology Integration Services Team
Information Technology
Career Education Corporation
Greenspoint Office - 847-851-7350
EDC Voice - 847-783-8141
Mobile - 847-542-0118
Fax - 847-874-5741
email - cbeck at careered.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://puck.nether.net/pipermail/cisco-voip/attachments/20071115/384ccb6b/attachment-0001.html
More information about the cisco-voip
mailing list