[cisco-voip] Generating PRI for Cisco-Tandberg-Codian 3241 ISDN gateway

Robert Kulagowski rkulagow at gmail.com
Fri May 7 12:40:24 EDT 2010


On Thu, Jan 28, 2010 at 2:30 PM, Ryan Ratliff <rratliff at cisco.com> wrote:
> Be prepared to have somebody tell you that the telco needs to tell us why they are dropping the call.

OK, so a few TAC cases later, this works.  Things that we had to change:

Network timing selection.
Making sure that the isdn calltype was set for voice on the crossover PRI.
Removing the "no local bypass" from the dspfarm command.

Here's a working configuration:
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
service sequence-numbers
!
!
boot-start-marker
boot system flash flash:c3845-ipvoicek9-mz.124-24.T1.bin
boot-end-marker
!
card type t1 0 1
card type t1 0 2
card type t1 0 3
logging message-counter syslog
logging buffered 1000000
!
aaa new-model
!
!
aaa authentication login default group radius local
aaa authentication login console-in local
!
!
aaa session-id common
clock timezone EST -5
clock summer-time EDT recurring
network-clock-participate wic 1
network-clock-participate wic 2
network-clock-participate wic 3
network-clock-select 1 T1 0/1/0
network-clock-select 2 T1 0/2/0
network-clock-select 3 T1 0/1/1
network-clock-select 4 T1 0/2/1
!
dot11 syslog
ip source-route
ip cef
!
!

!
no ip bootp server
ip name-server 10.1.1.20
ip name-server 10.1.1.6
ip multicast-routing
no ipv6 cef
ntp update-calendar
ntp server 10.255.1.5
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-5ess
isdn voice-call-failure 0
!
!
trunk group FXO
 max-retry 5
 voice-class cause-code 1
 hunt-scheme round-robin
!
!
trunk group Local
!
!
trunk group LongDistance
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
voice call send-alert
voice call carrier capacity active
voice rtp send-recv
!
voice service voip
 fax protocol pass-through g711ulaw
 h323
  call preserve limit-media-detection
 modem passthrough nse codec g711ulaw
!
!
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
!
!
!
voice class h323 1
  h225 timeout tcp establish 5
  h225 timeout ntf 100
 h225 display-ie ccm-compatible
  call preserve
!
!
!
!
!
voice class cause-code 1
 no-circuit
 !
 !
 !
 !
 !
 voice vad-time 65536
 !
voice translation-rule 37

!
voice translation-rule 371

!
voice translation-rule 372
 rule 1 /^37/ /203326/ type unknown international plan unknown isdn
!
voice translation-rule 373
 rule 1 /^37/ /203326/ type unknown national plan unknown isdn
!
voice translation-rule 375

!
voice translation-profile CallBlock
 translate calling 371
!
voice translation-profile Prepend_SiteCode
 translate called 37
!
voice translation-profile Rewrite_for_911
 translate calling 375
!
voice translation-profile Set_International
 translate called 372
!
voice translation-profile Set_National
 translate called 373
!
!
!
application
 package callfeature
  param long-dur-disc-cause 16
  param long-dur-duration 720
  param long-dur-action disconnect
  param long-dur-call-mon enable
 !

 !
 global
  service alternate default
 !
!
!
!
!
!
file prompt quiet

archive
 log config
  logging enable
  notify syslog contenttype plaintext
  hidekeys
 path flash:/archive/backup
 maximum 7
 write-memory
!
!
controller T1 0/1/0
 cablelength long 0db
 pri-group timeslots 1-24

!
controller T1 0/1/1
 cablelength long 0db
 pri-group timeslots 1-24

!
controller T1 0/2/0
 cablelength long 0db
 pri-group timeslots 1-24

!
controller T1 0/2/1
 cablelength long 0db
 pri-group timeslots 1-24

!
controller T1 0/3/0
 clock source internal
 cablelength long 0db
 pri-group timeslots 1-24
 description Crossover to Codian 3241
!
!
!
!
!
interface Loopback0
 description For music-on-hold
 ip address 6.6.6.6 255.255.255.255
!
interface Loopback10
 description Management interface
 ip address 10.0.3.5 255.255.255.255
!
interface GigabitEthernet0/0

 no ip address
 no ip unreachables
 no ip proxy-arp
 duplex auto
 speed auto
 media-type rj45
 no keepalive
 no mop enabled
!
interface GigabitEthernet0/0.10
 encapsulation dot1Q 10
 ip address 10.255.3.1 255.255.255.0
 ip pim sparse-dense-mode
 h323-gateway voip bind srcaddr 10.255.3.1
!
interface GigabitEthernet0/0.999
 encapsulation dot1Q 999
 ip address 10.244.3.1 255.255.255.0
 ip pim sparse-dense-mode
!
interface GigabitEthernet0/1
 description To Production
 ip address 10.3.1.5 255.255.0.0
 no ip proxy-arp
 ip ospf priority 0
 duplex full
 speed 100
 media-type rj45
 no keepalive
 no mop enabled
!
interface Serial0/1/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn map address . plan isdn type national
 isdn supp-service name calling
 isdn integrate calltype all
 trunk-group Local
 no cdp enable
!
interface Serial0/1/1:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-4ess
 isdn supp-service name calling
 isdn nsf-service sdn
 isdn integrate calltype all
 trunk-group LongDistance
 no cdp enable
!
interface Serial0/2/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn map address . plan isdn type national
 isdn supp-service name calling
 isdn integrate calltype all
 trunk-group Local
 no cdp enable
!
interface Serial0/2/1:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-4ess
 isdn supp-service name calling
 isdn nsf-service sdn
 isdn integrate calltype all
 trunk-group LongDistance
 no cdp enable
!
interface Serial0/3/0:23
 description Crossover PRI to Codian 3241
 no ip address
 encapsulation hdlc
 isdn switch-type primary-5ess
 isdn protocol-emulate network
 isdn incoming-voice voice
 no cdp enable
!

!
no ip http server
ip http authentication local
no ip http secure-server
!
ip rtcp report interval 65535
!

!
voice-port 0/1/0:23
 translation-profile incoming Prepend_SiteCode
 no comfort-noise
!
voice-port 0/2/0:23
 translation-profile incoming Prepend_SiteCode
 no comfort-noise
!
voice-port 0/3/0:23
 local-alerting
!
voice-port 0/1/1:23
 translation-profile incoming Prepend_SiteCode
 no comfort-noise
!
voice-port 0/2/1:23
 translation-profile incoming Prepend_SiteCode
 no comfort-noise
!

dial-peer voice 200 pots
 description Route incoming video calls from PSTN to 0/3/0
 destination-pattern 37477.
 port 0/3/0:23
 forward-digits all
!
dial-peer voice 201 pots
 description Accept outgoing video calls from Codian
 incoming called-number .
 direct-inward-dial
 port 0/3/0:23
!
dial-peer voice 202 pots
! Dialplan on Codian prepends a # so that we make sure we're using a
particular dial peer
 trunkgroup Local 1
 description POTS leg of outgoing video calls
 destination-pattern #.T
!
!
sip-ua
 no transport udp
 no transport tcp
!
!
!


More information about the cisco-voip mailing list