[f-nsp] About LACP interoperability - WORKING CONFIG

p.ramesh p_ramesh at rocketmail.com
Tue Aug 8 15:59:00 EDT 2006


Hi all,

I have a working LACP between cisco and ServerIron. Well, dont ask me why I need a specific command on Cisco side, just tried out different combinations and this one worked! After the config on Cisco and Foundry, I can ping between these 2 boxes. 

LACP config on Cisco

interface Port-channel13
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2
 switchport mode trunk


interface GigabitEthernet3/1
 logging event link-status
 logging event spanning-tree status
 logging event bundle-status
 logging event trunk-status
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2
 switchport mode trunk
 channel-group 13 mode active
 channel-protocol lacp
!
interface GigabitEthernet3/2
 logging event link-status
 logging event spanning-tree status
 logging event bundle-status
 logging event trunk-status
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2
 switchport mode trunk
 channel-group 13 mode active
 channel-protocol lacp
!
interface GigabitEthernet3/3
 logging event link-status
 logging event spanning-tree status
 logging event bundle-status
 logging event trunk-status
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2
 switchport mode trunk
 channel-group 13 mode active
 channel-protocol lacp
!
interface GigabitEthernet3/4
 logging event link-status
 logging event spanning-tree status
 logging event bundle-status
 logging event trunk-status
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2
 switchport mode trunk
 channel-group 13 mode active
 channel-protocol lacp


interface Vlan2
 ip address 20.1.1.253 255.255.255.0

=============================================

LACP on Foundry ServerIron

interface ethernet 2/9
 link-aggregate configure key 21000
 link-aggregate active
!
interface ethernet 2/10
 link-aggregate configure key 21000
 link-aggregate active
!
interface ethernet 2/11
 link-aggregate configure key 21000
 link-aggregate active
!
interface ethernet 2/12
 link-aggregate configure key 21000
 link-aggregate active
!
interface ve 2
 ip address 20.1.1.254 255.255.255.0
!

vlan 2 by port
 tagged ethe 2/9 to 2/12
 router-interface ve 2

Nikolay Pavlov <quetzal at zone3000.net> wrote: On Thursday, 13 July 2006 at 19:25:14 +0900, Hiromasa Sekiguchi wrote:
> Hi all,
> 
> Thank you for your help.
> 
> I try the following tests.
> But all tests is fail...
> 
> 1. add "channel-protocol lacp" command
> 
>     -> fail...
> 
> 2. The LACP mode changed active/passive Cisco and Foundry.
> 
>     - Cisco is active, Foundry is active
> 
>       -> fail...
> 
>     - Cisco is active, Foundry is passive
> 
>       -> fail...
> 
>     - Cisco is passive, Foundry is active
> 
>       -> fail...
> 
> I have no more ideas...
> 
> Are there any ideas???

Why don't just use EtherChannel with out LACP or any aggregation
protocol? Here is my configuration:

CAT4506:

interface GigabitEthernet2/3
 description Goes to 2/7 of ServerIron 400
 switchport access vlan 55
 switchport mode access
 logging event link-status
 load-interval 30
 speed 1000
 no qos
 channel-group 1 mode on
!
interface GigabitEthernet2/4
 description Goes to 2/8 of ServerIron 400
 switchport access vlan 55
 switchport mode access
 logging event link-status
 load-interval 30
 speed 1000
 no qos
 channel-group 1 mode on

SI400:
trunk switch ethe 2/7 to 2/8
 port-name "trunk to cs4506-sw11-NY 2/3-2/4 " ethernet 2/7

It works cool for me =)

> 
> Regards,
> Hiromasa
> 
> 
> Hiromasa Sekiguchi wrote:
> > Hi all,
> > 
> > I try chennel connection between Cisco and Foundry.
> > 
> > The host is the following.
> > Cisco : cat3750
> > Foundry : FWS4802-PREM
> > 
> > +---------+ gi2/0/1         e49 +--------------+
> > | cat3750 |=====================| FWS4802-PREM |
> > +---------+ gi2/0/2         e50 +--------------+
> > 
> > ### cat3750 ###
> > interface gigabitethernet 2/0/1
> >   switchport access vlan ***
> >   switchport mode access
> >   channel-group 1 mode active
> > 
> > interface gigabitethernet 2/0/2
> >   switchport access vlan ***
> >   switchport mode access
> >   channel-group 1 mode active
> > ###
> > 
> > ### FWS4802-PREM ###
> > interface ethernet 49
> >  link-aggregate configure key 20000
> >  link-aggregate active
> > 
> > interface ethernet 50
> >  link-aggregate configure key 20000
> >  link-aggregate active
> > ###
> > 
> > When gi2/0/1(or e49) was down, gi2/0/2 was flapped.
> > It occur about 90 sec later.
> > 
> > Are there any solution?
> > 
> > Please help!!!
> > 
> > _______________________________________________
> > foundry-nsp mailing list
> > foundry-nsp at puck.nether.net
> > http://puck.nether.net/mailman/listinfo/foundry-nsp
> _______________________________________________
> foundry-nsp mailing list
> foundry-nsp at puck.nether.net
> http://puck.nether.net/mailman/listinfo/foundry-nsp

-- 
========================================================================= 
= Best regards, Nikolay Pavlov. <<<------------------------------------ = 
========================================================================= 
_______________________________________________
foundry-nsp mailing list
foundry-nsp at puck.nether.net
http://puck.nether.net/mailman/listinfo/foundry-nsp


 		
---------------------------------
How low will we go? Check out Yahoo! Messenger’s low  PC-to-Phone call rates.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://puck.nether.net/pipermail/foundry-nsp/attachments/20060808/6b9a54cb/attachment.html>


More information about the foundry-nsp mailing list