[f-nsp] l2 pseudowire with between ASNs
chip
chip.gwyn at gmail.com
Tue Aug 21 16:24:35 EDT 2012
Hi all,
I have a situation in which I'd like to encapsulate packets coming
in on an 802.1q sub int on a Cisco 7600 and drop them into a VLAN on a
Brocade XMR. The two routers are in two different ASNs and do not
have an IGP. The two routers are directly connected to each other and
only speak via eBGP. I've got the "send-label" on the cisco side
and "next-hop-mpls" on the brocade side. It appears that I have and
LDP session but I'm not seeing labels and the
vll/xconnect/vc/pseudowire isn't up. The interface e1/1 on the
brocade side is a trunked port going down to other distribution
switches and eventually a server that sits in vlan 3000. I apologize
for my ignorance here, still learning all the moving pieces.
Thoughts?
Thanks!
--chip
On the cisco side I have:
-------------------------------------------
mpls label protocol ldp
mpls ldp router-id Loopback0 force
!
interface Loopback0
ip address 10.100.119.134 255.255.255.255
logging event link-status
end
!
interface GigabitEthernet4/48
description l2-test
no ip address
no keepalive
!
interface GigabitEthernet4/48.3000
encapsulation dot1Q 3000
xconnect 192.168.8.1 100 encapsulation mpls
end
!
router bgp 64600
bgp log-neighbor-changes
neighbor 10.100.117.18 remote-as 64606
neighbor 10.100.117.18 description voxlab-2
address-family ipv4
no synchronization
neighbor 10.100.117.18 activate
neighbor 10.100.117.18 send-community
neighbor 10.100.117.18 prefix-list routes-64606 in
neighbor 10.100.117.18 distribute-list 102 out
neighbor 10.100.117.18 route-map TEST-IN in
neighbor 10.100.117.18 route-map EBGP-STD out
neighbor 10.100.117.18 send-label
neighbor 10.100.117.18 maximum-prefix 250 80
!
On the brocade side I have:
-------------------------------------------
interface loopback 1
ip address 192.168.8.1/32
!
interface ethernet 1/1
enable
load-interval 30
no fdp enable
!
interface ethernet 1/3
enable
ip address 10.100.117.18/30
ip mtu 9000
!
router bgp
local-as 64606
next-hop-mpls
neighbor as64600 peer-group
neighbor as64600 remote-as 64600
neighbor 10.100.117.17 peer-group as64600
neighbor 192.168.8.2 remote-as 64606
neighbor 192.168.8.2 description tsr2
neighbor 192.168.8.2 update-source loopback 1
address-family ipv4 unicast
network 192.168.8.1/32
neighbor as64600 prefix-list 64606-nets-nap006 out
neighbor 10.100.117.17 route-map out comm_test
neighbor 10.100.117.17 send-community
exit-address-family
!
router mpls
mpls-interface e1/3
ldp-enable
!
vll b1_tsr1 100
vll-mtu 1500
vll-peer 10.100.119.134
vlan 3000
tagged e 1/1
!
!
--------------------------
Various outputs:
--------------------------
telnet at tsr1.TEST006#sho mpls ldp
Label Distribution Protocol version 1
LSR ID: 192.168.8.1, using Loopback 1 (deleting it will stop LDP)
Hello interval: Link 5 sec, Targeted 15 sec
Hold time value sent in Hellos: Link 15 sec, Targeted 45 sec
Keepalive interval: 6 sec, Hold time multiple: 6 intervals
Load sharing: 1
Tunnel metric: 0
FEC used for auto discovered peers: current 129, configured 129
Graceful restart: disabled
telnet at tsr1.TEST006#sho mpls ldp neighbor
Number of link neighbors: 1
Number of targeted neighbors: 1
Nbr Transport Interface Nbr LDP ID Max Hold Time Left
10.100.119.134 e1/3 (Trunk1) 10.100.119.134:0 15 11
10.100.119.134 (targeted) 10.100.119.134:0 45 41
telnet at tsr1.TEST006#sho mpls vll
* - Active VLL Peer; U - UP; D - DOWN
Vll-Peer Vll-Peer MCT
Name VC-ID End-Point
(State) (State) state
---- ----- ---------
-------- -------- -----
b1_tsr1 100 tag vlan 3000 e 1/1(U)
10.100.119.134(D)* -- None
telnet at tsr1.TEST006#sho mpls vll detail
VLL b1_tsr1, VC-ID 100, VLL-INDEX 0
End-point : tagged vlan 3000 e 1/1
End-Point state : Up
MCT state : None
IFL-ID : --
Local VC type : tag
Local VC MTU : 1500
COS : --
Extended Counters: Enabled
Vll-Peer : 10.100.119.134
State : DOWN - no tunnel LSP to vll-peer
Remote VC type : -- Remote VC MTU : --
Local label : -- Remote label : --
Local group-id : 0 Remote group-id: --
Tunnel LSP : --
MCT Status TLV : --
telnet at tsr1.TEST006#sho mpls forwarding
Total number of MPLS forwarding entries: 0
Dest-prefix In-lbl Out-lbl Out-intf Sig Next-hop
border1.TEST001# sho mpls forwarding-table 192.168.8.1
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
None No Label 192.168.8.1/32 0 Po61 10.100.117.18
border1.TEST001# sho mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Gi4/48.3000 Eth VLAN 3000 192.168.8.1 100
DOWN
border1.TEST001# sho mpls l2transport vc detail
Local interface: Gi4/48.3000 up, line protocol up, Eth VLAN 3000 up
Destination address: 192.168.8.1, VC ID: 100, VC status: down
Output interface: none, imposed label stack {}
Preferred path: not configured
Default path: no route
No adjacency
Create time: 00:50:29, last status change time: 00:16:27
Signaling protocol: LDP, peer 192.168.8.1:0 up
Targeted Hello: 10.100.119.134(LDP Id) -> 192.168.8.1, LDP is
DOWN, no binding
Status TLV support (local/remote) : enabled/None (no remote binding)
LDP route watch : enabled
Label/status state machine : local ready, LruRnd
Last local dataplane status rcvd: No fault
Last local SSS circuit status rcvd: No fault
Last local SSS circuit status sent: Not sent
Last local LDP TLV status sent: No fault
Last remote LDP TLV status rcvd: None (no remote binding)
Last remote LDP ADJ status rcvd: None (no remote binding)
MPLS VC labels: local 60, remote unassigned
Group ID: local 0, remote unknown
MTU: local 1500, remote unknown
Remote interface description:
Sequencing: receive disabled, send disabled
Control Word: Off (configured: autosense)
VC statistics:
transit packet totals: receive 0, send 0
transit byte totals: receive 0, send 0
transit packet drops: receive 0, seq error 0, send 0
--
Just my $.02, your mileage may vary, batteries not included, etc....
More information about the foundry-nsp
mailing list