Fw: [j-nsp] 802.3ad vs FEC (fwd)

Tay Chee Yong tcy@pacific.net.sg
Tue, 15 Oct 2002 10:35:44 +0800 (Singapore Standard Time)


Hi all,

I do have a similar setup as the one posted nearly 1 year ago, except I am
aggregating 2 FastEthernet instead of 3, and I am not doing any trunking.

------                           ---------
|    |                           |  6509 |
|    | fe-0/2/1              8/3 |       |
| M5 |---------------------------|   +   |
|    | fe-0/2/0             8/21 |       |
|    |---------------------------|  MSFC |
------                           ---------

However, it seems that the ae0 is up, and the interface is having output, but no
input. Over at the Cat6 switch, is also the same (only output, no input)

May I know what could be the cause for the problem?

My configuration is as follows:

In Juniper :

chassis {
    aggregated-devices {
        ethernet {
            device-count 16;
        }
    }
}

interfaces {
    fe-0/2/0 {
        fastether-options {
            802.3ad ae0;
        }
    }
    fe-0/2/1 {
        fastether-options {
            802.3ad ae0;
        }
    }
    ae0 {
        vlan-tagging;
        aggregated-ether-options {
            minimum-links 1;
        }
        unit 0 {
            vlan-id 2;
            family inet {
                address 192.168.40.253/23;
            }
        }
    }
}

In Catalyst 6509 :

#set boot command
set boot config-register 0x2
set boot system flash bootflash:cat6000-sup2k9.6-3-7.bin

set port channel 8/3,8/21 87
set port channel 8/3,8/21 mode on

In Catalyst 6509 MSFC :

interface Vlan2
 ip address 192.168.40.1 255.255.254.0



>From Juniper:

root@m20# run show interfaces ae0 detail
Physical interface: ae0, Enabled, Physical link is Up
  Interface index: 23, SNMP ifIndex: 16, Generation: 22
  Link-level type: Ethernet, MTU: 1518, Speed: 200mbps, Loopback: Disabled,
Source filtering: Disabled, Flow control: Disabled,
  Minimum links needed: 1
  Device flags   : Present Running
  Interface flags: SNMP-Traps
  Current address: 00:90:69:55:13:f0, Hardware address: 00:90:69:55:13:f0
  Last flapped   : Never
  Statistics last cleared: Never
  Traffic statistics:
   Input  bytes  :                    0                    0 bps
   Output bytes  :              1362750                  176 bps
   Input  packets:                    0                    0 pps
   Output packets:                29625                    0 pps

  Logical interface ae0.0 (Index 15) (SNMP ifIndex 17) (Generation 23)
    Flags: SNMP-Traps VLAN 2 Encapsulation: Aggregate
    Statistics        Packets        pps         Bytes          bps
    Bundle:
        Input :             0          0             0            0
        Output:           583          0         48972            0
    Link:
      fe-0/2/0.0
        Input :             0          0             0            0
        Output:           583          0         48972            0
      fe-0/2/1.0
        Input :             0          0             0            0
        Output:             0          0             0            0
    Marker Statistics:   Marker Rx    Resp Tx    Unknown Rx   Illegal Rx
      fe-0/2/0.0                 0           0            0            0
      fe-0/2/1.0                 0           0            0            0
    Protocol inet, MTU: 1500, Flags: None, Generation: 25 Route table: 0
      Addresses, Flags: Is-Preferred Is-Primary
        Destination: 192.168.40/23, Local: 192.168.40.253, Broadcast:
192.168.41.255, Generation: 22


>From the Catalyst :

C6509> (enable) show chan traffic
ChanId Port  Rx-Ucst Tx-Ucst Rx-Mcst Tx-Mcst Rx-Bcst Tx-Bcst
------ ----- ------- ------- ------- ------- ------- -------
   866  8/3    0.00%  47.92%   0.00%  65.00% 100.00%  22.77%
   866  8/21   0.00%  52.08%   0.00%  35.00%   0.00%  77.23%


Comments and suggestions are greatly appreciated.

Regards,
Cheeyong


----- Original Message -----
From: "Nicolas Fevrier" <nicolas.fevrier@telindus.fr>
To: <juniper@groupstudy.com>
Cc: <juniper-nsp@puck.nether.net>
Sent: Monday, November 19, 2001 11:21 PM
Subject: [j-nsp] 802.3ad vs FEC


> Hi group,
>
> I know 802.3ad has nothing to do with FastEtherChannel but as
> Stephane LITKOWSKI suggested it several days ago, if we force
> the channel on the cisco : It works fine ...
>
>
> ------ fe-0/2/2              7/3 ---------
> |    |---------------------------|  6509 |
> |    | fe-0/2/1              7/2 |       |
> | M5 |---------------------------|   +   |
> |    | fe-0/2/0              7/1 |       |
> |    |---------------------------|  MSFC |
> ------                           ---------
>
> I noticed several points :
> - if you have only one link up, the ae0 is down
> - but if you only deconnect one interface, the aggregate link
> is still working (with just 2 fastEthernet)
>
>
> On the juniper I just configure the ae0 interface with the
> IP add : 10.1.1.1/24
> and on the Cisco box, the VLAN 100 with IP : 10.1.1.2/24
>
>
> Check the config :
>
> On the catalyst :
>
> begin
> !
> #time: Mon Nov 19 2001, 16:57:38
> #version 6.3(3)
> !
> !
> !
> #!
> #vtp
> set vtp mode transparent
> set vlan 1 name default type ethernet mtu 1500 said 100001 state active
> set vlan 100 name test type ethernet mtu 1500 said 100100 state active
> [...]
> !
> #set boot command
> set boot config-register 0x2
> set boot system flash bootflash:cat6000-supcv.6-3-3.bin
> set boot system flash slot0:cat6000-sup.5-5-11.bin
> !
> #port channel
> set port channel 7/1-3 198
> !
> # default port status is enable
> !
> [...]
> #module 7 : 48-port 10/100BaseTX Ethernet
> set trunk 7/1  on dot1q 1-1005,1025-4094
> set trunk 7/2  on dot1q 1-1005,1025-4094
> set trunk 7/3  on dot1q 1-1005,1025-4094
> set port channel 7/1-3 mode on
> !
> [...]
> end
> Console> (enable)
>
> On the MSFC card :
>
> Router#sh run
> Building configuration...
>
> Current configuration : 482 bytes
> !
> version 12.1
> hostname Router
> boot system flash bootflash:c6msfc-dsv-mz.121-7.E.bin
> boot bootldr bootflash:c6msfc-boot-mz.121-7.E.bin
> ip subnet-zero
> interface Vlan1
>  no ip address
>  shutdown
> !
> interface Vlan100
>  ip address 10.1.1.2 255.255.255.0
> !
> [...]
> end
>
> Router#
>
>
> On the Juniper :
> [...]
> chassis {
>     aggregated-devices {
>         ethernet {
>             device-count 16;
>         }
>     }
> }
> interfaces {
>     fe-0/2/0 {
>         fastether-options {
>             802.3ad ae0;
>         }
>     }
>     fe-0/2/1 {
>         fastether-options {
>             802.3ad ae0;
>         }
>      }
>     fe-0/2/2 {
>         fastether-options {
>             802.3ad ae0;
>         }
>     }
>     ae0 {
>         vlan-tagging;
>         aggregated-ether-options {
>             minimum-links 2;
>
>         }
>         unit 0 {
>             vlan-id 100;
>             family inet {
>                 address 10.1.1.1/24;
>             }
>         }
>     }
> }
> [...]
>
>
> root@M5LAB> show interfaces ae0 detail
> Physical interface: ae0, Enabled, Physical link is Up
>   Interface index: 14, SNMP ifIndex: 22, Generation: 13
>   Link-level type: Ethernet, MTU: 1518, Speed: 300mbps, Loopback:
Disabled,
>   Source filtering: Disabled, Flow control: Disabled, Minimum links
needed:
> 2
>   Device flags   : Present Running
>   Interface flags: SNMP-Traps
>   Current address: 00:90:69:6f:7b:f0, Hardware address: 00:90:69:6f:7b:f0
>   Statistics last cleared: Never
>   Traffic statistics:
>    Input  bytes  :                97397                    0 bps
>    Output bytes  :              1432146                    0 bps
>    Input  packets:                 1290                    0 pps
>    Output packets:                 2216                    0 pps
>
>   Logical interface ae0.0 (Index 3) (SNMP ifIndex 42) (Generation 7)
>     Flags: SNMP-Traps VLAN 100 Encapsulation: Aggregate
>     Statistics        Packets        pps         Bytes          bps
>     Bundle:
>         Input :          1211          0         92945            0
>         Output:          1299          0        172142            0
>     Link:
>       fe-0/2/0.0
>         Input :           957          0         71689            0
>         Output:          1262          0        166962            0
>       fe-0/2/1.0
>         Input :           253          0         21192            0
>         Output:            37          0          5180            0
>       fe-0/2/2.0
>         Input :             1          0            64            0
>         Output:             0          0             0            0
>     Marker Statistics:   Marker Rx    Resp Tx    Unknown Rx   Illegal Rx
>       fe-0/2/0.0                 0           0            0            0
>       fe-0/2/1.0                 0           0            0            0
>       fe-0/2/2.0                 0           0            0            0
>     Protocol inet, MTU: 1500, Flags: Is-Primary, Generation: 8 Route
table:
> 0
>       Addresses, Flags: Is-Default Is-Preferred Is-Primary
>         Destination: 10.1.1/24, Local: 10.1.1.1, Broadcast: 10.1.1.255,
>         Generation: 6
>
> root@M5LAB>
>
> And on the Catalyst :
>
> Console> (enable) show channel traffic
> ChanId Port  Rx-Ucst Tx-Ucst Rx-Mcst Tx-Mcst Rx-Bcst Tx-Bcst
> ------ ----- ------- ------- ------- ------- ------- -------
>    833  7/1    0.00%   0.00%   0.00%  94.70%   0.00%   0.00%
>    833  7/2  100.00%   0.00%   0.00%   2.35%   0.00%   0.00%
>    833  7/3    0.00% 100.00%   0.00%   2.94%   0.00%   0.00%
>
>
> (I only use ping traffic between the Juniper and the Cisco)
>
>
>
> Console> (enable) sh trunk
> * - indicates vtp domain mismatch
> Port      Mode         Encapsulation  Status        Native vlan
> --------  -----------  -------------  ------------  -----------
>  7/1      on           dot1q          trunking      1
>  7/2      on           dot1q          trunking      1
>  7/3      on           dot1q          trunking      1
> 15/1      nonegotiate  isl            trunking      1
> 16/1      nonegotiate  isl            trunking      1
>
> Port      Vlans allowed on trunk
> --------
> ---------------------------------------------------------------------
>  7/1      1-1005,1025-4094
>  7/2      1-1005,1025-4094
>  7/3      1-1005,1025-4094
> 15/1      1-1005,1025-4094
> 16/1      1-1005,1025-4094
>
>
>
> If you're interested, we also did the test with Juniper and Extreme Summit
> (802.3ad at both side).
>
> Nicolas.
>
>
>
>
> .
>
>