[j-nsp] Link aggregation

Michael Lyngbøl michael at lyngbol.dk
Sat Jun 12 06:12:56 EDT 2004


On 12.06.2004 11:24:50 +0000, Jonas Frey wrote:
> Hello,
> 
> i am just trying to find more info on link aggregation/link bundling on
> GE interfaces. (Going to bundle to 2 GE from a M20 to a Cisco Cat 3750).
> 
> I stumbled across this which looks strange to me:
> 
> >For aggregated Ethernet interfaces, you must include the 
> >vlan-tagging statement at the [edit interfaces aex] hierarchy level 
> >to complete the association.
> 
> Does this mean i have to run vlan's on the aeX interface?

Yes.

> And if i do,
> is the first vlan for system purposes or can it be production stuff?

"first vlan" == VLAN #1 or? Don't use native vlan. Anyway, you're free
to use any vlan you would like.

> Also, does anyone have a code sniplet of both the juniper side and cisco
> side for link aggregation?

Ok, Juniper side (config here is FastEthernet but it's the same for
GigE):

lyngbol at m10> show configuration chassis aggregated-devices 
ethernet {
    device-count 1;
}

lyngbol at m10> show configuration interfaces fe-0/1/1  
fastether-options {
    802.3ad ae1;
}

lyngbol at m10> show configuration interfaces fe-0/1/2    
fastether-options {
    802.3ad ae1;
}

lyngbol at m10> show configuration interfaces ae1    
no-traps;
vlan-tagging;
aggregated-ether-options {
    minimum-links 1;
    link-speed 100m;
}
unit 20 {
    vlan-id 20;
    family inet {
        address 1.2.3.1/24;
    }
}

Cisco 3550-24 ethernet switch:

switch#sh run int p1
Building configuration...

Current configuration : 138 bytes
!
interface Port-channel1
 description m10 ae1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 bandwidth 200000
end

switch#sh run int f0/23
Building configuration...

Current configuration : 347 bytes
!
interface FastEthernet0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 bandwidth 100000
 duplex full
 speed 100
 channel-group 1 mode on
end

switch#sh run int f0/24
Building configuration...

Current configuration : 347 bytes
!
interface FastEthernet0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 bandwidth 100000
 duplex full
 speed 100
 channel-group 1 mode on
end

/Michael

-- 
Michael Lyngbøl -- michael at lyngbol dot dk
Network Architect, AS3292 TDC, IP·backbone


More information about the juniper-nsp mailing list