[j-nsp] Cisco -- Juniper

Mohacsi Janos mohacsi at niif.hu
Mon Jun 28 07:35:25 EDT 2004


Hi,


On Mon, 28 Jun 2004, Usman Tahir wrote:

> Hi
>
> I have to replace cisco routers from our clients premises & replace them
> with M7i
>
> The current cisco routers have following configuration which is simple
> enough. I was wondering if someone can point out if there is any problem
> with implementing the same on Juniper, I have no prior experience with
> juniper and the ordered routers are not in yet. At the some sites cisco will
> be replaced by Juniper on some sites cisco will stay the same but the core
> site will have Juniper M40.
> PS: in some of the access sites certain timeslots are not utilised meaning
> in some sites only 2 timeslots are used, I`ll appreciate the help.
>
> ip subnet-zero
> !
> !
> controller E1 1/0
> channel-group 1 timeslots 1-31
>
> !
> interface Loopback0
> ip address 10.16.11.1 255.255.255.255
> !
> !
> !
> interface Serial1/0:1
> ip address 172.16.2.253 255.255.255.0
> ip accounting output-packets
> encapsulation ppp
> fair-queue
> !
> router ospf 10
> router-id 10.16.11.1
> log-adjacency-changes
> network 172.16.0.0 0.0.255.255 area 10
> !
>
> Regards
> Usman
>

Your config should be something like:

interfaces {
     /* Created from IOS Interface: ethernet0 */
     your_serial_interface {
         encapsulation ppp;
         unit 0 {
 	    timeslots time-slot-range
             family inet {
                 address 172.16.2.253/24;
             }
         }
     }
     /* Created from IOS Interface: loopback0 */
     lo0 {
         unit 0 {
             family inet {
                 address 10.16.11.1/32;
             }
         }
     }
}
routing-options {
     router-id 10.16.11.1;
}
protocols {
     ospf {
         area 0.0.0.10 {
             interface your_serial_interface {
                 priority 1;
             }
         }
     }
}



For ip accouting output packets I believe you should create a firewall 
filter.

Best Regards,



Janos Mohacsi
Network Engineer, Research Associate
NIIF/HUNGARNET, HUNGARY
Key 00F9AF98: 8645 1312 D249 471B DBAE  21A2 9F52 0D1F 00F9 AF98


More information about the juniper-nsp mailing list