[j-nsp] Cisco/Juniper MPLS-TE Interoperability

Phil Rosenthal pr at isprime.com
Wed Jan 12 19:57:05 EST 2005


Hi,

I'm trying to get MPLS-TE working between some cisco Sup720's and 
juniper M20's, and I'm running into a problem.  I'm sure I'm missing 
something stupid, but here goes...

On the cisco I have:

vlan 1001
mpls traffic-eng tunnels
mpls traffic-eng signalling advertise implicit-null
no tag-switching ip propagate-ttl
tag-switching tdp discovery directed-hello accept
tag-switching tdp router-id Loopback0 force

interface Tunnel2
  ip unnumbered Loopback0
  no ip redirects
  load-interval 30
  tunnel destination 10.0.6.2
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 1 1
  tunnel mpls traffic-eng bandwidth  100
  tunnel mpls traffic-eng path-option 1 dynamic

router isis
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-2
  net 49.(removed)
  is-type level-2-only
  metric-style wide
  set-overload-bit on-startup 40 suppress interlevel
  max-lsp-lifetime 65535
  lsp-refresh-interval 65000
  no hello padding
  log-adjacency-changes all
  redistribute connected
  passive-interface Loopback0
  maximum-paths 6

interface Loopback0
  ip address 10.0.7.132 255.255.255.255
  isis metric 1 level-2
interface GigabitEthernet2/7
  mtu 9216
  no ip address
  load-interval 30
  speed nonegotiate
  flowcontrol send off
  switchport
  switchport access vlan 1001
  switchport trunk encapsulation dot1q
  switchport mode trunk
  no cdp enable

interface Vlan1001
  mtu 9174
  ip address 10.0.9.78 255.255.255.252
  ip router isis
  load-interval 30
  mpls traffic-eng tunnels
  ip rsvp bandwidth 1000000



On the juniper i have:
 > show configuration protocols mpls
traffic-engineering bgp-igp;
label-switched-path J2-C2 {
     to 66.230.181.132;
}
interface ge-0/2/0.1001;

 > show configuration protocols rsvp
interface ge-0/2/0.1001 {
     bandwidth 1g;
}

 > show configuration protocols isis
export isis-export;
reference-bandwidth 10g;
traffic-engineering shortcuts;
level 1 disable;
level 2 wide-metrics-only;
interface ge-0/2/0.1001 {
     level 1 disable;
     level 2 {
         hello-interval 3;
         hold-time 9;
     }
}
interface lo0.0 {
     passive;
     level 1 disable;
     level 2 metric 0;
}

 > show configuration interfaces ge-0/2/0
vlan-tagging;
mtu 9192;
link-mode full-duplex;
gigether-options {
     no-flow-control;
}
unit 1001 {
     vlan-id 1001;
     family inet {
         address 10.0.9.77/30;
     }
     family iso;
     family mpls;
}

 > show configuration interfaces lo0
unit 0 {
     family inet {
         filter {
             input route-engine;
         }
         address 10.0.6.2/32 {
             primary;
         }
     }
     family iso {
         address 49.(removed);
     }
     family inet6 {
         filter {
             input route-engine6;
         }
     }
}


Any ideas where I'm going wrong?

I've got a few sup720 boxes connected to eachother using the same "int 
tunnelX" setup.

--Phil Rosenthal
ISPrime, Inc.



More information about the juniper-nsp mailing list