[j-nsp] Missing route in routing-instance

Thomas Mangin thomas.mangin at exa-networks.co.uk
Wed Nov 15 09:03:57 EST 2006


Hello,

I am puzzled by a default route not willing to install itself in an
routing-instance and would really appreciate any help with what could be
 the source.

routing-options {
  rib-groups {
    if-rib {
        import-rib [ inet.0 inet.2 ];
    }
    isis-rib {
        export-rib inet.0;
        import-rib [ inet.0 inet.2 ];
    }
    mcast-rib {
        export-rib inet.2;
        import-rib inet.2;
    }
  }
  interface-routes {
    rib-group inet if-rib;
  }
}

routing-instances {
  to-surfprotect-web-return {
    instance-type forwarding;
    routing-options {
        static {
            route 0.0.0.0/0 next-hop 82.219.2.81;
        }
    }
  }
  to-surfprotect-web-return {
    instance-type forwarding;
    routing-options {
        static {
            route 0.0.0.0/0 next-hop 82.219.2.71;
        }
    }
  }
}

logical-routers {
    dsl {
        interfaces {
            ge-0/3/0 {
                unit 7 {
                    vlan-id 7;
                    family inet {
                        address 82.219.2.85/29;
                        adrress 82.219.2.86/29;
                    }
                }
                unit 22 {
                    vlan-id 22;
                    family inet {
                        address 82.219.3.118/29;
                    }
                }
                unit 502 {
                    vlan-id 502;
                    family inet {
                        address 82.219.2.77/28;
                        address 82.219.2.78/28;
                    }
                }
            }
            lt-1/2/0 {
                unit 2 {
                    description "to parent M7i";
                    encapsulation ethernet;
                    peer-unit 1;
                    family inet {
                        address 82.219.2.13/30;
                    }
                    family iso;
                }
            }
            lo0 {
                unit 1 {
                    family inet {
                        no-redirects;
                        address 82.219.2.133/32;
                        address 82.219.0.7/32;
                        address 82.219.0.71/32;
                    }
                    family iso {
                        address 49.0001.0822.1900.0071.00;
                    }
                }
            }
        }
        protocols {
            isis {
                export static-to-isis;
                rib-group inet isis-rib;
		[...]
            }
            bgp {
                [...]
            }
        }
       routing-options {
            interface-routes {
                rib-group inet if-rib;
            }
            static {
                [...]
                route 0.0.0.0/0 next-hop 82.219.2.14;
            }
            rib-groups {
                if-rib {
                    import-rib [ inet.0 inet.2
to-surfprotect-web-nat.inet.0 to-surfprotect-web-return.inet.0 ];
                }
                isis-rib {
                    export-rib inet.0;
                    import-rib [ inet.0 inet.2 ];
                }
            }
        }
    }
}



thomas.mangin at m7i-4.u3.tcw.uk> show route 82.219.2.81 table
to-surfprotect-web-return.inet.0 logical-router dsl

to-surfprotect-web-return.inet.0: 15 destinations, 16 routes (15 active,
0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

82.219.2.80/29     *[Direct/0] 00:28:02
                    > via ge-0/3/0.7


thomas.mangin at m7i-4.u3.tcw.uk> show route table
to-surfprotect-web-return.inet.0 logical-router dsl

to-surfprotect-web-return.inet.0: 15 destinations, 16 routes (15 active,
0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

82.219.0.7/32      *[Direct/0] 00:16:09
                    > via lo0.1
82.219.0.71/32     *[Direct/0] 00:16:09
                    > via lo0.1
82.219.2.12/30     *[Direct/0] 00:16:09
                    > via lt-1/2/0.2
82.219.2.13/32     *[Local/0] 00:16:09
                      Local via lt-1/2/0.2
82.219.2.64/28     *[Direct/0] 00:16:09
                    > via ge-0/3/0.502
                    [Direct/0] 00:16:09
                    > via ge-0/3/0.502
82.219.2.77/32     *[Local/0] 00:16:09
                      Local via ge-0/3/0.502
82.219.2.78/32     *[Local/0] 00:16:09
                      Local via ge-0/3/0.502
82.219.2.80/29     *[Direct/0] 00:16:09
                    > via ge-0/3/0.7
82.219.2.85/32     *[Local/0] 00:16:09
                      Local via ge-0/3/0.7
82.219.2.86/32     *[Local/0] 00:16:09
                      Local via ge-0/3/0.7
82.219.2.133/32    *[Direct/0] 00:16:09
                    > via lo0.1
82.219.3.112/29    *[Direct/0] 00:16:09
                    > via ge-0/3/0.22
82.219.3.118/32    *[Local/0] 00:16:09
                      Local via ge-0/3/0.22
213.170.128.4/30   *[Direct/0] 00:16:09
                    > via ge-0/3/0.502
213.170.128.5/32   *[Local/0] 00:16:09
                      Local via ge-0/3/0.502

thomas.mangin at m7i-4.u3.tcw.uk> ping 82.219.2.81 logical-router dsl
source 82.219.2.77
PING 82.219.2.81 (82.219.2.81): 56 data bytes
64 bytes from 82.219.2.81: icmp_seq=0 ttl=64 time=0.509 ms
64 bytes from 82.219.2.81: icmp_seq=1 ttl=64 time=4.880 ms

thomas.mangin at m7i-4.u3.tcw.uk> ping 82.219.2.81 logical-router dsl
routing-instance to-surfprotect-web-return
PING 82.219.2.81 (82.219.2.81): 56 data bytes
ping: sendto: Can't assign requested address
ping: sendto: Can't assign requested address

I am obviously missing something BIG ...

Thomas

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 186 bytes
Desc: OpenPGP digital signature
Url : https://puck.nether.net/pipermail/juniper-nsp/attachments/20061115/5f4537b7/attachment.bin 


More information about the juniper-nsp mailing list