[j-nsp] MPLS VPN LAYER 3 translation from cisco to M20

Georgi Yalamov georgi.yalamov at btc-net.bg
Tue Mar 6 03:34:05 EST 2007


Juan C. Crespo R. wrote:
> Dears
>
>     Anyone could help me translating this config from a Cisco to a 
> Juniper M20?
>
> STATIC ROUTE
> ip route X.X.X.X 255.255.255.252 Serial0 name L3VPN
>
>
> ip vrf L3VPN
>  rd ASASA:000000001
>  route-target export ASASA:000000001
>  route-target import ASASA:000000002
>
>
> address-family vpnv4
> neighbor a.b.c.d peer-group iBGP-GROUP
>
> address-family ipv4 vrf L3VPN
> redistribute connected
> redistribute static
> no auto-summary
> no synchronization
> exit-address-family
>
> Thanks
>
> JC
> _______________________________________________
> juniper-nsp mailing list juniper-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/juniper-nsp
>
>   
Hi,


Try something like this:

 # show protocols bgp

 show protocols bgp
group iBGP-GROUP {
    type internal;
    local-address A.A.A.A.;
    mtu-discovery;
    family inet {
        unicast;
    }
    family inet-vpn {
        unicast;
        any;
    }
    peer-as 8866;
    neighbor a.b.c.d;
    neighbor a.b.c.e;
}


 #show routing-instances L3VPN
description L3VPN;
instance-type vrf;
interface ge-0/2/1.....;
route-distinguisher ASASA:00000000001
vrf-import l3vpn-imp;
vrf-export l3vpn-exp;
vrf-table-label;
routing-options {
    static {
        route X.X.X.X/30 next-hop Y.Y.Y.Y;
}

# show policy-options policy-statement l3vpn-imp
term a {
    from {
        protocol bgp;
        community l3vpn-comm-imp;
    }
    then accept;
}
term b {
    then reject;
}

[edit]
# show policy-options policy-statement l3vpn-exp
term a {
    from protocol [ direct static ];
    then {
        community add l3vpn-comm-exp;
        accept;
    }
}
term b {
    then reject;
}

# show policy-options community ..
community l3vpn-comm-exp members target:ASASA:00000000001
community l3vpn-comm-imp members target:ASASA:00000000002


Kind regards,

--
George Yalamov
Bulgarian Telecommunications Company AD
Senior Engineer Core/Metro Technologies
tel: 359 2 949 6844




More information about the juniper-nsp mailing list