[j-nsp] question regarding l2vpn
CHEN Xu
simonchennj at gmail.com
Mon Jun 16 17:21:25 EDT 2008
Hi all,
I am trying to set up a l2vpn between two logical-routers across two
physical routers.
The setup is actually complicated, but I will try to make it simple...
Basically, Router-A-CE and Router-A-PE are two logical routers on the
same physical router.
Router-A-PE and Router-B-PE are connected via a VPN service through a
series of routers in between, which I ignore here. So the setup looks
like this conceptually:
Router-A-CE <-> Router-A-PE <-> Router-B-PE <-> Router-B-CE
Configuration for Router-A-PE:
logical-routers {
router-a-pe {
interfaces {
gr-1/2/0 {
unit 0 { ### gre channel to router-B-pe
tunnel {
source 8.0.0.4;
destination 8.0.0.3;
}
family inet {
address 4.0.0.2/30;
}
family iso;
family mpls;
}
}
lt-1/2/0 {
unit 0 { ### logical channel to Router-A-CE
encapsulation ethernet-ccc;
peer-unit 1001;
family ccc;
}
}
}
protocols {
rsvp {
interface all;
}
mpls {
label-switched-path to-router-b-pe {
### lsp for the l2vpn
from 4.0.0.2;
to 4.0.0.1;
no-cspf;
}
interface all;
}
bgp {
import match-all;
export match-all;
group pe-pe-l2vpn {
type internal;
local-as 7777;
neighbor 4.0.0.1 {
### bgp session to router-b-pe
local-address 4.0.0.2;
family l2vpn {
signaling;
}
}
}
}
}
routing-instances {
L2VPN-to-router-a-ce {
instance-type l2vpn;
interface lt-1/2/0.0;
route-distinguisher 100:1;
vrf-import vpn-SPA-import;
vrf-export vpn-SPA-export;
protocols {
l2vpn {
encapsulation-type ethernet;
site router-a {
site-identifier 2;
interface lt-1/2/0.0 {
remote-site-id 1;
}
}
}
}
}
}
}
}
Configuration for Router-A-CE:
logical-routers {
router-a-ce {
interfaces {
lt-1/2/0 {
unit 1001 {
encapsulation ethernet;
peer-unit 0;
family inet {
address 88.88.88.2/24;
}
}
}
}
}
}
Configuration for Router-B-PE and Router-B-CE are basically the mirror
of the above two.
The problem is the l2vpn connection is successfully established:
Instance: XXX
Local site: YYY (2)
connection-site Type St Time last up # Up trans
1 rmt Up Jun 16 20:50:26 2008 1
Local interface: fe-0/0/2.0, Status: Up, Encapsulation: ETHERNET
Remote PE: 4.0.0.1, Negotiated control-word: Yes (Null)
Incoming label: 800000, Outgoing label: 800001
MPLS LSP is also up both sides.
But I cannot ping from Router-A-CE to Router-B-CE.
Any ideas?
Thanks in advance!
-Simon
More information about the juniper-nsp
mailing list