[j-nsp] l2circuit in vrf

angel angel.bardarov at btc-net.bg
Fri Jan 9 08:50:09 EST 2009


So here is a working config I just checked in my lab:
PE1-----------------MPLS----------------PE2
l2circuit------------------------------------l2circuit
vrf aaa-------------------------------------vrf aaa
192.168.3.1-------------------------------192.168.3.2

for PE1:

lab at edge-a1-RE0# show interfaces lt-2/1/0
unit 0 {
    encapsulation ethernet-ccc;
    peer-unit 1;
    family ccc;
}
unit 1 {
    encapsulation ethernet;
    peer-unit 0;
    family inet {
        address 192.168.3.2/24;
    }
}

lab at edge-a1-RE0# show protocols l2circuit
neighbor x.x.x.x {
    interface lt-2/1/0.0 {
        virtual-circuit-id 777;
    }
}

lab at edge-a1-RE0# show routing-instances aaa
instance-type vrf;
interface lt-2/1/0.1;
route-distinguisher 1:1;
vrf-target target:2:2;
vrf-table-label;

for PE2:

lab at edge-a2-RE0# show interfaces lt-2/1/0
unit 0 {
    encapsulation ethernet-ccc;
    peer-unit 1;
}
unit 1 {
    encapsulation ethernet;
    peer-unit 0;
    family inet {
        address 192.168.3.1/24;
    }
}

lab at edge-a2-RE0# show protocols l2circuit
neighbor y.y.y.y {
    interface lt-2/1/0.0 {
        virtual-circuit-id 777;
    }
}

lab at edge-a2-RE0# show routing-instances aaa
instance-type vrf;
interface lt-2/1/0.1;
route-distinguisher 1:1;
vrf-target target:2:2;
vrf-table-label;

Verification:

{master}
lab at edge-a2-RE0> show interfaces lt-2/1/0.0 | match packets             
    Input packets : 30
    Output packets: 29

{master}
lab at edge-a2-RE0> ping routing-instance aaa 192.168.3.2                    
PING 192.168.3.2 (192.168.3.2): 56 data bytes
64 bytes from 192.168.3.2: icmp_seq=0 ttl=64 time=0.859 ms
64 bytes from 192.168.3.2: icmp_seq=1 ttl=64 time=0.836 ms
64 bytes from 192.168.3.2: icmp_seq=2 ttl=64 time=0.796 ms
64 bytes from 192.168.3.2: icmp_seq=3 ttl=64 time=0.903 ms
64 bytes from 192.168.3.2: icmp_seq=4 ttl=64 time=0.834 ms
^C
--- 192.168.3.2 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.796/0.846/0.903/0.035 ms

{master}
lab at edge-a2-RE0> show interfaces lt-2/1/0.0 | match packets   
    Input packets : 35
    Output packets: 34

Regards,
Angel Bardarov



Marcus Eide wrote:
> Hi,
> I don't know if this is even possible, but I thought I'd ask you: Does
> anyone know if it's possible to connect an l2circuit to an vrf type
> routing-instance?
>
> I found some information that stated this could be done with logical tunnel
> interfaces, so I tried the following:
>
>
> interface lt-1/2/0 {
>     unit 0 {
>         encapsulation ethernet-ccc;
>         peer-unit 1;
>         family ccc;
>     }
>     unit 1 {
>         encapsulation ethernet;
>         peer-unit 0;
>         family inet {
>             address 192.168.3.1/24;
>         }
>     }
> }
>
> protocol l2circuit {
>     neighbor 172.16.0.2 {
>         interface lt-1/2/0.0 {
>             virtual-circuit-id 7777;
>         }
>     }
> }
>
> routing-instance VRF1003 {
>     instance-type vrf;
>     interface lo0.1003;
>     interface lt-1/2/0.1003;
>     route-distinguisher 65000:1003;
>     vrf-target target:65000:1003;
>     vrf-table-label;
> }
>
> The l2circuit shows up, but there's no traffic coming through.
>
> Any thoughts on the subject is appreciated.
>
> /Marcus
> _______________________________________________
> juniper-nsp mailing list juniper-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/juniper-nsp
>
>   



More information about the juniper-nsp mailing list