[j-nsp] L2VPN not forwarding

Eric Van Tol eric at atlantech.net
Mon Jul 20 13:46:15 EDT 2009


Hi all,
I am attempting to test out an L2VPN that connects two GE interfaces on two separate J2320 routers via MPLS over GRE.  I have the MPLS tunnel up and working and can ping using the 'ping mpls l2vpn' command.  My problem is when I connect my devices to each GE port on the 2320s, I am unable to ping across.  

Here's the relevant portions of the configs:

J2320-1:
ge-0/0/0 {
    mtu 1560;
    unit 0 {
        family inet {
            mtu 1532;
            address 172.16.1.2/30;
        }
    }
}
gr-0/0/0 {
    unit 1 {
        tunnel {
            source 10.0.0.3;
            destination 10.0.0.4;
            ttl 10;
        }
        family inet {
            mtu 1500;
            address 172.20.100.2/30;
        }
        family mpls;
    }
}
ge-0/0/1 {         
    encapsulation ethernet-ccc;
    unit 0 {
        family ccc;
    }
}
lo0 {
    unit 0 {
        family inet {
            address 10.0.0.3/32;
        }
    }
}
...
rsvp {
    interface gr-0/0/0.1;
}
mpls {
    label-switched-path to_j2320-2 {
        to 10.0.0.4;
    }
    interface gr-0/0/0.1;
    interface ge-0/0/1.0;
}
bgp {
    group test {
        local-address 10.0.0.3;
        family l2vpn {
            signaling;
        }
        export ibgp;
        peer-as 65000;
        neighbor 10.0.0.4;
    }
}
ospf {
    traffic-engineering;
    area 0.0.0.0 { 
        interface ge-0/0/0.0;
        interface lo0.0 {
            passive;
        }
        interface gr-0/0/0.1 {
            metric 65000;
        }
    }
}

layer2-test {
    instance-type l2vpn;
    interface ge-0/0/1.0;
    route-distinguisher 10.0.0.3:65000;
    vrf-import l2vpn-import;
    vrf-export l2vpn-export;
    protocols {
        l2vpn {
            encapsulation-type ethernet;
            no-control-word;
            site j2320-top {
                site-identifier 1;
                interface ge-0/0/1.0 {
                    remote-site-id 2;
                }
            }
        }
    }
}

J2320-2:
interfaces {
    ge-0/0/0 {
        mtu 1560;
        unit 0 {
            family inet {
                mtu 1532;
                address 172.16.2.2/30;
            }
        }
    }
    gr-0/0/0 {
        unit 1 {
            tunnel {
                source 10.0.0.4;
                destination 10.0.0.3;
                ttl 10;
            }
            family inet {
                mtu 1500;
                address 172.20.100.1/30;
            }
            family mpls;
        }
    }
    ge-0/0/1 {
        encapsulation ethernet-ccc;
        unit 0 {
            family ccc;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 10.0.0.4/32;
            }
        }
    }
}
protocols {
    rsvp {
        interface gr-0/0/0.1;
    }
    mpls {
        label-switched-path to_j2320-1 {
            to 10.0.0.3;
        }
        interface gr-0/0/0.1;
        interface all;
    }
    bgp {
        group test {
            local-address 10.0.0.4;
            family l2vpn {
                signaling;
            }
            export ibgp;
            peer-as 65000;
            neighbor 10.0.0.3;
        }
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface lo0.0 {
                passive;
            }
            interface ge-0/0/0.0;
            interface gr-0/0/0.1 {
                metric 65000;
            }
        }
    }
}
routing-instances {
    layer2-test {
        instance-type l2vpn;
        interface ge-0/0/1.0;
        route-distinguisher 10.0.0.4:65000;
        vrf-import l2vpn-import;
        vrf-export l2vpn-export;
        protocols {
            l2vpn {
                encapsulation-type ethernet;
                no-control-word;
                site j2320-bot {
                    site-identifier 2;
                    interface ge-0/0/1.0 {
                        remote-site-id 1;
                    }
                }
            }
        }
    }
}


I'm pretty sure I'm missing something obvious, but this is the first time I've messed with L2VPNs.

thanks,
evt


More information about the juniper-nsp mailing list