[j-nsp] LDP Interop with IOS

Brad Fleming bdflemin at gmail.com
Wed Jun 29 16:03:30 EDT 2011


Hello all,

I'm having a tough time with LDP interoperability between Juniper and Cisco gear. I'm starting to wonder if this isn't a limitation of the Cisco platform in the lab.

I have the following devices:
+ Brocade NetIron XMR 4000 running IronWare 5.1.00b
+ Cisco 2821 ISR running IOS 12.4(24)T5 T-train w/ Advanced IP Services
+ Juniper SRX running Junos 10.0R4.7

The Cisco is acting as the P router between services deployed on the Brocade and Juniper. Connectivity is like so:
Juniper SRX <--- 2xT1 / MLPPP ---> Cisco 2821 <--- Ethernet ---> Brocade XMR

OSPFv2 happily comes online on all systems and IP routes propagate as expected.
LDP on the other hand, never seems to come up on the Cisco.
What's very odd is that both the Brocade and Juniper believe the LDP session is up and functioning.

If I replace the Cisco 2821 with another SRX, J-Series, or Brocade NI CER (adv prem) LDP happily comes online with no issues and services flow as expected.

Does anyone have a working example of LDP between a Cisco ISR and Juniper gear they would be willing to share?

Thanks in advance for any suggestions or insights!

----------------------------------------------
OSPF works but LDP is busted:

Cisco-2821(config-if)#do show ip ospf neigh

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.199.109   1   FULL/BDR        00:00:32    192.168.204.69  GigabitEthernet0/0
192.168.199.34    0   FULL/  -        00:00:37    192.168.204.74  Multilink100
kr-kludgy(config)#do show mpls ldp neigh

Cisco-2821(config)#end



Configurations are extremely simple:

Brocade:
!
default-max-frame-size 9216
!
router ospf
 area 0.0.0.0
!
interface loopback 1
 ip ospf area 0.0.0.0
 ip address 192.168.199.109/32
!
!
interface ethernet 1/11
 port-name to-Cisco
 enable
 ip ospf area 0.0.0.0
 ip address 192.168.204.69/30
 ip mtu 9198
!
router mpls
 mpls-interface e1/11
  ldp-enable
!


Cisco:
!
ip cef
!
mpls label protocol ldp
!
interface Loopback0
 ip address 192.168.206.53 255.255.255.255
!
interface Multilink100
 description MLPPP-to-Juniper-SRX
 bandwidth 3000
 ip address 192.168.204.73 255.255.255.252
 ip ospf 2495 area 0.0.0.0
 load-interval 30
 mpls label protocol ldp
 mpls ip
 ppp multilink
 ppp multilink links minimum 1
 ppp multilink group 100
 max-reserved-bandwidth 100
!
interface GigabitEthernet0/0
 description to-Brocade-XMR
 ip address 192.168.204.70 255.255.255.252
 no ip proxy-arp
 ip pim sparse-mode
 ip ospf 2495 area 0.0.0.0
 load-interval 30
 duplex full
 speed 1000
 mpls label protocol ldp
 mpls ip
 no cdp enable
!
interface Serial0/0/0:0
 description T1-to-SRX-1
 no ip address
 encapsulation ppp
 load-interval 30
 no fair-queue
 ppp multilink
 ppp multilink group 100
 max-reserved-bandwidth 100
!
interface Serial0/0/1:0
 description T1-to-SRX-2
 no ip address
 encapsulation ppp
 load-interval 30
 no fair-queue
 ppp multilink
 ppp multilink group 100
 max-reserved-bandwidth 100
!
router ospf 2495
 mpls ldp sync
 router-id 192.168.206.53
 log-adjacency-changes
 auto-cost reference-bandwidth 1000000
!
mpls ldp router-id Loopback0 force
!


Juniper:
interfaces {
    lsq-0/0/0 {
        unit 0 {
            description "MLPPP to Cisco 2821";
            encapsulation multilink-ppp;
            bandwidth 3k;
            family inet {
                address 192.168.204.74/30;
            }
            family mpls;
        }
    }
    t1-1/0/0 {
        unit 0 {
            description "T1 to Cisco 2821 1";
            family mlppp {
                bundle lsq-0/0/0.0;
            }
        }
    }
    t1-2/0/0 {
        unit 0 {
            description "T1 to Cisco 2821 2";
            family mlppp {
                bundle lsq-0/0/0.0;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 192.168.199.34/32;
            }
        }
    }
}
routing-options {
    router-id 192.168.199.34;
}
protocols {
    mpls {
        interface all;
    }
    ospf {
        reference-bandwidth 1000g;
        area 0.0.0.0 {
            interface lo0.0 {
                passive;
            }
            interface lsq-0/0/0.0;
        }
    }
    ldp {
        interface lsq-0/0/0.0;
        interface lo0.0;
    }
}
security {
    forwarding-options {
        family {
            mpls {
                mode packet-based;
            }
        }
    }
}


More information about the juniper-nsp mailing list