[j-nsp] Routed VLAN Interfaces on MX

Chuck Anderson cra at WPI.EDU
Fri Nov 13 16:42:34 EST 2015


Right, you aren't required to do bridging and IRB if all you want is a
layer 3 termination:

ae0 {
    flexible-vlan-tagging;
    encapsulation flexible-ethernet-services;
    unit 41 {
        vlan-id 41;
        family inet {
            address 1.1.1.2/30;
        }
    }
}

You can do the same on the EX side, or you can do a vlan l3-interface
on the EX side with the above on the MX side.

On Fri, Nov 13, 2015 at 01:31:41PM -0800, Michael Loftis wrote:
> If you don't need to switch the subintf at all you can just do...
> set int ae0 flexible-vlan-tagging
> set int ae0 .....
> set int ae0 unit 41 vlan-id family inet ....
> 
> instead of doing encap vlan-bridge on the unit 41 and all the other
> related bridge-domain stuff
> 
> 
> On Fri, Nov 13, 2015 at 1:12 PM, Josh Baird <joshbaird at gmail.com> wrote:
> > Hi,
> >
> > I apologize for the basic question as I'm a new Junos user.  I'm attempting
> > to convert the following basic config from a Cisco NPE-G1:
> >
> > interface GigabitEthernet0/3
> >  desc 'Physical link to EX'
> >
> > interface GigabitEthernet0/3.41
> >   encapsulation dot1q
> >   ip address 1.1.1.2/30
> >
> > On the MX, I am trying to configure an agg between the MX and other device
> > (EX), so this is the config that I have came up with:
> >
> > # interfaces
> > ae0 {
> >     flexible-vlan-tagging;
> >     encapsulation flexible-ethernet-services;
> >     aggregated-ether-options {
> >         lacp {
> >             active;
> >             periodic fast;
> >         }
> >     }
> >     unit 41 {
> >         encapsulation vlan-bridge;
> >         vlan-id 41;
> >     }
> > }
> >
> > # interfaces irb
> > irb {
> >     unit 41 {
> >         family inet {
> >             address 1.1.1.2/30
> >         }
> >     }
> > }
> >
> >
> > # bridge-domain
> > bridge-domains {
> >     vlan41 {
> >         vlan-id 41;
> >         interface ae0.41;
> >         routing-interface irb.41;
> >     }
> > }
> >
> > Does this configuration look correct?  Is all of this necessary?  I realize
> > there are several different ways to handle this in Junos.
> >
> > Thanks for any suggestions or input.
> >
> > Josh


More information about the juniper-nsp mailing list