[rbak-nsp] BGP inaccessible next-hop

Dave Bell me at geordish.org
Tue Dec 18 15:56:29 EST 2018


Thats odd that this doesn't work, but I guess a BGP route can't recurse to
a static route for some reason?

Try an inter-context interface instead. That seems to work.

context BGP

  interface int2 intercontext p2p 1
   ip address 10.0.0.1/30

  community-list REDIRECT
   seq 10 permit 65000:667

  route-map rm-in permit 200
   match community-list REDIRECT
   set ip next-hop 10.0.0.2

  route-map rm-out deny 10

   neighbor 192.168.12.184 external
     remote-as 65000
     address-family ipv4 unicast
       route-map rm-in in
       route-map rm-out out

  ip route 192.168.99.89/32 context FILTER

context FILTER

  interface int1
   ip address 192.168.99.89/30

  interface int2 intercontext p2p 1
   ip address 10.0.0.2/30

  ip route 0.0.0.0/0 192.168.99.90

Dave



On Tue, 18 Dec 2018 at 16:44, Łukasz Kopiszka <lukasz at alfa-system.pl> wrote:

> Hi,
>
> My lab config:
>
> context BGP
>
>   community-list REDIRECT
>    seq 10 permit 65000:667
>
>   route-map rm-in permit 200
>    match community-list REDIRECT
>    set ip next-hop 192.168.99.89
>
>   route-map rm-out deny 10
>
>    neighbor 192.168.12.184 external
>      remote-as 65000
>      address-family ipv4 unicast
>        route-map rm-in in
>        route-map rm-out out
>
>   ip route 192.168.99.89/32 context FILTER
>
> context FILTER
>
>   interface int1
>    ip address 192.168.99.89/30
>
>   ip route 0.0.0.0/0 192.168.99.90
>
>
> First step I'm marking IP 93.179.215.2 with community 6500:667
>
> BGP#show bgp route 93.179.215.2/32
> BGP ipv4 unicast routing table entry: 93.179.215.2/32, version 0
> Paths: total 1, best path count 0, best peer 0.0.0.0
> Not downloaded to RIB (no bestpath)
> Not advertised to any peer
>
> 65000
>    Nexthop 192.168.99.89 (inaccessible), peer 192.168.12.184
> (192.168.12.184), AS 65000
>    Origin IGP, localpref 100, med 0, weight 100, external
>    Community: 65000:667
>
> Problem:
> next-hop 192.168.99.89 is inaccessible
>
>
> Question:
> How can I solve issue with inaccessible next-hop to FILTER context?
>
>
> PS: IP 192.168.99.90/30 is interface on PC with running tcpdump but
> there is no incomming traffic.
>
>
> --
> Pozdrawiam,
> Łukasz Kopiszka
> http://alfa-system.pl
>
> _______________________________________________
> redback-nsp mailing list
> redback-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/redback-nsp
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://puck.nether.net/pipermail/redback-nsp/attachments/20181218/fc831357/attachment.html>


More information about the redback-nsp mailing list